Pergunta

VoIP MEO deixou de conseguir fazer chamadas em FreePBX

  • 2 February 2021
  • 76 respostas
  • 1983 visualizações

Crachá +2

Boas.

Tenho dois equipamentos muitos distintos com FreePBX (Versões do Asterisk e do FreePBX diferentes e equipamentos também muito diferentes) que não conseguem fazer chamadas.

No LOG aparece este erro:

chan_sip.c: Got SIP response 502 "Bad DNS Request 040351915" back from 194.65.2.241:5070

 

Em vez da chamada ser estabelecida ouve-se esta mensage:

“Lamentamos, mas neste momento não é possível estabelecer a sua chamada...”

 

Não funciona tanto para número 3020 como para outros números.

 

Testei configurar o número num X-Lite e funciona.

 

Alguém sabe qual é o problema?

Cumprimentos.


76 respostas

Crachá +1

Ora ca vai:

 

 registrar: sip.sapo.pt

username: +35130200XXXX

password: a que foi criada no portal da meo

realm: ims.telecom.pt (isto foi dificil de descobrir)

sip-server proxy: proxy.sip.sapo.pt:5070

 

 

Basicamente estas foram as configuracoes usadas no meu SBC. Estou neste momento a tentar configurar o servico de “CLIP no screening”, manipulacao de numeros de saida, vamos la ver se a meo suporta isto.

 

Alguma duvida é so dizerem.

 

cumprimentos

Crachá

Tenho exatamente o mesmo problema. tenho o numero configurado numa central ZYCOO e nunca tive problemas. recentemente tenho….

Se ligar para o numero voip por exemplo da operadora vodafone a chamada é recebida. Se ligar de um telemóvel MEO da chamada falhada. Se ligar para fora através do numero da voip MEO da sempre a mensagem referida, sem sucesso.

 

Só pode ser problema interno da MEO.

 

Abri uma avaria, aguardo resposta.

Realizar chamadas = OK
Receber Chamadas = “Tá quietoLiteralmente

Trunk:

[ General ]
Trunk Name : MEO
Hide CallerID: No
Outbound CallerID : +35130200XXXX
CID Options: Allow Any CID
Maximum Channels:
Asterisk Trunk Dial options:
                     System
continue if Busy: No
Disable Trunk: No
Monitor Trunk Failures: No


Sip Settings :
[Outgoing ]

Trunk Name : MeoOut
PEER Details:

username=+35130200XXXX
type=friend
t38pt_udptl=yes
secret=123456
registername=+35130200XXXX
qualify=yes
port=5060
outboundproxy=proxy.sip.sapo.pt:5070
insecure=port,invite
host=sip.sapo.pt
fromuser=+35130200XXXX
fromdomain=sip.sapo.pt
from=+35130200XXXX
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=yes
call-limit=2
authname=+35130200XXXX
allow=ulaw&alaw


[Incoming]

USER Context:

USER Details:

Register String: +35130200XXXX@sip.sapo.pt:123456:+35130200XXXX@proxy.sip.sapo.pt:5070/+35130200XXXX

Tenho configurado uma extensão em CHAN_SIP para usar como o ramal de realização e recebimentos de chamada mas só consigo realizar as chamadas.
Até já tentei criar uma extensão em CHAN_PJSIP, mas acontece o mesmo problema no recebimento das chamadas. Quando eu ligo para o meu NOMADA, não completa a chamada e no meu caso, não acontece nada nos Logs.

Já configurei a minha linha em um SIP Phone e funcionou a 100% (nenhuma novidade até aqui). Ao utilizar esse método, verifiquei o log da Firewall e percebi um caminho diferente no registo do trunk e o registo do SIP Phone.

No SipPhone o registo acontece no host: sip.sapo.pt (213.13.145.45) porta 5060 ou 5070 (depende de como configurar, funciona nas duas portas)

Configuração SIP Phone

Log da Firewall


No PBX o registo acontece no proxy.sip.sapo.pt porta 5070 (sempre) essa configuração é definida no register string.

Log da Firewall


Em ambas as situações, a comunicação RTP acontece no ip do proxy.sip.sapo.pt.
Já tentei alterar a register string para ver se conseguia fazer o mesmo caminho de registo, mas dá erro de password.
Register string de teste que Não funcionou +35130200XXXX@sip.sapo.pt:123456:+35130200XXXX@sip.sapo.pt:5060/+35130200XXXX

Alguém que tenha as chamadas de entrada a funcionar, há alguma configuração extra a realizar?
Obs.: Não utilizar a Register String de teste, pois não funciona.

Crachá +2

Bom dia.

Eu nem percebo o que é que o erro tem a ver com DNS, eu verifiquei e em ambos os sistemas o nomes resolvem correctamente para o mesmo IP:
sip.sapo.pt.            202     IN      A       213.13.145.45
proxy.sip.sapo.pt.      103     IN      A       194.65.2.241

 

Ao contrário do que o @Andre_Maia disse, estamos a usar DNS: ao usar um nome de servidor, o serviço de DNS é invocado para o converter num IP que é usado no final para estabelecer a comunicação.

No entanto não acredito que o nosso problema seja de DNS porque até no log aparece um IP e não um nome de servidor e além disso para todos os efeitos a chamada é feita com sucesso a única coisa é que em vez de ser ligada ao destino pretendido é ligada a uma gravação que diz “não é possível estabelecer a sua chamada ”.
É possível que a siglna DNS queira dizer outra coisa diferente no VoIP? Ou que haja verificações efectuadas por DNS que vão além da resolução de nomes?

 

PS: fui novamente contactado pela MEO por causa desta avaria e dizem que não detetam nada.

Quando tiver uns minutos já vou configurar a conta na minha GigaSet IP e ver se também funciona como no X-Lite.

 

Entretanto tive uma ideia relacionada com os DNS que vou explorar, depois dou notícias.

 

Cumprimentos.

Boas,

 

Continuamos com o mesmo problema de sempre, a altice decide alterar alguma configuração interna e não avisa ninguém…..

Desde 2012 que ciclicamente vão aparecendo alguns problemas com as ligações voip a centrais, nunca é problema deles e dado que são equipamentos particulares não existe qualquer suporte da parte deles… aceitável não fosse o facto de não existir nenhuma alteração e o serviço deixa de funcionar parcialmente… chamadas de outros operadores entram sem problemas, só originadas na rede altice, fixo ou móvel não se consegue receber… 

 

P:S. acabei por ter de mudar de operador voip, mas ainda tenho 2 números da altice para backup que neste momento é como se não tivesse nada…

 

Continuando a despistar, os logs para ver qual foi a alteração da altice !….

 

 

 

Crachá +1

Pena este tópico estar morto….

Crachá

Espero que consigas obter reposta, por que a nós, só nos disseram que da parte deles está tudo bem.

Cumprimentos

Boa noite,

Efetivamente e após 15 dias de abertura do ticket nada foi feito por parte da MEO para resolver o problema.

Como já foi referido anteriormente, este problema está a acontecer em sistemas/centrais ASTERISK, o que penso ser a esmagadora maioria de casos.

 

Esta situação e tão ridícula que eu tenho o numero registado com sucesso, consigo receber chamadas de alguns telefones da rede fixa, testei com um numero de uma empresa e funcionou, testei com um numero residencial já não funcionou, se ligar de telemóvel da rede MEO não funciona, se ligar por exemplo do operador 91 recebo a chamada perfeitamente, e não consigo fazer nenhuma chamada do numero voip.

 

Registei o mesmo numero num telefone voip e não tive qualquer problema.

 

das duas uma ou a MEO fez alterações que ficou a provocar inadvertidamente este problema, e assim sendo pelo tempo e pela inação de resolução do problema, demonstra amadorismo, o que é muito mau em  meu entender para uma empresa como a MEO, ou então esta situação e propositada para sistemas ASTERISK o que ainda é pior porque trata-se de uma decisão unilateral da MEO alterar uma funcionalidade que em lao nenhum a MEO informa que os números 30, não podem ser usados em sistemas ASTERISK.

 

dado que a MEO nem sequer se digna a responder ao meu ticket, vou abrir uma reclamação no portal da queixa sobre esta situação. Sei que será só mais uma  nas milhares que a MEO tem, mas o apelo que eu faço a todos os lesados e que reclamem também e desta forma não será apenas uma mas garantidamente algumas milhares.

 

Esta situação até se pode enquadrar em meu entender publicidade enganosos por parte da MEO.

Apresenta um serviço onde diz que pode ser registado o numero em outro equipamento que não da MEO e o mesmo neste momento com esta situação não está a corresponder à verdade.

 

 

 

Reputação 7
Crachá +21

@marco75 

 

Apaguei-lhe o secret. que por algum eventual lapso deixou no post ;) 

Crachá +1

Espero que consigas obter reposta, por que a nós, só nos disseram que da parte deles está tudo bem.

Cumprimentos

Olá a todos,

 

Aqui confirmo o mesmo.

Há 2 meses que tenho vindo a fazer despistes, mas agora vejo que a minha suspeiçao é efetiva. Deixei de conseguir usar o número nómada. Ele regista, mas depois não é aceite no proxy. Ou seja, não se consegue efetuar ou receber chamadas. A chamada entra no PBX e cai.

Criei várias máquinas para teste em Portugal, França e Inglaterra. Usei base Asterisk e Freeswitch. Em todos o mesmo resultado. Apenas funciona com softphones.

O suporte não passou qualquer feedback. Depois de apresentar dados mais técnicos passaram a chamada, passaram a chamada e nunca mais contactaram.

É cada vez mais claro. Foi introduzido um barramento. O mais provável é que estejam a impedir que se utilizem serviços de EPBX não adquiridos à empresa. 

Estamos a analisar outras ofertas de operadores onde tudo funcione bem e migrar para lá todas as contas da empresa. Entretanto iremos também proceder a uma reclamação no livro.

Crachá +1

Boas @CidiRome, por aqui o problema continua e sinceramente já nao sei que mais possa fazer.
Ja alterei configurações para experimentar e nada.

Assim que puderes comenta como foi o resultado na Gigaset ip sff

Crachá +2

Boas.

Testei na Gigaset A580IP e funciona (leva bastante mais tempo a estabelecer a chamada, mas acaba por fazer).

As configurações de trunk que uso são (exactamente iguais a um sistema que tenho num acesso MEO que funciona bem):

username=+3513020xxxxx
type=friend
secret=secret_password
registername=+3513020xxxxx
qualify=yes
port=5070
nat=force_rport,comedia
insecure=very
host=proxy.sip.sapo.pt
fromuser=+3513020xxxxx
fromdomain=sip.sapo.pt
dtmfmode=rfc2833
disallow=all
context=from-pstn
canreinvite=yes
call-limit=2
authname=+3513020xxxxx
auth=+3513020xxxxx:secret_password@sip.sapo.pt
allow=ulaw&alaw

 

Registry String: +3513020xxxxx@sip.sapo.pt:secret_password:+3513020xxxxx@proxy.sip.sapo.pt:5070/+3513020xxxxx

Cumprimentos.

Crachá +1

já consegui descobrir o problema com o meu freepbx tinha um problema no DNS server. Ainda assim só consigo realizar chamadas e continuo sem conseguir receber. Anexo aqui o log caso alguém saiba como resolver isto, sff. O telefone não chega a tocar quando me ligam mas o número que me está a tentar ligar fica registado no log. Logo acho que é algo que está a impedir a ligação a ser feita à minha extensão.

 

[2021-07-28 23:06:52] NOTICE[1339][C-00000006] chan_sip.c: From address missing 'sip:', using it anyway

2[2021-07-28 23:06:52] ERROR[1339][C-00000006] chan_sip.c: Empty domain name in FROM header

3[2021-07-28 23:06:52] NOTICE[1339][C-00000006] chan_sip.c: Unexpected error for device tel:XXXXXXXXXtag=p65539t1627510012m713297c50654s1_875381070-269987270 for INVITE, code = -100

Reputação 1
Crachá +5

Caros colegas, não sei se a vossa situação será identica à minha mas eu também deixei de poder fazer chamadas no meu freepbx (a correr num Rpi). após alguns testes, como já tinha sido dito aqui, a conta sip funciona perfeitamente num telefone ip ou num softphone, no entanto no freepbx, nada de chamadas de saída, apenas o “lamentamos...”.

consegui resolver a minha situação criando 2 trunks, um para in e outro para out. a unica diferença na configuração entre os dois é que no in o host=proxy.sip.sapo.pt (ou proxy.ims.iptv.telecom.pt), enquanto no out o host=sip.sapo.pt. desta forma fico com 2 ip peers e tem funcionado bem até agora, a ver vamos se se revela estável.

 

Na realidade, penso que o problema não está no operador, mas em nós clientes, que estamos a tentar usar uma sip line como um sip trunk….

Reputação 1
Crachá +5

@biomedica  tenta: retiraport=5070 e colocar outboundproxy=proxy.sip.sapo.pt:5070

Crachá

Nevermind. Descobri um bug no freeswitch. Parece ser disso, vou tentar resolver agora que sei para onde olhar.

Obrigado

Crachá +1

Nao usamos DNS, usamos é estes parametros outboundproxy=proxy.sip.sapo.pt e host=proxy.sip.sapo.pt

Crachá

Também estou a tentar configurar na grandstream no telemóvel e no zoiper no pc. Já os tive a funcionar há 1 ano. Hoje não consigo nada.

Crachá +1

@CidiRome , conseguiste chegar a mais alguma conclusão? Ja experimentei de varias formas e alterando alguns parametros e o resultado é o mesmo. Ate foi notificado que está a dar problema nas chamadas entrantes, so a partir de alguns telemoveis funciona, de fixos diz que nao é possivel ligar para o número.

Crachá +1

vocês conseguem também receber chamadas usando o freepbx? eu não estou a conseguir...

Crachá +1

Bom dia, visto que esta não há solução por parte da Meo para este problema, alguem consegue dizer-me outros operadores voip que conheçam e estejam a funcionar bem e que valha a pena mudar?

 

Crachá +2

Não fiz mais nada.
Não uso o número para receber chamadas, mas nos testes que fiz está a funcionar.

Estou à espera da análise deles.
Tenho que ver se consigo testar um destes sistemas noutro acesso internet: por exemplo, testar o sistema MEO que está a funcionar num acesso NOS.

Crachá +2

Boas.

Em resposta ao jmramalho:
Tenho um telefone GrandStrem em que configurei a conta Sapo e funcionou bem. Também configurei hoje para testar novamente numa Gigaset IP e funcionou bem. Talvez não tenha as configurações bem.

O problema permanece tal e qual nos FreePBX.

 

Em resposta ao Andre_Maia, eu uso e tenho a Lets Call e a G9 em alguns clientes até ver sem grandes problemas. Se quiser fazer contrato, eu posso fazer propostas e dar esclarecimentos.

Cumprimentos.

Crachá +1

Bom dia @marco75 , tentei fazer como disseste e não consegui. quando tento fazer uma chamada out aparece a dizer “all services are busy now”. 

podes colar aqui a configuração que tens para cada trunk sff?

Reputação 1
Crachá +5

Boas. tenho um rasp a correr freepbx e estou com o mesmo problema: regista o peer aparece mas nas chamadas de saida “lamentamos mas neste momento não foi possível estabelecer a sua chamada”. alguém já sabe porque está a acontecer e/ou como resolver.

Responder