Tutorial pfSense

Tutorial pfSense

Novo Membro kxtreme
Novo Membro

Re: Tutorial pfSense

Bom dia segui os passos e tenho internet e televisão a funcionar mas falta colocar o voip pois esse necessita do router da meo para isso alguma sugestão?
Visitante Sénior JPatriarca
Visitante Sénior

Re: Tutorial pfSense

Para isso terás sempre que utilizar o Thomson. E podes fazê-lo de duas formas: ou colocas uma porta do pfsense, se a tiveres, em bridge para ligar ao Thomson e ele apanhar IP público ou colocas um switch entre o ONT e o pfsense e Thomson.

 

Desta forma tens IP público quer no Thomson quer no pfsense e ficas com VoIP.

Novo Membro kxtreme
Novo Membro

Re: Tutorial pfSense

Isso funciona, após testes verifiquei que o melhor layout será colocar tanto o router como a PFSence, com IP Público por detrás de um switch e colocar o DHCP Server a dar à televisão como gateway o router da Meo visto que mesmo com IGMP proxy tinha queixas de paragem de televisão, ou seja ter 2 gateways LAN um da Meo outro da PFSence e o DHCP com um range que apanhe o router da Meo e a Lan e dar ip Lease à TV. de resto é peanuts.

Visitante Sénior JPatriarca
Visitante Sénior

Re: Tutorial pfSense

A configuração por mim sugerida permitia que o router meo e o pfsense funcionassem de forma autónoma sem qualquer conflito. Se tens paragens no iptv com a box ligada no pfsense então ou não tens hardware suficiente para gerir ou tens alguma configuração errada.

 

Relembro que, por LAN, o router da meo e o pfsense não devem estar interligados e devem trabalhar de forma independente. Se interligas tudo, há dois gateways de saida e dois IGMPproxy na rede o que vai criar colisões na rede interna que pode causar os problemas que descreves

Visitante Sénior mrc-core
Visitante Sénior

Re: Tutorial pfSense

Bom dia.

 

No PFSense em relação ao IPTV consigo colocar a dar a imagem sem bloqueios após algumas tentativas.

O problema é que quando reinicio o PFSense o IPTV deixa de dar. Começa logo com os bloqueios após 10 segundos. Posso reiniciar a MEO box mas o problema continua.

 

Alguém tem este problema? Sabe como dar a volta a este problema?

Já fiz vários reboots a box e ao PFSense e mesmo assim não consigo ficar com a imagem a dar sem bloqueios.

Visitante Sénior JPatriarca
Visitante Sénior

Re: Tutorial pfSense

E quais são as tentativas que fazes até repores o IPTV?

 

se tens freeze na imagem é porque o serviço do igmpproxy não está a arrancar ou as regras configuradas não estão corretas.

 

verifica se, quando fazes reboot se o serviço do igmpproxy arranca corretamente. Verifica e interpreta o log da firewall para verificar que erros tens.

Visitante Sénior mrc-core
Visitante Sénior

Re: Tutorial pfSense

Acabo por fazer vários reboots tanto ao pfsense como a box...

 

Mas já estive a ver os logs da firewall e quando faço restar service igmpproxy obtenho este resultado:

Dec 7 10:32:43 igmpproxy 47113 select() failure; Errno(4): Interrupted system call
Dec 7 10:32:43 php-fpm 58349 /status_services.php: Started IGMP proxy service.

 

Em relação ao setup do igmp tenho o seguinte:

WAN upstream 194.65.46.0/23, 10.173.0.0/16, 213.13.16.0/20, 213.13.19.0/20, 213.13.19.177/20, 224.0.0.0/4 IPTV   
LAN downstream 232.0.0.0/8

IPTV 

 

Quanto as regras tenho o seguinte na WAN:

2017-12-07 (2).png

 

A ideia que fico é que o igmproxy não esta a arrancar

Visitante Sénior JPatriarca
Visitante Sénior

Re: Tutorial pfSense

Não estou a ver outra solução senão reinstalar o igmpproxy e respectivas regras e verificar se o serviço começa a arrancar. 

 

Isso é um problema de PfSense

Highlighted
Visitante Sénior mrc-core
Visitante Sénior

Re: Tutorial pfSense

Numa das pesquizas que fiz vi que ouve quem criase uma interface só para o IPTV, colocan do uma regra para abrir a passagem da rede 224.0.0.0/4 em UDP e depois no igmp setup no dowstream mudam a interface lan para esta nova interface. Já tentei mas também não da. 

O mais estranho mesmo é que por exemplo posso reiniciar o pfsense umas 30 vezes e nao dar mas a 31 vez que reiniciar já começa a dar imagem na box sem bloqueios. Depois se fizer um reboot ou faltar a luz volto a ficar sem imagem...