Pergunta

VoIP MEO deixou de conseguir fazer chamadas em FreePBX

  • 2 February 2021
  • 75 respostas
  • 1777 visualizações

Crachá +2

Boas.

Tenho dois equipamentos muitos distintos com FreePBX (Versões do Asterisk e do FreePBX diferentes e equipamentos também muito diferentes) que não conseguem fazer chamadas.

No LOG aparece este erro:

chan_sip.c: Got SIP response 502 "Bad DNS Request 040351915" back from 194.65.2.241:5070

 

Em vez da chamada ser estabelecida ouve-se esta mensage:

“Lamentamos, mas neste momento não é possível estabelecer a sua chamada...”

 

Não funciona tanto para número 3020 como para outros números.

 

Testei configurar o número num X-Lite e funciona.

 

Alguém sabe qual é o problema?

Cumprimentos.


75 respostas

Crachá +2

Boas.

Estive a olhar para o Log do FreePBX e o erro “ Bad DNS Request” só aparece no final da chamada ser desligada, já depois de se ter ouvido a mensagem “Lamentamos, mas neste momento não é possível estabelecer a sua chamada...” .

E não há nenhum erro óbvio no log até esse momento.

Isto pode querer dizer que para o FreePBX a chamada se estabeleceu correctamente, apenas o sistema do Sapo/MEO está a negar a chamada por alguma razão.

 

Ideias?

Crachá +1

Bom dia, eu estou exatamente igual. Liguei para a PCmedic disseram que era problema da Meo.
Quando liguei para o apoio tecnico da Meo, referiram nao ter qualquer conhecimento sobre esta causa mas que iriam reportar o problema e até à data continuo sem resposta

Crachá +2

Eu Abri uma avaria na MEO e fui contacto há pouco.

O operador foi bastante rude e disse que não detectava problema nenhum.

 

Entretanto estive a analisar os registos e verifico que em ambos os sistemas que estão a dar problemas não tinha aparecido a mensagem "chan_sip.c: Got SIP response 502 "Bad DNS Request 040351915" back from 194.65.2.241:5070". A primeira vez que apareceu foi no dia 2 de Fevereiro.
Além disso, apesar de não ter testado directamente, tudo indica que num terceiro sistema a Trunk do MEO esteja a funcionar correctamente, a única diferença é que esse sistema está ligado num Acesso Fibra da MEO e o outros dois estão em acessos da NOS.
É possível que a MEO esteja a fazer bloqueio a FreePBX/Asterisk cujo IP não seja MEO.

 

Cumprimentos.

Crachá +1

Duvido que seja bloqueio para IP que nao seja da Meo, porque eu testei tambem no x-lite na rede nós, inclusive, numa IP de espanha e deu sem problema. O problema esta mesmo na configuraçao feita no freepbx

Crachá +2

Eu testei no X-Lite (do mesmo acesso que o FreePBX) e funcionou.

No entanto do FreePBX no mesmo IP não funciona (onde sempre funcionou até este dia 2).

Entretanto já confirmei que o outro sistema num acesso MEO que tenho também com um RasPBX (que é idêntico a uma dos dois primeiros) consegue fazer chamadas sem problemas.

Que é estranho, é.

Crachá +1

Será que nao ha aqui ninguem da Meo que nos consiga ajudar neste sentido?

Crachá +1

@CidiRome , conseguiste chegar a mais alguma conclusão? Ja experimentei de varias formas e alterando alguns parametros e o resultado é o mesmo. Ate foi notificado que está a dar problema nas chamadas entrantes, so a partir de alguns telemoveis funciona, de fixos diz que nao é possivel ligar para o número.

Crachá +2

Não fiz mais nada.
Não uso o número para receber chamadas, mas nos testes que fiz está a funcionar.

Estou à espera da análise deles.
Tenho que ver se consigo testar um destes sistemas noutro acesso internet: por exemplo, testar o sistema MEO que está a funcionar num acesso NOS.

Crachá +1

Conseguiste ter resposta da parte deles? A mim ainda nao me disseram nada e o problema continua..

Reputação 7
Crachá +23

"chan_sip.c: Got SIP response 502 "Bad DNS Request 040351915" back from 194.65.2.241:5070".

 

Isso deverá problema de configuração. Como é uma aplicação freeware, acho que a MEO não vai conseguir ajudar. As contas voip estão a funcionar

 

Crachá +1

Boas @OmicronPersei8 , mas algo deve ter mudado na configuração deles, porque ate ha uns dias sempre funcionou corretamente, so agora é que deixou de dar

Reputação 7
Crachá +23

Boas @OmicronPersei8 , mas algo deve ter mudado na configuração deles, porque ate ha uns dias sempre funcionou corretamente, so agora é que deixou de dar


Sim eu reparei no comentário inicial. Poderá é ter sido alterado algum parâmetro. O que sei é que via app móvel o voip está operacional. Usa algum DNS na configuração voip?

Crachá +1

Nao usamos DNS, usamos é estes parametros outboundproxy=proxy.sip.sapo.pt e host=proxy.sip.sapo.pt

Crachá +2

Bom dia.

Eu nem percebo o que é que o erro tem a ver com DNS, eu verifiquei e em ambos os sistemas o nomes resolvem correctamente para o mesmo IP:
sip.sapo.pt.            202     IN      A       213.13.145.45
proxy.sip.sapo.pt.      103     IN      A       194.65.2.241

 

Ao contrário do que o @Andre_Maia disse, estamos a usar DNS: ao usar um nome de servidor, o serviço de DNS é invocado para o converter num IP que é usado no final para estabelecer a comunicação.

No entanto não acredito que o nosso problema seja de DNS porque até no log aparece um IP e não um nome de servidor e além disso para todos os efeitos a chamada é feita com sucesso a única coisa é que em vez de ser ligada ao destino pretendido é ligada a uma gravação que diz “não é possível estabelecer a sua chamada ”.
É possível que a siglna DNS queira dizer outra coisa diferente no VoIP? Ou que haja verificações efectuadas por DNS que vão além da resolução de nomes?

 

PS: fui novamente contactado pela MEO por causa desta avaria e dizem que não detetam nada.

Quando tiver uns minutos já vou configurar a conta na minha GigaSet IP e ver se também funciona como no X-Lite.

 

Entretanto tive uma ideia relacionada com os DNS que vou explorar, depois dou notícias.

 

Cumprimentos.

Crachá +1

Boas @CidiRome, por aqui o problema continua e sinceramente já nao sei que mais possa fazer.
Ja alterei configurações para experimentar e nada.

Assim que puderes comenta como foi o resultado na Gigaset ip sff

Reputação 7
Crachá +23

@Andre_Maia Conseguia partilhar uma captura de ecrã (escondendo ou borrando o(s) número(s) voip e passwords) de forma a compreender como estão os campos e configurações?. O que sei é que o freepbx tem um nível de funcionalidades e opções que não são como nas app’s móveis. 

Crachá +2

Boas.

Testei na Gigaset A580IP e funciona (leva bastante mais tempo a estabelecer a chamada, mas acaba por fazer).

As configurações de trunk que uso são (exactamente iguais a um sistema que tenho num acesso MEO que funciona bem):

username=+3513020xxxxx
type=friend
secret=secret_password
registername=+3513020xxxxx
qualify=yes
port=5070
nat=force_rport,comedia
insecure=very
host=proxy.sip.sapo.pt
fromuser=+3513020xxxxx
fromdomain=sip.sapo.pt
dtmfmode=rfc2833
disallow=all
context=from-pstn
canreinvite=yes
call-limit=2
authname=+3513020xxxxx
auth=+3513020xxxxx:secret_password@sip.sapo.pt
allow=ulaw&alaw

 

Registry String: +3513020xxxxx@sip.sapo.pt:secret_password:+3513020xxxxx@proxy.sip.sapo.pt:5070/+3513020xxxxx

Cumprimentos.

Crachá +2

Actualização muito importante.

 

O sistema que eu tenho no acesso MEO já começou a dar o mesmo problema.

Sendo é assim é plausível que este problema comece a aparecer como cogumenlos em outros utilizadores de FreePBX.

 

Cumprimentos.

Crachá +1

Entao achas que o problema está mesmo no Freepbx @CidiRome ?

Crachá +2

É difícil dizer.
Eu vou mais por uma qualquer alteração deles que não foi imediata para todos os clientes.
Também é possível que tenha havido alguma alteração no FreePBX, mas teria que ser mesmo no FreePBX ou respectivos módulos, porque a nível do Asterisk não há actualizações automáticas.

Ainda assim, tenho trunks de outros 3 operadores a funcionar correctamente e só o do Sapo é que está a dar problemas.

Cumprimentos.

Crachá +1

Pois eu acho que sinceramente isto é um problema da Meo/Sapo, porque até agora sempre funcionou.
Eu verifiquei e nao exisitiu nenhuma alteraçao no Freepbx em termos de módulos

Crachá +2

Fiz mais um teste:

Coloquei nas configurações os IPs dos servidores em vez dos nomes e dá erro de autenticação:
chan_sip.c: Received response: "Forbidden" from '<sip:+3513020xxxxx@213.13.145.45>;tag=xxxxxxx'

Penso que o servidor obriga os pedidos a irem com o nome do servidor e não admitem o IP…

(Há vários erros diferentes consoante se trate do registo ou de uma tentativa de chamada)

Cumprimentos.

Crachá +1

Boas, conseguiste chegar a mais alguma conclusao?  agora já nem consigo receber chamadas nao sei por que. Ha uns dias recebia de alguns numeros e de outros nao, agora já nem da para ligar

Crachá +2

Boas.
Para mim continua tudo igual:
- Consigo receber;
- Não consigo fazer com a mensagem “Lamentamos, mas de momento….” e com o erro no log «chan_sip.c: Got SIP response 502 "Bad DNS Request 040351915" back from 194.65.2.241:5070»

 

Visto que tenho 3 sistemas* distintos com o mesmo problema, não pode ser problema só meu.

* 2 RasPBX e 1FreePBX em equipamento x64 Intel com Sistema Operativo CentOS.

 

Cumprimentos.

Crachá +1

Bom dia, ja consegui fazer com que as chamadas entrem normalmente, mas para fazer continuo exatamente com o mesmo problema, nao é permitido.

 

Responder