vpn pptp router meo fibra tg784n v3

  • 12 Julho 2013
  • 16 respostas
  • 10547 visualizações

Viva,

Tenho um acesso fibro e foi instalado o novo tg784n v3,

Agora necessito de ter acesso remoto e para tal tenho um raspberry pi com um pptp server configurado e ja testado a funcionar 100% quando estou dentro da rede.

Entretanto reencaminhei o ipp do raspberry para o pptp 1273 e udp 500.. mas não consigo aceder de fora...
Ja tentei colocar o raspberry como dmz mas mesmo assim ele não responde.

Entretanto ja li umas coisas contraditorias referente ao GRE... em alguns locais dizem para abrir o porto udp 47 outros dizem que o tg784n v3 não vem com o GRE apontado para a lan...

Que devo eu fazer?

Podem ajudar?

16 respostas

Reputação 6
Viva,

Tenho um acesso fibro e foi instalado o novo tg784n v3,

Agora necessito de ter acesso remoto e para tal tenho um raspberry pi com um pptp server configurado e ja testado a funcionar 100% quando estou dentro da rede.

Entretanto reencaminhei o ipp do raspberry para o pptp 1273 e udp 500.. mas não consigo aceder de fora...
Ja tentei colocar o raspberry como dmz mas mesmo assim ele não responde.

Entretanto ja li umas coisas contraditorias referente ao GRE... em alguns locais dizem para abrir o porto udp 47 outros dizem que o tg784n v3 não vem com o GRE apontado para a lan...

Que devo eu fazer?

Podem ajudar?

Boas

Penso que isto pode ajudar , tens de remover as binds da porta 500 que vêm por defeito no router .

vê aqui VPN Problem
Usa o primeiro ou o segundo método apenas

Tens de executar esses comandos via telnet com privilégios de root user .
Ou editando o ficheiro user.ini que é criado quando salvas as configurações do router , também tens de ter privilégios de rootuser.

se não souberes como obter root usar para user via telnet ou para fazer o backup do user.ini .

vê aquihttp://www.meoforum.com/meo-fibra/meo-fibra-internet/4179-como-criar-um-rootuser-aceder-telnet-firmware-10-2-1-d

se tiveres duvidas avisa
Viva,

Será que este metodo resulta com o firmware 10.2.1.D ?

Que firmware tens no teu?

obrigado
Reputação 6
Viva,

Será que este metodo resulta com o firmware 10.2.1.D ?

Que firmware tens no teu?

obrigado

Boas

Sim esse foi o método que usei no meu thomson TG784n V3 com o fw:10.2.1.D , mas funciona com todos os routers com o firmware 10.2.1.D , firmwares anteriores têm outro método
Não estou a ter muita sorte...
Reputação 6
Não estou a ter muita sorte...

Boas
O que é que não estas a conseguir fazer ?
Viva,
segui o que indicaste criei um Rootuser.
entrei en telnet com o mesmo e dei os comandos de telnet, mas a porta aparece sempre fechada.

eu ja me liguei dentro da lan no raspberry em pptp fora não consigo.

ja começo a duvidar da config do raspberry.

o problema é que ele está a 160km de mim...
Amanha com a ajuda de um primo meu vou testar em criar a ligação sem o raspberry . vou configurar um pc para fazer de servidor pptp.

obrigado
Reputação 6
Viva,
segui o que indicaste criei um Rootuser.
entrei en telnet com o mesmo e dei os comandos de telnet, mas a porta aparece sempre fechada.

eu ja me liguei dentro da lan no raspberry em pptp fora não consigo.


ja começo a duvidar da config do raspberry.

o problema é que ele está a 160km de mim...
Amanha com a ajuda de um primo meu vou testar em criar a ligação sem o raspberry . vou configurar um pc para fazer de servidor pptp.

obrigado

boas
Tens de abrir as partas manualmente na pagina do router .


Ps o Loopback pode não estar a funcionar corretamente por isso é que só consegues aceder via rede local e não via internet .

Eu estou a usar o asus a gerir a internet e consigo aceder ao meus serviços de teamspeak servidores de jogos etc.. via ip de rede local via ip publico e via ddns sem problemas .

Usares outro router pode ser a solução mais fácil , visto que há muitos problemas e limitações nos routers das operadoras.
Viva,

Quando testo no pc estou sempre a ter erro de ligação 807...

Ontem ja pensei nisso de colocar um router a fazer a gestão da net...
Que asus estás a usar? com firmware de origem ou dd-wr ?

Obrigado
Abraço
Sobre o erro 807

"Microsoft error codes doesn't really tell you what's wrong. A error code 807 typically is either the client or the server is behind a NAT device and does not pass through GRE protocol 47. If GRE protocol 47 isn't pass through the NAT device you'll get 807. you'll also get 807 if port 1723 isn't forwarded from the NAT device to the VPN server if the server is behind a NAT device. VPN servers usually have packet filters which restrict inbound connection to only PPTP or L2TP. "

Fiz um teste basico... telnet o_meu_dyndns.dyndns.org 1723

e ele não permite ligar.. mas fico novamente na duvida se o problema é mesmo do router ou do raspberry pi.

quando faço um teste no Open Port Check Tool - Test Port Forwarding on Your Router

Recebo : Port 1723 is closed on o_meu_dyndns.dyndns.org ou filtered...

vou tentar ver como se comporta com um pc mesmo...

Thks!"
Reputação 6
Sobre o erro 807

"Microsoft error codes doesn't really tell you what's wrong. A error code 807 typically is either the client or the server is behind a NAT device and does not pass through GRE protocol 47. If GRE protocol 47 isn't pass through the NAT device you'll get 807. you'll also get 807 if port 1723 isn't forwarded from the NAT device to the VPN server if the server is behind a NAT device. VPN servers usually have packet filters which restrict inbound connection to only PPTP or L2TP. "

Fiz um teste basico... telnet o_meu_dyndns.dyndns.org 1723

e ele não permite ligar.. mas fico novamente na duvida se o problema é mesmo do router ou do raspberry pi.

quando faço um teste no Open Port Check Tool - Test Port Forwarding on Your Router

Recebo : Port 1723 is closed on o_meu_dyndns.dyndns.org ou filtered...

vou tentar ver como se comporta com um pc mesmo...

Thks!"



Boas

Se estas a ter esses problemas com a nat o melhor é mesmo comprares outro router para gerir a internet e deixares o thomson só a gerir a iptv e o telefone , infelizmente quando da problemas de nat no thomso n não há muito fazer .
Que router recomendas?

Não queria ir por esse caminho uma vez que comprei o raspberry pi para esse fim... mas se a solução passa por ai...

será que o suporte 16200 pode dar alguma ajuda?

obrigado
e boa semana!
Reputação 6
Que router recomendas?

Não queria ir por esse caminho uma vez que comprei o raspberry pi para esse fim... mas se a solução passa por ai...

será que o suporte 16200 pode dar alguma ajuda?

obrigado
e boa semana!

Boas
Eu uso o asus rt-n16 e estou satisfeito com ele, mas podes usar qualquer uma da gama asus com chip Broadcom , podes encontrar os vários modelos e características neste site
Asus routers - Wikipedia, the free encyclopedia

o 16200 muito dificilmente te vai poder ajudar mas podes tentar

ps: normalmente recomendo asus por terem um interface amigo do utilizador , simples e intuitivo , fácil de configurar , a nível de hardware nada a apontar .
Pelo preço quase que sou tentado a ir para um Mikrotik Router RB2011UAS-2HnD-IN ...
Reputação 6
Pelo preço quase que sou tentado a ir para um Mikrotik Router RB2011UAS-2HnD-IN ...

Boas
É uma excelente opção , sem duvida um brinquedo que também não me importava de ter.

Mas embora exista muita documentação e tutoriais disponíveis , não é simples de configurar , para o utilizador comum o asus é mais amigo do utilizador .

Mas é sem duvida uma boa escolha para quem quiser brincar um pouco :biggrin:?.
Acho que vale a pena..

Alem do mais ja tem 10 portas de lan 5gigabit e mais 5 de 10/100. e uma é poe...


é uma boa escolha! devo mandar vir da landashop. penso que é o local mais barato pelo que ja vi.
Problema resolvido!

Reset de fabrica, configuração de raiz.

Só atribui o pptp ao servidor de pptp e ficou ok...

Aparentemente a config do raspberry estava a bloquear o serviço e o router testei com NAs qnap e ficou tudo logo ok!

obrigado a todos pela Ajuda e pelas ideias!

Responder