Resolvido

VoIP Nómada, mudança de plataforma de serviço > reconfiguração

  • 8 Outubro 2018
  • 48 respostas
  • 5240 visualizações

Reputação 2
Serviço VOIP Nómada > reconfiguração de acesso


 


Devido a migração de plataforma técnológica e dada a necessidade de reconfiguração dos acessos VoIP Nómada a partir de 8 de outubro de 2018, os clientes que tiverem números VoIP Nómada ativos (3020xxxxx) deverão efetuar os seguintes passos:



a) Dirigir-se à sua Área de Cliente (e.g https://cliente.meo.pt ) e entrar na gestão do seu pacote em [NET FIXA[ e [Números VOIP] > [gerir]


encontrará a seguinte mensagem:



Voz sobre IP (VoIP):


Por atualização tecnológica a partir de 08/10/2018 para poder continuar a utilizar o serviço deverá alterar a password e configurar novamente os seus dispositivos, consultando a Ajuda e suporte do site MEO - Como posso configurar o VoIP? (https://www.meo.pt/ajuda-e-suporte/produtos-meo/internet/servicos#utilizarvoip), se já o fez o seu serviço está a funcionar corretamente para efetuar e receber chamadas. Com o VoIP pode fazer e receber chamadas dentro e fora de casa, para todas as redes nacionais e internacionais usando a internet.



b) Consultando a Ajuda e Suporte no link acima indicado poderá obter mais informação sobre a configuração dos seus dispositivos, mais concretamente a saber:



Dados de configuração nas aplicações VoIP:


Endereço Registar (Host): sip.sapo.pt [porta: opcional 5070]
Endereço Proxy (Outbound Proxy): proxy.sip.sapo.pt
Porta Proxy: 5070
Utilizador (Username): +3513020xxxxx(*)
Password: [de 6 a 8 carateres]
Transporte Rede (Network Settings): UDP [opcional]
SIP URL: +3513020xxxxx (*)
(*) Número VoIP criado.


 


Pode fazer e receber chamadas VoIP através de:


-Uma rede WiFi de acesso à internet;
-Uma rede de dados móveis 4G.



Os preços e condições mantém-se inalterados, ver em: https://www.meo.pt/ajuda-e-suporte/produtos-meo/internet/servicos#voip



Em anexo, podem encontrar imagens de configuração de área de cliente MEO e de aplicações para smartphone (CSIP SImple e Zoiper).
icon

Solução por gilaraujo 16 Outubro 2018, 18:20

Caro Herique, era mesmo essa a situação.

Confirmo que consigo fazer chamadas apenas mudando a linha


outboundproxy=proxy.sip.sapo.pt -> para  -> outboundproxy=proxy.sip.sapo.pt:5070

 


Muito Obrigado desde já pela prontidão de suporte!

Cumprimentos

Ver original

48 respostas

Crachá
Como esperado eis a resposta da MEO

"A nossa equipa enviou-lhe um SMS com o texto:
"No seguimento do pedido, informamos que não identificamos nenhuma anomalia com o serviço voip. A questão reportada poderá estar relacionada com os programas de terceiros utilizados para config do serviço voip. Obrigado pelo contacto.".

Obrigado,"

Ou seja. Funcionava, agora não funciona. mas a culpa é sempre nossa.
Inacreditável


Obtive a mesma resposta mas por telefone.
Reputação 1
Crachá +3
Como esperado eis a resposta da MEO

"A nossa equipa enviou-lhe um SMS com o texto:
"No seguimento do pedido, informamos que não identificamos nenhuma anomalia com o serviço voip. A questão reportada poderá estar relacionada com os programas de terceiros utilizados para config do serviço voip. Obrigado pelo contacto.".

Obrigado,"

Ou seja. Funcionava, agora não funciona. mas a culpa é sempre nossa.
Inacreditável
Reputação 1
Crachá +3
Basta ir à area de cliente.
https://cliente.meo.pt/perfil/mensagens/abrir-pedido
Criar um pedido de ajuda.

Apontar para este link no forum.

Penso que será a forma mais facil
Crachá
A linha telefónica de apoio ao cliente não faz a menor ideia do que o SIP é.

Costumave haver um técnico que andava aqui no forum, o Henrique, que tinha bons conhecimentos, mas penso que já trabalha para ou com a meo.

A não ser que alguem da equipa técnica consiga acompanhar este topico, nada nunca irá acontecer.

Parece-me no entanto que é erro de autenticação no momento da chamada do lado do servidores deles. Contudo o apoio técnico telefónico não faz menor ideia do que estamos a falar.

Enviei ticket de apoio na area de cliente apontando para este post. Sugiro que faça o mesmo


Quer me passar o conteudo do ticket, para poder ter uma base do que lhes dizer? Sendo que nao me entendem por telefone?
Reputação 1
Crachá +3
A linha telefónica de apoio ao cliente não faz a menor ideia do que o SIP é.

Costumave haver um técnico que andava aqui no forum, o Henrique, que tinha bons conhecimentos, mas penso que já trabalha para ou com a meo.

A não ser que alguem da equipa técnica consiga acompanhar este topico, nada nunca irá acontecer.

Parece-me no entanto que é erro de autenticação no momento da chamada do lado do servidores deles. Contudo o apoio técnico telefónico não faz menor ideia do que estamos a falar.

Enviei ticket de apoio na area de cliente apontando para este post. Sugiro que faça o mesmo
Crachá
Após as recentes mudanças e problemas de configuração o serviço SIP anda a funcionar muito estranhamente.

Consigo fazer 1 ou 2 chamadas, mas aleatóriamente recebo esta mensagem de erro em algumas chamadas

Sendo que a unica forma de resolver é fazer um reload do servidor

[2019-07-25 11:10:33] VERBOSE
[11525]
[C-0000001a] app_dial.c: Called SIP/Meo - xxx- Out/258xxxxx

[2019-07-25 11:10:33] WARNING
[5626]
[C-0000001a] chan_sip.c: Received response: "Forbidden" from ';tag=as5a77e76f'

[2019-07-25 11:10:33] VERBOSE
[11525]
[C-0000001a] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
[2019-07-25 11:10:33] VERBOSE
[11525]
[C-0000001a] pbx.c: Executing [s@macro-dialout-trunk:31] NoOp("PJSIP/412-00000027", "Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 21") in new stack
[2019-07-25 11:10:33] VERBOSE
[11525]
[C-0000001a] pbx.c: Executing [s@macro-dialout-trunk:32] GotoIf("PJSIP/412-00000027", "0?continue,1:s-CHANUNAVAIL,1") in new stack
[2019-07-25 11:10:33] VERBOSE
[11525]
[C-0000001a] pbx_builtins.c: Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)

Será que há algum do suporte técnico MEO que possa verificar o que se passa com a autenticação dos peers?

Cumprimentos


Está a acontecer-me o mesmo. Cheguei á conclusão que a linha telefónica não tem conhecimentos suficientes quando o assunto é VOIP Nomada, pois dizem que não podem dar os servidores corretos de autenticação. Alguem sabe alguma solução?
Reputação 1
Crachá +3
Parece-me que alguns dos IP dos servidores proxy estão a rejeitar os registos e contactos


OPTIONS sip:sip.sapo.pt SIP/2.0
Via: SIP/2.0/UDP 192.168.1.57:5160;branch=z9hG4bK651ddb98;rport
Max-Forwards: 70
From: "Unknown" ;tag=as4c645a15
To:
Contact:
Call-ID: 7bf753365274e3a8263aa31d19f2e8cc@192.168.1.57:5160
CSeq: 102 OPTIONS
User-Agent: FPBX-14.0.13.4(13.22.0)
Date: Thu, 25 Jul 2019 12:42:33 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Content-Length: 0

<--- SIP read from UDP:194.65.2.241:5070 --->
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.1.57:5160;received=2.83.120.219;branch=z9hG4bK651ddb98;rport=5160
From: "Unknown" ;tag=as4c645a15
To: ;tag=aprqngfrt-onpfhg30000c6
Call-ID: 7bf753365274e3a8263aa31d19f2e8cc@192.168.1.57:5160
CSeq: 102 OPTIONS
P-Charging-Vector: icid-value=82cs1046p1ds2rk6ehcs2pg6h9qs6qlcijra6qtbg3t6mnldvipamfde9rp2oiq-3;icid-generated-at=194.65.2.241

<------------->

REGISTER sip:sip.sapo.pt SIP/2.0
Via: SIP/2.0/UDP 192.168.1.57:5160;branch=z9hG4bK733e0d79;rport
Max-Forwards: 70
From: ;tag=as75a385ab
To:
Call-ID: 15b61a7651887c914720a7cc394823fe@[::1]
CSeq: 102 REGISTER
Supported: replaces, timer
User-Agent: FPBX-14.0.13.4(13.22.0)
Expires: 10
Contact:
Content-Length: 0

<--- SIP read from UDP:194.65.2.241:5070 --->
SIP/2.0 401 Unauthorized 11030030337
Via: SIP/2.0/UDP 192.168.1.57:5160;received=2.83.120.219;branch=z9hG4bK733e0d79;rport=5160
From: ;tag=as75a385ab
To: ;tag=bccb96b9013d47c6b0d935907e6c5904
Call-ID: 15b61a7651887c914720a7cc394823fe@[::1]
CSeq: 102 REGISTER
Content-Length: 0
WWW-Authenticate: Digest nonce="1D0A96E1C5A3395D000000001A9D834B",realm="ims.telecom.pt",algorithm=MD5,qop="auth"

REGISTER sip:sip.sapo.pt SIP/2.0
Via: SIP/2.0/UDP 192.168.1.57:5160;branch=z9hG4bK1efe908e;rport
Max-Forwards: 70
From: ;tag=as75a385ab
To:
Call-ID: 15b61a7651887c914720a7cc394823fe@[::1]
CSeq: 103 REGISTER
Supported: replaces, timer
User-Agent: FPBX-14.0.13.4(13.22.0)
Authorization: Digest username="+351302000XXX", realm="ims.telecom.pt", algorithm=MD5, uri="sip:sip.sapo.pt", nonce="1D0A96E1C5A3395D000000001A9D834B", response="2522511a13a93d56938089474fb8025a", qop=auth, cnonce="62b6a997", nc=00000001
Expires: 10
Contact:
Content-Length: 0
Reputação 1
Crachá +3
Após as recentes mudanças e problemas de configuração o serviço SIP anda a funcionar muito estranhamente.

Consigo fazer 1 ou 2 chamadas, mas aleatóriamente recebo esta mensagem de erro em algumas chamadas

Sendo que a unica forma de resolver é fazer um reload do servidor

[2019-07-25 11:10:33] VERBOSE[11525][C-0000001a] app_dial.c: Called SIP/Meo - xxx- Out/258xxxxx

[2019-07-25 11:10:33] WARNING[5626][C-0000001a] chan_sip.c: Received response: "Forbidden" from ';tag=as5a77e76f'

[2019-07-25 11:10:33] VERBOSE[11525][C-0000001a] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
[2019-07-25 11:10:33] VERBOSE[11525][C-0000001a] pbx.c: Executing [s@macro-dialout-trunk:31] NoOp("PJSIP/412-00000027", "Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 21") in new stack
[2019-07-25 11:10:33] VERBOSE[11525][C-0000001a] pbx.c: Executing [s@macro-dialout-trunk:32] GotoIf("PJSIP/412-00000027", "0?continue,1:s-CHANUNAVAIL,1") in new stack
[2019-07-25 11:10:33] VERBOSE[11525][C-0000001a] pbx_builtins.c: Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)

Será que há algum do suporte técnico MEO que possa verificar o que se passa com a autenticação dos peers?

Cumprimentos
Crachá +3
O microsip funciona só depois de correr o zoiper. não compreendo.
Crachá +3
Para Pc também existe o microsip: https://www.microsip.org/help#domain

Nome da conta: Meo Voip
Servidor SIP: sip.sapo.pt
Proxy SIP: proxy.sip.sapo.pt

Utilizador: +3513020xxxxx
Domínio: sip.sapo.pt
Login: +3513020xxxxx
Palavra-passe:
numero de voicemail: vazio
encriptação desactivado
tranporte UDP
enderenço publico:automático
mais nada
Crachá +3
Para usar no PC podem usar o zoiper:

username/Login:+3513020xxxxx@sip.sapo.pt
Password
->login
Hostname.sip.sapo.pt
->next
yes to "Optional Authentication and Outbound proxy"
Authentication username: +3513020xxxxx
Outbound proxy: proxy.sip.sapo.pt:5070
->next

se o SIP UDP deu verde é só selecionar e clicar next.

Se não funcionou, selecionem SIP UDP e sigam os passos abaixo:
-> skip
->Yes
->Create account
Account Name. +3513020xxxxx@sip.sapo.pt
SIP
----> Carregar em +3513020xxxxx@sip.sapo.pt
domain: sip.sapo.pt
username: +3513020xxxxx
Password:password
Use auth. username: +3513020xxxxx
Use outbound proxy, outbound proxy: proxy.sip.sapo.pt:5070

-> no canto superior direito ir a advanced:
Domain: sip.sapo.pt
Username: +3513020xxxxx
Password:password
Use auth. username: +3513020xxxxx
Use outbound proxy, outbound proxy: proxy.sip.sapo.pt:5070
Caller ID Name: +3513020xxxxx

->ao lado de advanced clicar em register ou cancel e depois register
Crachá +3
Para quem precisar de aplicações para android ou ios
Use o csipsimple (só android) ou o grandstream wave (ios e android):

Dados a introduzir na App CSipSimple:
Wizard: Advanced (não usar o do Sapo pois está desatualizado!)
Nome da conta; MEO (por exemplo)
Identificação da chamada: +3513020xxxxx (facultativo)
Servidor: sip.sapo.pt
Usuário: +3513020xxxxx
ID de autenticação SIP: (facultativo)
Palavra-passe: (password)
Usar TCP(não UDP): não
Proxy: proxy.sip.sapo.pt:5060 ou proxy.sip.sapo.pt:5070

App grandstream wave:
->adicionar nova conta
->Conta Sip
-> Dados a introduzir na App grandstream wave:
Nome da conta; MEO (por exemplo)
Servidor SIP: sip.sapo.pt
ID do Usuário SIP: +3513020xxxxx
ID de autenticação SIP: +3513020xxxxx
Senha: (password)
ID do Usuário do Correio de Voz: (não mexer)
Mostrar nome: (não mexer)

->voltar ás configurações
->configurações de conta
->carregar no Nome da conta
->descer até configurações de rede:
Proxy-Require: proxy.sip.sapo.pt ou proxy.sip.sapo.pt:5060 ou proxy.sip.sapo.pt:5070
Proxy de Saída: proxy.sip.sapo.pt ou proxy.sip.sapo.pt:5060 ou proxy.sip.sapo.pt:5070

é tudo, se por alguma razão quiserem alterar a porta:
1º tem de ir a configs, configurações avançada e desseleccionar a porta aleatória.
Crachá +3
E para windows alguma coisa?
Apenas uma observação sobre a configuração, no arquivo sip.conf, os codecs precisaram ser setados como:

disallow=all
allow=ulaw
allow=alaw

allow=alaw&ulaw gerou erro no asterisk.

Obrigado,

Felipe
Olá Henrique,

 

Muito obrigado pela sua ajuda.

Já consigo fazer chamadas de saída/outbound.

 

Entretanto, quando recebo chamadas a chamada não é direcionada para o "context" definido, e o meu asterisk exibe a mensagem:

No matching peer for 'XXXXXXX' from '194.65.2.193:5070'

 

Onde XXXX é o caller-id que realiza a chamada.

 

Fiquei horas à volta desse problema, mas não consegui descobrir como ajustar.

 

Obrigado,

Felipe
Reputação 2
  escreveu:

Olá,


 


Poderiam me confirmar se é posível conectar um asterisk que tem endereço IP fora da rede da MEO ao MEO Voip?
Estou há algumas horas tentando a conexão, mas o register volta como 401 not authorized.


 


Obrigado,

Felipe



Boa tarde,


 


A criação do número VoIP tem de ser efetuada a partir do Line Id associado ao acesso.


A partir daí desde que exista conetividade e sejam inseridos os dados corretos pode ser usado de qualquer sítio.


 


A resposta 401 tem em princípio a ver com dados de autenticação incorretos.  


 


A configuração  do Trunk SIP deve estar como exemplificado abaixo.


(substitui-a 3020abcde pelos 9 dígitos do número nómada e xxxxxxxx pela password)


 


Trunk SIP:


General Tab


Trunk Name: MEO


OutBound Caller ID: +3513020abcde


 


Sip Settings Tab Outgoing


username=+3513020abcde


type=peer


t38pt_udptl=yes


secret=xxxxxxxx


registername=+3513020abcde


qualify=yes


port=5070


outboundproxy=proxy.sip.sapo.pt:5070


insecure=port,invite


host=sip.sapo.pt


fromuser=+3513020abcde


fromdomain=sip.sapo.pt


from=+3513020abcde


dtmfmode=rfc2833


disallow=all


context=from-trunk


canreinvite=yes


call-limit=2


authname=+3513020abcde


allow=ulaw&alaw


 


Incoming


Register String apenas


+3513020abcde@sip.sapo.pt:xxxxxxxx:+3513020abcde@proxy.sip.sapo.pt:5070/+3513020abcde


 
Olá,

 

Poderiam me confirmar se é posível conectar um asterisk que tem endereço IP fora da rede da MEO ao MEO Voip?
Estou há algumas horas tentando a conexão, mas o register volta como 401 not authorized.

 

Obrigado,

Felipe
Reputação 2
  escreveu:

Boas. Eu tenho "allow anonymous inbound SIP Calls" em YES


 


Desde que o trunk tenha o DID corretamente configurado é possivel fazer o routing das incoming calls sem qualquer problema.


Não sei até que ponto fazer o disable das chamadas anonimas, é importante. Contudo será importante manter o olho na firewall "just in case"


 


 Alterar as definições PJSIP quando se usa um SIP trunk. Poderá funcionar mas não é criar um maior problema?


 


 


 


 



Bom dia,


A configuração das definições PJSIP asterisk terá de ser aprofundada pelos users nas suas situações concretas. O método "allow anonymous" é aquele que tem sido usado, também com os devidos cuidados.


H.


H.
Bem, a coisa do UDP não resultou.

Revi o outbound e como está nesta página, está a funcionar.

Inbound tive de ativar a permissão de chamadas anonimas ou desconhecidas e assim trabalha.

 

Preferia não ter de o fazer, caso alguém consiga ou saiba como por a dar com isso desativo eu agradeço.

 

Desde já obrigado pelo tempo dispendido.

 

Cumprimentos

 

Nuno Reis
É precisamente esse erro que dá quando entra uma chamada.

Logo testo quando chegar a casa e depois aviso aqui de como correu.

 

PS: a imagem não apareceu no post :P

 

Cumprimentos

 
Reputação 1
Crachá +3
Boas. Eu tenho "allow anonymous inbound SIP Calls" em YES


 


Desde que o trunk tenha o DID corretamente configurado é possivel fazer o routing das incoming calls sem qualquer problema.


Não sei até que ponto fazer o disable das chamadas anonimas, é importante. Contudo será importante manter o olho na firewall "just in case"


 


 Alterar as definições PJSIP quando se usa um SIP trunk. Poderá funcionar mas não é criar um maior problema?


 


 


 


 
Reputação 2
  escreveu:

Boas


 


Estive a repor as configs no asterisk por causa desta alteração e com o post das configs originais, consigo fazer chamadas para fora.


Quando faço chamadas para o numero nomada o asterisk rejeitas a chamada, com o seguinte log.


 


[


code:
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:1] NoOp("SIP/ims.telecom.pt-00000009", "Received incoming SIP connection from unknown peer to +351302001194") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:2] Set("SIP/ims.telecom.pt-00000009", "DID=+351302001194") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:3] Goto("SIP/ims.telecom.pt-00000009", "s,1") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,1)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:1] GotoIf("SIP/ims.telecom.pt-00000009", "1?setlanguage:checkanon") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,2)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:2] Set("SIP/ims.telecom.pt-00000009", "CHANNEL(language)=pt-br") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:3] GotoIf("SIP/ims.telecom.pt-00000009", "1?noanonymous") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,5)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:5] Set("SIP/ims.telecom.pt-00000009", "TIMEOUT(absolute)=15") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] func_timeout.c: Channel will hangup at 2018-10-20 19:32:27.877 UTC.
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:6] Log("SIP/ims.telecom.pt-00000009", "WARNING,"Rejecting unknown SIP connection from 194.65.2.193"") in new stack
[2018-10-20 19:32:12] WARNING[25059][C-00000009] Ext. s: "Rejecting unknown SIP connection from 194.65.2.193"

 


Se ativar a opção de permitir chamadas anoninas nas Asterisk SIP settings, a chamada entra, mas o que leio pelos foruns de asterisk ou freeBPX, isso não é boa prática e se para as chamadas funcionarem é preciso isso é derivado a um erro de configuração do trunk.


 


Portanto pergunto se os que conseguiram por o trunk a funcionar, têm isso desativo ou não e se está desativo, se há mais alguma setting que esteja a falhar do meu lado.


Ou se têm alguma sugestão adicional.


 


Cumprimentos


 


Nuno Reis


 


EDIT: tenho um trunk de saída para telemvel que estava a ser usado, portanto nem para fora consigo fazer chamadas via o trunk do meo.



Bom dia,


 


A equipa técnica utiliza Asterisk para alguns testes e de facto para receber chamadas de entrada a forma mais comum de ter chamadas de entrada é ativar a opção “Allow anonymous Inbound sip calls” (sem esta opção ativa  a chamada é entregue ao PBX mas este não a encaminha para a extensão (ou outro destino) que tenha configurado e responde com um anúncio a dizer que o número marcado não está em serviço.)


 


No entanto conseguiu-se receber chamadas com aquela opção desativada alterando, na configuração dos SIP Settings, a configuração do transport UDP para “Não “ na opção “udp – 0.0.0.0 – All” e “Sim” na opção “Udp **bleep**.**bleep**.**bleep**.**bleep** –eth0” (ver figura):


 


H.


 
Boas

 

Estive a repor as configs no asterisk por causa desta alteração e com o post das configs originais, consigo fazer chamadas para fora.

Quando faço chamadas para o numero nomada o asterisk rejeitas a chamada, com o seguinte log.

 

[

code:
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:1] NoOp("SIP/ims.telecom.pt-00000009", "Received incoming SIP connection from unknown peer to +351302001194") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:2] Set("SIP/ims.telecom.pt-00000009", "DID=+351302001194") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:3] Goto("SIP/ims.telecom.pt-00000009", "s,1") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,1)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:1] GotoIf("SIP/ims.telecom.pt-00000009", "1?setlanguage:checkanon") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,2)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:2] Set("SIP/ims.telecom.pt-00000009", "CHANNEL(language)=pt-br") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:3] GotoIf("SIP/ims.telecom.pt-00000009", "1?noanonymous") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,5)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:5] Set("SIP/ims.telecom.pt-00000009", "TIMEOUT(absolute)=15") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] func_timeout.c: Channel will hangup at 2018-10-20 19:32:27.877 UTC.
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:6] Log("SIP/ims.telecom.pt-00000009", "WARNING,"Rejecting unknown SIP connection from 194.65.2.193"") in new stack
[2018-10-20 19:32:12] WARNING[25059][C-00000009] Ext. s: "Rejecting unknown SIP connection from 194.65.2.193"
 

Se ativar a opção de permitir chamadas anoninas nas Asterisk SIP settings, a chamada entra, mas o que leio pelos foruns de asterisk ou freeBPX, isso não é boa prática e se para as chamadas funcionarem é preciso isso é derivado a um erro de configuração do trunk.

 

Portanto pergunto se os que conseguiram por o trunk a funcionar, têm isso desativo ou não e se está desativo, se há mais alguma setting que esteja a falhar do meu lado.

Ou se têm alguma sugestão adicional.

 

Cumprimentos

 

Nuno Reis

 

EDIT: tenho um trunk de saída para telemvel que estava a ser usado, portanto nem para fora consigo fazer chamadas via o trunk do meo.
Confirmo, também já funciona


 


Thanks!
Reputação 1
Crachá +3
Caro Herique, era mesmo essa a situação.


 


Confirmo que consigo fazer chamadas apenas mudando a linha


outboundproxy=proxy.sip.sapo.pt -> para  -> outboundproxy=proxy.sip.sapo.pt:5070


 


 


Muito Obrigado desde já pela prontidão de suporte!


 


Cumprimentos

Responder