Resolvido

VoIP Nómada, mudança de plataforma de serviço > reconfiguração

  • 8 Outubro 2018
  • 36 respostas
  • 2428 visualizações


Mostrar a primeira mensagem

36 respostas

Reputação 2
  escreveu:

Boa Tarde


Obrigado pela resposta rápida.


Infelizmente tal alteração não é o suficiente


Explico (dados protegidos por **bleep**)


Anteriormente as settings eram as seguintes:


 


Trunk SIP:


General Tab


Trunk Name: MEO


OutBound Caller ID: +351302xxx


 


Sip Settings Tab Outgoing


username=+351302000xxx
type=peer
t38pt_udptl=yes
secret=xxxxxxxx
registername=+351302000xxx
qualify=yes
port=5070
outboundproxy=proxy.voip.sapo.pt
insecure=port,invite
host=voip.sapo.pt
fromuser=+351302000xxx
fromdomain=voip.sapo.pt
from=+351302000xxx
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=yes
call-limit=2
authname=+351302000xxx


allow=ulaw&alaw


 


Incoming


Register String apenas


+351302000xxx@voip.sapo.pt:password:+351302000xxx@proxy.voip.sapo.pt:5070/+3513020001xxx




 


Contudo, alterando apenas os host. ou seja voip.sapo.pt e proxy.voip.sapo.pt para os respetivos sip.sapo.pt não permite a autenticação


 


O status é: 


code:
proxy.sip.sapo.pt:5070                  Y      +351302000xx       120 Request Sent   

Ou seja, houve uma alteração mais profunda no processo ade autenticação.


 


Aguardo instruções


 



Boa tarde,


 


O primeiro passo é re-registar a password VoIP na Área de Cliente. Tenho que confirmar consigo que já efetuou este passo. É esta ação que recria o seu número na plataforma.


 


Se já o fez e não consegue efetuar o registo SIP e/ou efetuar/receber chamadas envie-me o seu número por mensagem privada aqui no Forum.


 


H.
Reputação 2
  escreveu:

Se bem que hoje de manhã já dá:


code:
Failed to authenticate on REGISTER to '+351302000XXX@proxy.voip.sapo.pt'

Devo ter-me enganado a por a password...


max 8 carateres certo?



Bom dia,


 


Sim, 6 a 8 carateres. As novas configurações após ter reinserido a password na área de cliente proxy são "proxy.sip.sapo.pt" e o host é "sip.sapo.pt". portos: 5070
Reputação 2
  escreveu:

Ok, uma delas já ligou...


 


A outra continua a dar:


code:
Forbidden - wrong password on authentication for REGISTER

Suponho que quando se muda a password no site demore a mudar efetivamente?


 



Bom dia,


 


Ainda bem que já conseguiu ligação.


Sim poderá haver alguma demora, mas não mais de uns minutos. 


 


Caso fique resolvido, peço-vos para considerarem aceite a solução.


H.
Reputação 2
  escreveu:

Embora a 2ª linha tenha exactamente a mesma configuração da primeira....


 


está-me a dar:


code:
Forbidden - wrong password on authentication for REGISTER

por muito que mude a password no site da meo e na configuração...


 



Boa tarde,


 


Peço-lhe que configure uma password simples de teste de 6 a 8 carateres. Deve contar com um período de alguns minutos até efetuar o registo SIP.


H.
Reputação 2
  escreveu:

Será que o Herique ainda le este topic como já foi marcado como resolvido?



Bom dia,


SIm, tenho estado a seguir o tópico. As configurações de outbound estão a ser analisadas.


H.
Reputação 2
Boa tarde,


 


Quando testámos inicial o FPBX fazia chamadas e hoje (tivemos de reinstalar) tinhamos um problema similar ao indicado nos posts acima.


 


O que se passa é que não obstante se registar para o porto correto (5070) obtém-se um erro, quando tenta efetuar uma chamada o FreePBX envia o INVITE para o porto 5060 o que leva a que seja rejeitado com 403 Forbidden.


 


Conseguimos efetuar chamadas alterando na configuração do trunk forçando o parâmetro do porto outbound proxy para proxy.sip.sapo.pt:5070, e.g.;


 


username=+35130200xxxx


type=peer


t38pt_udptl=yes


secret=Secret


registername=+35130200xxxx


qualify=yes


port=5070


outboundproxy=proxy.sip.sapo.pt:5070


insecure=port,invite


host=sip.sapo.pt


fromuser=+35130200xxxx


fromdomain=sip.sapo.pt


from=+35130200xxxx


dtmfmode=rfc2833


disallow=all


context=from-trunk


canreinvite=yes


call-limit=2


authname=+35130200xxxx


allow=ulaw&alaw


 


Confirmem pf que esta alteração resolve o tema, e caso afirmativo aceitem como solução aqui nesta thread pf.


 
Reputação 2
  escreveu:

Boas


 


Estive a repor as configs no asterisk por causa desta alteração e com o post das configs originais, consigo fazer chamadas para fora.


Quando faço chamadas para o numero nomada o asterisk rejeitas a chamada, com o seguinte log.


 


[


code:
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:1] NoOp("SIP/ims.telecom.pt-00000009", "Received incoming SIP connection from unknown peer to +351302001194") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:2] Set("SIP/ims.telecom.pt-00000009", "DID=+351302001194") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [+351302001194@from-sip-external:3] Goto("SIP/ims.telecom.pt-00000009", "s,1") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,1)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:1] GotoIf("SIP/ims.telecom.pt-00000009", "1?setlanguage:checkanon") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,2)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:2] Set("SIP/ims.telecom.pt-00000009", "CHANNEL(language)=pt-br") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:3] GotoIf("SIP/ims.telecom.pt-00000009", "1?noanonymous") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx_builtins.c: Goto (from-sip-external,s,5)
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:5] Set("SIP/ims.telecom.pt-00000009", "TIMEOUT(absolute)=15") in new stack
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] func_timeout.c: Channel will hangup at 2018-10-20 19:32:27.877 UTC.
[2018-10-20 19:32:12] VERBOSE[25059][C-00000009] pbx.c: Executing [s@from-sip-external:6] Log("SIP/ims.telecom.pt-00000009", "WARNING,"Rejecting unknown SIP connection from 194.65.2.193"") in new stack
[2018-10-20 19:32:12] WARNING[25059][C-00000009] Ext. s: "Rejecting unknown SIP connection from 194.65.2.193"

 


Se ativar a opção de permitir chamadas anoninas nas Asterisk SIP settings, a chamada entra, mas o que leio pelos foruns de asterisk ou freeBPX, isso não é boa prática e se para as chamadas funcionarem é preciso isso é derivado a um erro de configuração do trunk.


 


Portanto pergunto se os que conseguiram por o trunk a funcionar, têm isso desativo ou não e se está desativo, se há mais alguma setting que esteja a falhar do meu lado.


Ou se têm alguma sugestão adicional.


 


Cumprimentos


 


Nuno Reis


 


EDIT: tenho um trunk de saída para telemvel que estava a ser usado, portanto nem para fora consigo fazer chamadas via o trunk do meo.



Bom dia,


 


A equipa técnica utiliza Asterisk para alguns testes e de facto para receber chamadas de entrada a forma mais comum de ter chamadas de entrada é ativar a opção “Allow anonymous Inbound sip calls” (sem esta opção ativa  a chamada é entregue ao PBX mas este não a encaminha para a extensão (ou outro destino) que tenha configurado e responde com um anúncio a dizer que o número marcado não está em serviço.)


 


No entanto conseguiu-se receber chamadas com aquela opção desativada alterando, na configuração dos SIP Settings, a configuração do transport UDP para “Não “ na opção “udp – 0.0.0.0 – All” e “Sim” na opção “Udp **bleep**.**bleep**.**bleep**.**bleep** –eth0” (ver figura):


 


H.


 
Reputação 2
  escreveu:

Boas. Eu tenho "allow anonymous inbound SIP Calls" em YES


 


Desde que o trunk tenha o DID corretamente configurado é possivel fazer o routing das incoming calls sem qualquer problema.


Não sei até que ponto fazer o disable das chamadas anonimas, é importante. Contudo será importante manter o olho na firewall "just in case"


 


 Alterar as definições PJSIP quando se usa um SIP trunk. Poderá funcionar mas não é criar um maior problema?


 


 


 


 



Bom dia,


A configuração das definições PJSIP asterisk terá de ser aprofundada pelos users nas suas situações concretas. O método "allow anonymous" é aquele que tem sido usado, também com os devidos cuidados.


H.


H.
Reputação 2
  escreveu:

Olá,


 


Poderiam me confirmar se é posível conectar um asterisk que tem endereço IP fora da rede da MEO ao MEO Voip?
Estou há algumas horas tentando a conexão, mas o register volta como 401 not authorized.


 


Obrigado,

Felipe



Boa tarde,


 


A criação do número VoIP tem de ser efetuada a partir do Line Id associado ao acesso.


A partir daí desde que exista conetividade e sejam inseridos os dados corretos pode ser usado de qualquer sítio.


 


A resposta 401 tem em princípio a ver com dados de autenticação incorretos.  


 


A configuração  do Trunk SIP deve estar como exemplificado abaixo.


(substitui-a 3020abcde pelos 9 dígitos do número nómada e xxxxxxxx pela password)


 


Trunk SIP:


General Tab


Trunk Name: MEO


OutBound Caller ID: +3513020abcde


 


Sip Settings Tab Outgoing


username=+3513020abcde


type=peer


t38pt_udptl=yes


secret=xxxxxxxx


registername=+3513020abcde


qualify=yes


port=5070


outboundproxy=proxy.sip.sapo.pt:5070


insecure=port,invite


host=sip.sapo.pt


fromuser=+3513020abcde


fromdomain=sip.sapo.pt


from=+3513020abcde


dtmfmode=rfc2833


disallow=all


context=from-trunk


canreinvite=yes


call-limit=2


authname=+3513020abcde


allow=ulaw&alaw


 


Incoming


Register String apenas


+3513020abcde@sip.sapo.pt:xxxxxxxx:+3513020abcde@proxy.sip.sapo.pt:5070/+3513020abcde


 
Crachá +2
Boa Tarde

Tinha, até ontem, o servico Nomada a funcionar perfeitamente na plataforma FreePbx

 

Será possível, esclarecer quais as peer settings a registration strings para fazer a migração para a nova plataforma?

Por outras palavras, SIP ou pjsip? e quais os settings por favor?

 

Obrigado
Crachá +2
Boa Tarde

Obrigado pela resposta rápida.

Infelizmente tal alteração não é o suficiente

Explico (dados protegidos por **bleep**)

Anteriormente as settings eram as seguintes:

 

Trunk SIP:

General Tab

Trunk Name: MEO

OutBound Caller ID: +351302xxx

 

Sip Settings Tab Outgoing

username=+351302000xxx
type=peer
t38pt_udptl=yes
secret=xxxxxxxx
registername=+351302000xxx
qualify=yes
port=5070
outboundproxy=proxy.voip.sapo.pt
insecure=port,invite
host=voip.sapo.pt
fromuser=+351302000xxx
fromdomain=voip.sapo.pt
from=+351302000xxx
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=yes
call-limit=2
authname=+351302000xxx

allow=ulaw&alaw

 

Incoming

Register String apenas

+351302000xxx@voip.sapo.pt:password:+351302000xxx@proxy.voip.sapo.pt:5070/+3513020001xxx



 

Contudo, alterando apenas os host. ou seja voip.sapo.pt e proxy.voip.sapo.pt para os respetivos sip.sapo.pt não permite a autenticação

 

O status é: 

code:
proxy.sip.sapo.pt:5070                  Y      +351302000xx       120 Request Sent   
Ou seja, houve uma alteração mais profunda no processo ade autenticação.

 

Aguardo instruções

 

Responder