Tutorial firmware 10.2.1.L mais segundo router a gerir o serviço de internet

  • 28 September 2014
  • 766 respostas
  • 59563 visualizações

Reputação 6
  • Conselheiro Júnior
  • 1938 respostas
Antes de começar a descrever a configuração gostava de mencionar que esta é uma solução provisoria e experimental visto que a meo está a trabalhar numa solução mais simples .


E também que o firmware 10.2.1.L inclui um modo Gamer que resolve grande partes dos problemas relacionados com jogos e NAT que se encontravam no firmware anterior .


 


Método 1 (Firmware Asus + switch)


 


Para esta configuração é necessário um SWITCH antes dos routers.


 


Configuração no router Asus


NOTA… Para a configuração inicial devem usar a porta 1 ou 2 do router .


 


Ir a WAN e em WAN Connection Type seleccionar Automatic IP , em Enable WAN seleccionar Yes





 


Ir a lan/IPTV em Select ISP Profile seleccionar Manual e em Internet VID introduzir o valor 12





 


Executar estes comandos no router Asus via telnet para activar a porta 3 e 4 que foram separadas quando activamos a VLAN 12  


code:
nvram set switch_stb_x=0
nvram commit
reboot

 


 


Ligar tudo como nesta imagem





 


NOTA… Pode demorar alguns minutos até o Asus receber o IP publico.


 


Prós e contras desta solução ..


 


Prós


- Possibilidade de usar outro router para contornar alguns problemas encontrados no router da meo .


- Ambos os routers vão ter internet e um IP publico diferente em cada um .


 


Contras


-Dois equipamentos extra ligados (Router + Switch)


-Os dois routers vão ficar em redes diferentes , um dispositivo ligado ao router da meo não consegue comunicar com um dispositivo no router asus


-o router asus não está a receber IPV6 (ver Notas)


 


NOTA pessoal , eu tenho estado a testar todos os jogos em que tinha problemas com o firmware anterior e em 99% dos casos já não tenho problemas com o router da MEO e apenas optei por esta solução porque existem certos serviços que utilizo no router da Asus que necessitam de ter um ip publico na porta WAN.


 


Quem testar esta solução agradeço que coloque neste tópico o feedback .


 


Notas adicionais...


 


IPV6


O asus não está a receber IPV6 com firmwares mais recentes , isto foi causado depois da Asus ter corrigido uma falha de segurança , testei com um firmware mais antigo e funciona sem qualquer problema , vamos ter de aguardar que a Asus corrija o problema .


 


TVBox


Para que a box funcione ligada ao asus tem de ser reiniciada depois de ligarem o cabo ao router .


 

Tópico fechado, já não permite mais respostas.

766 respostas

Reputação 6
Boas ?


Tens de instalar o Merlin Firmware  e usar o meu script, segue este tutorial.


http://asuswrt.blogspot.pt/2015/03/configuracao-dos-routers-asus-para-o.html
Muito Obrigado ?.


 


O Merlin Firmware saco deste site: http://asuswrt.lostrealm.ca/download


não é?


 


 
Reputação 6
?


Exactamente.
?


 


Mais uma vez obrigado pela tua ajuda 🙂
? estou a ponderar também adquirir TP-Link TD-W8970 com modem ADSL como tu mas tenho uma dúvida na tua configuração:


 


posso fazer tudo com este modem /router sem ter necessidade de aquirir mais um router. Ou seja deixar o dhcp e wireless ligado e ligar tudo nele, pc's, box, etc, nas portas lan e não ligar nada na porta wan.. Ou seja fazer mesmo só a troca de router. Se não der compensa mais comprar só um modem baratucho como o pedrocr fez.


 


? ainda é possivel adquirir o router TD-8816, pois não o consigo encontrar em nenhum loja online.


 


 


Cumprimentos
Reputação 1
Crachá +6
Boa tarde,


À uns tempos montei um ASUS RT-AC56U na minha casa com o firmware 10.2.1.L


Neste momento estou a tentar por a funcionar um novo router com um modelo diferente (RT-AC51U) numa outra casa em que o router MEO têm este mesmo firmware, porém não consigo.


Após fazer todas as configurações conforme estão aqui no tópico ele não ganha IP Publico.


Alguém me consegue ajudar?


 


Obrigado
Reputação 1
Crachá +6
Esquecime de mencionar que estou a utilizar o método 1 e as ligações estão conforme a imagem


Configurações atuais em anexo


Desde já,


Obrigado


 


EDIT: Estive a ver o log do router e aparece-me esta informação:


WAN Connection: ISP's DHCP did not function properly.
?


 


Quando vou configurar o router segundo o tutorial que me indicaste, no primeiro passo, não me aparece a opção Internet (para colocar a vlan 12) em LanIPTV.


 


Sabes porque será?


 


Cumprimentos
Reputação 1
Crachá +6
?


Mesmo selecionando "Manual Setting" as opções não aparecem? 


 
Sim ? , seleciono Manual Setting, e só me aparecem as oções Lan Port 4 e 3.
Reputação 1
Crachá +6
?


Isso já acontecia antes de ter instalado o firmware indicado na página anterior?


Eu tenho um RT-AC56U neste momento a funcionar 5* apenas seguindo o metodo 1 com o firmware original.


 


Neste momento tenho o firmware 3.0.0.4.378_9529
?


 


Por acaso não reparei nisso, abri a caixa do router, liguei-o e instalei o Merlin firmware, não cheguei a ver se antes aparecia.
Reputação 6
Boas ?


Isso é um bug no firmware, instala a ultima versão do Merlin firmware e usa este tutorial.


http://asuswrt.blogspot.pt/2015/03/configuracao-dos-routers-asus-para-o.html


 
Reputação 6
Boas ?


Experimenta o firmware neste link.


https://www.dropbox.com/sh/4mk2pvp2onf5hg2/AAD8Q2XSZEM0_3Awyzkdspc8a?dl=0
Sim, ?


 


Foi isso que eu fiz, instalei a versão 380.58 indicada para o modelo do meu router, e ia seguir o teu tutorial para configurar a vlan 12.


 


Vou instalar o firmware novamente, a ver se corrige.
Reputação 6
?


 


Eu não sei quais a versões afectadas por esse bug, mas se faz isso com a ultima experimenta com as anteriores
Boas ?


 


Instalei a 380.57, e já aparece :)


 


Muito obrigado
Reputação 1
Boas ?, como tens uma serie de tutorials estou baralhado e vinha-te aqui perguntar duas coisas:


 


1- Onde está (tens?) tutorial para o Archer C9


 


2- Este router vale a pena?


Qual router me aconselhas para gerir a internet? Com boa distribuição de WiFi para uma casa grande (vou ter comprar novos APs compativeis com AC). Desde que nao seja estupidamente caro? O Archer C9 é boa opçao?


Estou um bocado perdido no meio de tanto tutorial e tanto router. Vou ter o tarifario 200/100, vivo numa casa grande, tenho varios switches porque tenho KODIS em 3 divisoes, uma SYNOLOGY NAS, e no meio disto, 2 tp-links ligados a cada switch por cabo e a funcionar em modo AP-BRIDGE mode (para haver um unico SSID).


 


O meu Thomson799vn as vezes manda tudo abaixo (so as vezes)...tadinho. Aquela porta gigabit dele...leva o switch que depois vai a synology NAS e um dos kodis...


O Thomson799vn as vezes manda tudo abaixo (so as vezes)...tadinho. Aquela porta gigabit dele...leva o switch que depois vai a synology NAS e um dos kodis...
 


O Thomson799vn as vezes manda tudo abaixo (so as vezes)...tadinho. Aquela porta gigabit dele...leva o switch que depois vai a synology NAS e um dos kodis...
 
Reputação 1
Crachá +6
?


Boa tarde e obrigado pela resposta,


Ao instalar este firmware posso mais tarde voltar a instalar o firmware que a ASUS disponibiliza oficialmente no seu site sem recorrer a "truques"?


Obrigado


 


EDIT: Já instalei e está tudo 5*. Instalei na minha casa e agora vou muda-lo para a outra onde o queria por a funcionar.


A pergunta acima mantém-se.


Obrigadissimo!!!!!!
?


 


Desculpa estar sempre a chatear, lol, mas após fazer a primeira parte do tutorial, estou a ter problemas com a confguração em telnet.


 


Pelo que percebi entro por telnet no router e introduzo o seguinte comando:


 


RT-AC56U
wget ftp://vsteam.asuscomm.com/WRT/asus/mrl/RT-AC56U.sh

sh RT-AC56U.sh


 


 


certo?


 


Mas como é que o router vai buscar essa config a esse endereço, se após configurar a porta de internet como vlan12, deixo de ter internet no router (tenho o cabo ligado á porta wan).


 
Reputação 1
Crachá +6
?


Tanto quanto sei só se tem internet após ter configurar a porta de internet como VLAN 12.


 


Aproveito para perguntar ao ? o porquê da necessidade de executar este script.


Qual a diferença entre o método 1 e este método.


As ligações não são as mesmas?
? e ?


 


Obrigado pela ajuda, já está tudo a funcionar.


 


🙂
Reputação 1
Crachá +6
?


Olá novamente,


Quando ligo a box ao router ASUS consigo ver tv por 15 segundos até bloquear e mostrar a mensagem de serviço indisponivel.


Se mudar de canal ele volta a dar durante mais 15 segundos e volta a mostar a mensagem de serviço indisponivel.


 


A internet está a funcionar 5*


Desde já obrigado
Reputação 1
Crachá +6
Já descobri, era o "Enable multicast routing (IGMP Proxy)" que estava desativado.
Reputação 6
Boas ?


Com este script podes ligar o router da meo á porta 4 do Asus para não ficares sem serviço  de voip