Tutorial firmware 10.2.1.L mais segundo router a gerir o serviço de internet

  • 28 Setembro 2014
  • 768 respostas
  • 48225 visualizações

  • Conselheiro Sénior
  • 0 respostas
Antes de começar a descrever a configuração gostava de mencionar que esta é uma solução provisoria e experimental visto que a meo está a trabalhar numa solução mais simples .


E também que o firmware 10.2.1.L inclui um modo Gamer que resolve grande partes dos problemas relacionados com jogos e NAT que se encontravam no firmware anterior .


 


Método 1 (Firmware Asus + switch)


 


Para esta configuração é necessário um SWITCH antes dos routers.


 


Configuração no router Asus


NOTA… Para a configuração inicial devem usar a porta 1 ou 2 do router .


 


Ir a WAN e em WAN Connection Type seleccionar Automatic IP , em Enable WAN seleccionar Yes





 


Ir a lan/IPTV em Select ISP Profile seleccionar Manual e em Internet VID introduzir o valor 12





 


Executar estes comandos no router Asus via telnet para activar a porta 3 e 4 que foram separadas quando activamos a VLAN 12  


code:
nvram set switch_stb_x=0
nvram commit
reboot

 


 


Ligar tudo como nesta imagem





 


NOTA… Pode demorar alguns minutos até o Asus receber o IP publico.


 


Prós e contras desta solução ..


 


Prós


- Possibilidade de usar outro router para contornar alguns problemas encontrados no router da meo .


- Ambos os routers vão ter internet e um IP publico diferente em cada um .


 


Contras


-Dois equipamentos extra ligados (Router + Switch)


-Os dois routers vão ficar em redes diferentes , um dispositivo ligado ao router da meo não consegue comunicar com um dispositivo no router asus


-o router asus não está a receber IPV6 (ver Notas)


 


NOTA pessoal , eu tenho estado a testar todos os jogos em que tinha problemas com o firmware anterior e em 99% dos casos já não tenho problemas com o router da MEO e apenas optei por esta solução porque existem certos serviços que utilizo no router da Asus que necessitam de ter um ip publico na porta WAN.


 


Quem testar esta solução agradeço que coloque neste tópico o feedback .


 


Notas adicionais...


 


IPV6


O asus não está a receber IPV6 com firmwares mais recentes , isto foi causado depois da Asus ter corrigido uma falha de segurança , testei com um firmware mais antigo e funciona sem qualquer problema , vamos ter de aguardar que a Asus corrija o problema .


 


TVBox


Para que a box funcione ligada ao asus tem de ser reiniciada depois de ligarem o cabo ao router .


 

768 respostas

Método 2 (TOMATO Firmware) 


Solução encontrada pelo utilizador @@afonso88 


 


MUITO IMPORTANTE !!! Ver notas no final
Com este método deixamos de usar o switch .


 


Depois de instalarem o firmware devem configura-lo desta forma .


 


1- Clicar em Advanced /VLAN





 


1.1- Clicar na Vlan 1 remover o visto da porta 4 e clicar em ok





1.2- Clicar na Vlan 2 e altera-la para a 12 , colocar os vistos em Port 4 /Tagged /Wan Port /Tagged e clicar em ok





1.3- Este passo apenas é necessário em routers mais antigos exemplo (RT-N12 B1, C1, D1).


     Activar a opção Trunk Vlan (Experimental)


 





 


1.4- Clicar em save


 


E agora é só ligar tudo como na imagem





 


Notas
Antes de instalarem o firmware devem ler com muita atenção qual a versão de firmware aconselhada para o vosso router e o método de instalação .


 


Fica aqui uma lista de modelos e respectivas versões de firmware compatíveis
http://tomato.groov.pl/?page_id=69


 


No meu caso com o Asus RT-N16 o firmware que usei foi o tomato-K26USB e para conseguir instalar tive que usar o software de restauro da asus que está disponível na pagina da asus no meu caso é o ASUS RT-N16 utilities. (Qualquer duvida estarei aqui para tentar ajudar )
http://tomatousb.org/tut:installing-on-asus-rt-n16


 


 


Método 3 (Openwrt Firmware)


 


Ir a Network/Switch clicar em Add atribuir o valor 12 na Vlan ID e em CPU seleccionar Tagged.


 





 


Na Vlan 2 Port 0 ”porta wan” seleccionar Off e na Vlan 1 Port 1 selecionar Off


 





 


 


 


Na Vlan 12 Port 0 e port 1 seleccionar Tagged e finalizar clicando em Save&Apply.







 Nota importante ,o firmware detecta as portas na ordem inversa á que está marcada no Asus , portanto a Port 1 no firmware é a porta 4 indicada na traseira do router Asus , mas não sei se acontece o mesmo em todos os router portanto certifique-se se o vosso router apesenta as portas correctamente no firmware 


 


 


Ir a Network/Interfaces , em WAN clicar em edit ,


 


Clicar em Physical Settings e seleccionar VLAN Interface: "eth0.12" (wan) e fazer novamente Save&Apply


 


 





 


6º Clicar em System e Reboot


 


7º ligar tudo como na imagem


 





 


 


 


Método 4 (Router asus + Firware Asuswrt-Merlin )


 


   


Solução encontrada pelo utilizador @@yoseikan 


https://forum.meo.pt/t5/Equipamentos-Internet/Tutorial-firmware-10-2-1-L-mais-segundo-router-a-gerir-o-servi%C3%A7o/m-p/65614/highlight/true#M14721


 


Informação adicional…
Cada modelo de router asus usa um switch diferente portanto o script tem de ser adaptado a cada um deles , vou tentar testar o máximo possível de modelos e colocar aqui os scripts para cada um deles .


 


Nota… nos modelos que já testei a ordem das portas do router está invertida , neste caso para fazer bridge da porta 4, no script temos de usar a porta 1 , mas o resultado final vai ser a porta 4 marcada na parte traseira do router é a que está em bridge.


 


Script Asus RT-N16


code:
#!/bin/sh
robocfg vlan 1 ports "2 3 4 8t"
robocfg vlan 12 ports "0t 1t 8t"

 


Script Asus RT-AC68U


code:
#!/bin/sh
robocfg vlan 1 ports "1 2 3 5t"
robocfg vlan 12 ports "0t 4t 5t"

 


 


Script Asus RT-AC87U


code:
#!/bin/sh
robocfg vlan 1 ports "2 3 5u 7t"
robocfg vlan 12 ports "0t 1t 7t"

 


 


 


 


 


Nota.. Este firmware só está disponível para alguns modelos da Asus, podem encontra-los aqui


http://asuswrt.lostrealm.ca/about


 


 


 


Método 5 (firmware DDWRT )


 


Embora goste bastante deste firmware a verdade é que está cada vez pior , o projecto nos últimos anos perdeu a força que tinha , embora continuem a sair novas versões á sempre qualquer coisa que deixa de funcionar e muitas que nunca chegaram a ser corrigidas e está cada vez mais instável .


 


Depois de varias horas a tentar configurar as Vlan´s no meu Asus RT-N16 descobri que só é possível faze-lo através da pagina de configuração do router em alguns “poucos” modelos , a solução seria uma configuração manual via telnet .


 


Desde sempre tentei apresentar soluções fáceis de utilizar , mas como não é o caso com este firmware recomendo usarem o firmware Tomato , é compatível com paticamente todos os routers e neste caso muito simples de fazer a configuração .


 


Para quem quiser tentar a configuração manual do DDWRT fica aqui a documentação necessária.
http://www.dd-wrt.com/wiki/index.php/VLAN_Support
http://www.dd-wrt.com/wiki/index.php/Switched_Ports
Bravo, Xptopt!


 


Embora ainda tenha o firmware 10.2.1.D, e portanto não posso testar, gostaria de te perguntar se agora já tens telefone.


 


Obrigado por tudo!


 


Ovelha Negra
Boas


Sim está tudo a funcionar .
Eu sabia que ias conseguir...;)


 


Ovelha Negra
Reputação 7
Crachá +19
boas


 


tenho de fazer umas questao...como consegues ter 2 IP's publicos com o mesmo user de net? ou neste caso já é singledge?
Boas


 


Sim já é Single Edge , mas só consigo dois IPV4 ainda não consegui por IPV6 no asus .
Olá outra vez!


 


Embora pareça que é cedo (ainda tenho o firmware 10.2.1.D) gostaria de te pedir alguns esclarecimentos sobre o guia que nos apresentaste.


 


1.- Com o firmware DD-WRT (de que não abdico) não tenho a opção "Enable WAN". Como terei que fazer?


 


2.-O MTU é 1500 ou 1492?


 


3.- Com o firmware DD-WRT não tenho Lan-IPTV. E agora?


 


4.- O router ASUS fica na mesma gama de IPs que o da Meo: 192.168.1.1 em vez de 192.168.2.1, como até agora?


 


Obrigado pelos esclarecimentos!


 


Ovelha Negra
Boas


 


Essa configuração é para o asus original , para o DDWRT basta em WAN escolher Automatic IP , e a VLan pode ser configurada em Setup/Networking , mas não sei ao certo como é feito nesse firmware .


 


O valor da MTU é automático e quanto ao ip podes usar o 1.1 ou o 2.1 é indiferente visto que os dois routers estão separados .
xptopt escreveu: e a VLan pode ser configurada em Setup/Networking , mas não sei ao certo como é feito nesse firmware ....
...Nem eu... mas para já ainda não é preciso...


Obrigado pelas informações.


 


Ovelha Negra
Reputação 1
Olá, relativamente a esta solução,se utilizar um 2º router e tenha um tablet ligado por wireless a esse mesmo router, é necessário efectuar configuração adicional para o MEO GO funcionar tal como está no tutorial da firmware 10.2.1.D?

 

Obrigado, cumps
Boas


Não consigo testar isso porque tenho o serviço meo go multi e este funciona em qualquer lado, mas se não funcionar com o serviço meogo simples é provável que a configuração adicional do firmware 10.2.1.D não funcione .


 


Mas podes sempre ligar o tablet ao router da meo porque nesta configuração os dois routers têm net .
Será que a PT alguma vez vai disponibilizar um router com 4 portas gigabit ?


 


Como o TG799vn2
Olá, XPTOPT.

 

Obrigado pelo teu tutorial!

 

Será que já usaste algum router, Asus ou não, que tenha como modo de autentição o IPoE? Já verifiquei que o Asus RT-N56U, pelos menos com o firmware alternativo Padavan, permite que se use o IPoE para ligação WAN. No escritório, tenho 1 RT-N66U e 1 RT-N56U a funcionarem como AP e 1 RT-N66U está a fazer de router, fazendo o bridging entre o Technicolor. Provavelmente usando um router que permita o IPoE, deixa de ser necessário o tal switch entre o router da MEO e o segundo router.

 

Alguma ideia sobre isto?

 

Obrigado desde já e até breve,

 

Sérgio Oliveira.

 
Boas
Enquanto a Meo não disponibilizar um modo bridge untagd´d não é possível , é necessário o switch .


 


E como agora só já existe a VLan 12 não é possível configurar o technicolor com outra vlan para poder usar a 12 no segundo router .
Boas pessoal.


 


xptopt eu uso um draytek vigor2830vn+, esclarece-me uma situação se souberes. A Internet VID = 12 que falas no primeiro post, será que no meu router é a opção VLAN Tag insertion Enable e o Tag value = 12?


http://s9.postimg.org/cy1fxlub3/draytek.png


 


Obrigado.
Olá a todos, tenho seguido de perto os dois tópicos relativos à configuração de um segundo router e gostava de partilhar convosco uma situação que se passou comigo.


 


No escritório do meu pai tenho um TP-LINK WDR-3600 a gerir uma rede de 10 computadores + 2 servidores de dados e acesso remoto. Tive de investir no TP-LINK porque o Thomson do MEO estava constantemente a bloquear e a desaparecer com os servidores ligados. Desde que meti o TP-LINK que nunca mais tive problemas e funciona tudo na perfeição.


 


Para meu espanto, receberem no escritório uma chamada na semana passada, por parte do MEO, a dizer que vão atualizar o Thomoson para a nova versão, que vai deixar de existir passwords e que vamos deixar de poder utilizar o segundo router! Eu tinha ouvido que eles estavam a ter a decência de esperar por uma solução, mas neste momento estão a fazer-me voltar à idade da pedra com o router thomson.


 


Gostava de saber se se está a passar o mesmo convosco e o que devo fazer nesta situação. Sei que os equipamentos são deles, mas isso dás-lhe o direito de limitar a utilização de outros equipamentos a meio de um contrato de fidelização? Creio que tenho aqui matéria para pedir a rescisão, visto que estão a alterar as condições de prestação do serviço.


 


A adicionar a isto, houve um problema na central de PT na segunda-feira desta semana, durante a resolução, não sei por que razão, fizeram reset à password de acesso sem nos avisar e o router TP_LINK não conseguia ligar à internet. Estive for esse tempo e por esse motivo o escritório esteve sem ligação à internet por 3 dias. Cá para mim parece-me que estavam era a fazer o jogo para me obrigar a eliminar o segundo router.


 


Esta situação é indecente e estou bastante desiludido com o MEO, não só por esta razão mas por muita coisa que se tem passado nos últimos tempos. Sou cliente PT desde que surgiu o ADSL e sempre defendi que era o melhor serviço a nível nacional. Mas a minha ideia mudou radicalmente nos últimos tempos.


 


Muito obrigado a todos.
Olá, DMFerreira.


 


Por acaso o meu comentário anterior também se deveu a no final da semana passada ter existido algum problema na central ds PT, pois também fiquei sem acesso à net. Mesmo colocando só o router da MEO a fazer a ligação à net, a maior parte das vezes só me dava o erro de Centralizador não disponível. Depois de ter ligado para o apoio ao cliente, nem eles conseguiram numa primeira fase repor a password (a antiga 102030). Só depois de ter eu efectuado um reset ao router é que o acesso ficou normalizado. Ainda fiquei com o router da MEO a fazer a gestão da net durante o fim de semana e na segunda-feira, fiz a reposição do segundo router como router principal.


 


Vou entretanto fazer uma pergunta ao XPTOPT sobre a possibilidade de colocar o switch entre os dois routers (o da MEO e no meu caso um Asus) mesmo sem a nova versão, usando neste caso a anterior 10.2.1.D.


 


Obrigado e até breve,


 


Sérgio Oliveira.
Olá, XPTOPT.


 


Obrigado pela tua ajuda.


 


Uma pergunta: será que a situação do switch antes dos dois routers funciona na versão anterior, a 10.2.1.D ou só na nova 10.2.1.L?


 


Obrigado e até breve,


 


Sérgio Oliveira.
Boas @@@Morcego 
Sim deve ser ai que se configura nesse router .
Boas @@@alburitel 
Sim deve funcionar , mas no caso desse firmware tens de usar a Vlan 10 para internet e Vlan 12 para IPTV .
Boas @@@DMFerreira 


 


Seguindo este tutorial podes continuar a usar outro router , eu inicialmente também não me agradou a situação mas acabei por não desgostar da alteração .


 


Principalmente porque tenho um ip publico para cada router .
Boas a todos

 

So por curiosidade, que router alternativo usam ? Andei a ver se encontrava alguem a falar de modelos e não tive sorte :(

 

Mudei de casa recentemente, fiz a migração do serviço, e não so o router foi resetado como actualizado, logo, bye bye root.

Este novo metodo agrada-me porque tenho dois ips publicos, logo consigo ter muito mais facilidae (e nao andar as turras com port forwarding, especialmente quando não é TCP nem UDP...)

 

Não queria gastar muito €, já sei que o RT66N é bom, mas muito acima do orçamento 😃
Podes usar qualquer um destes , recomendo especialmente o RT-N18 U ,mas qualquer um deles aguenta bem .


 


ASUS norma N
RT-N10U, RT-N10U B, RT-N10P, RT-N12 B1, RT-N12 C1, RT-N12 D1, RT-N12HP, RT-N15U, RT-N16, RT-N18U, RT-N66U
ASUS norma AC
RT-AC56U, RT-AC66U, RT-AC68U
Obrigado xptopt pela resposta rapida


 


Tenho em vista um Asus RT-N56U ou um Asus RT-N53, não serão compativeis ?


 


 
O RT-N56U não recomendo por ter um chip Ralink , o RT-N53 é compatível mas não tem partas gigabit , o RT-N15U pode ser uma melhor opção visto que é gigabit e também tem uma porta USB.


 


Tens aqui este site com as características de cada um .
http://en.wikipedia.org/wiki/List_of_Asus_routers


 


Ps. No caso de optares pelo RT-N53 certifica-te que é a revisão A1 que tem um chip a 500MHZ , o normal é só a 300MHZ

Responder