Tutorial, como mudar o ip publico no FW: 10.2.1.L

  • 27 Abril 2015
  • 38 respostas
  • 26834 visualizações

Reputação 6
  • Conselheiro Júnior
  • 1938 respostas
Para mudarem o ip publico do router meo em dois segundos têm de aceder ao router via telnet .


Ver aqui como activar e usar o serviço telnet .


 


User=sumeo
Pass= bfd,10ng


 


E executar os seguintes comandos para o serviço fibra.


 


code:
dhcp client ifdetach intf=InternetGPON
dhcp client ifattach intf=InternetGPON

 E este para ver o estado (Opcional)


 


code:
dhcp client iflist

 


 


executar os seguintes comandos para o serviço Adsl


code:
dhcp client ifdetach intf=InternetADSL
dhcp client ifattach intf=InternetADSL

 


E este para ver o estado (Opcional)


code:
dhcp client iflist

38 respostas

Crachá


User=sumeo
Pass= bfd,10ng
Eu não consigo usar o sumeo como utilizador vou a por a pass e diz que está errado

Alguém me consegue ajudar
Crachá

User=sumeo
Pass= bfd,10ng
Eu não consigo usar o sumeo como utilizador vou a por a pass e diz que está errado

Crachá

User=sumeo
Pass= bfd,10ng

Eu não consigo usar o sumeo como utilizador vou a por a pass e diz que está errado
Sim, tem 3 videos no YouTube a respeito disso. Um penso que é de um Moderador da Meo , o outro não faço ideia e o 3º é o meu que fiz com o objetivo de divulgar o programa que faz isso. 

https://www.youtube.com/watch?v=EHSzCIf7Kd8
Nenhum desses métodos apresentados até agora funciona mais com o novo firmware que no Technicolor TG784n v3 quer noutro qualquer que tenha recebido o novo firmware
boa tarde, este metodo ainda esta a funcionar? e ja fiz tudo o que disseram anteriormente e o ip nao muda
Reputação 6
Boas ?
Tenho informação que a Meo está a trabalhar nisso mas não tenho datas previstas para estar disponível.
Olá ?,


 


Alguma novidade quanto à existência de um script (ou de alguma outra forma) que permita fazer bridge da porta 4 do router Meo, de forma a que um dispositivo ligado à mesma adquira um IP público da MEO?


 


Obrigado,


 


Gustavo


 
Crachá
Aparentemente os IP agora são estáticos e se quisermos dinâmicos temos de pagar. Só não percebo porque não é assim para todos visto que alguns ainda conseguem mudar?
Script em python para quem quiser:


 


code:
#!/usr/bin/python
# -*- coding: utf-8 -*-
import telnetlib

HOST = "192.168.1.254"
user = "sumeo"
password = "bfd,10ng"

tn = telnetlib.Telnet(HOST)
tn.read_until("Username : ")
tn.write(user+ "
")
tn.read_until("Password : ")
tn.write(password+ "
")
tn.write("
")

tn.write("dhcp client ifdetach intf=InternetGPON
")
tn.write("dhcp client ifattach intf=InternetGPON
")
tn.write("dhcp client iflist
")

tn.write("exit
")
out = tn.read_all()
print out
Reputação 6
Boas
Eu não sei porque é que isso acontece, no meu serviço funciona sempre á primeira .
Crachá
Já, continua a não funcionar. Será que tem algo a ver com o IPv6?
Reputação 6
Boas ?


 


Já experimentaste o que o está no post anterior ao teu?
Crachá
Desde o update para 10.2.1.L não consigo alterar o IP, alguém sabe de uma solução, tenho ADSL e já tentei todos os comandos descritos.
Boas, para desativar o DHCP e assim já funciona ir a > Rede doméstica > Interfaces > LocalNetwork > Configurar, desativar Servidor DHCPv4, aplicar e reiniciar o modem!

 

Agora já funciona 😉
Reputação 2
Este tópico não serve de nada, pois o IP é atribuído por DHCP.


Como tal se não existir outro IP disponível será atribuído sempre o mesmo IP.


O acesso não deixa de ter perfil de IP Dinâmico, apenas não é renovado com a frequência que se calhar gostariam lol.


 


Enquanto uns pagam para ter IP fixo, outros refilam por o "terem"... enfim. O tuga nunca está satisfeito 😃
Passada uma semana, experimentei de novo o script e, sem fazer absolutamente nada, começou a funcionar.


🤦
idem...
Hj durante a noite deixei os routers desligados, liguei-os agora e mesmo assim foi me atribuido o mesmo IP. Não entendo pq que agora de um dia para o outro isto deixou de dar para mudar o IP, antes era só reiniciar o router que mudava logo.
Comigo isto tb não está a funcionar. Já tenho a telnet activada, corro os scripts, ja os inseri manualmente tb, Ja fiz reset ao router e nada, n consigo mudar o IP da InternetGPON.  Alguem me pode ajudar?

O meu Desktop PC está ligado por ethernet.

TG784n v3

10.2.1.L

SingleEDGE IPv4 & IPv6 (modificado pelo utilizador)
Comigo não funciona.


O script corre normalmente mas o ip não muda.


Tenho fibra normal, já fiz reset ao router, o portátil está ligado por wireless.


Será que tenho que mudar alguma configuração no router?


 


Router: Technicolor TG784n v3


Firmware: 10.2.1.L
Podes sempre usar isto

https://www.youtube.com/watch?v=sVyBGXXRF_U
Amigo não cheguei a fazer reset e agora já está a bombar estranho....mas muito obrigado pela paciência.valeu grande abraço
Reputação 6
@@pauloscp80


 


Experimenta fazer um reset ao router e tenta novamente .
Sim para fibra é o que tenho em casa

Responder