Tutorial, como mudar o ip publico no FW: 10.2.1.L

  • 27 Abril 2015
  • 35 respostas
  • 25596 visualizações

  • Conselheiro Sénior
  • 0 respostas
Para mudarem o ip publico do router meo em dois segundos têm de aceder ao router via telnet .


Ver aqui como activar e usar o serviço telnet .


 


User=sumeo
Pass= bfd,10ng


 


E executar os seguintes comandos para o serviço fibra.


 


code:
dhcp client ifdetach intf=InternetGPON
dhcp client ifattach intf=InternetGPON

 E este para ver o estado (Opcional)


 


code:
dhcp client iflist

 


 


executar os seguintes comandos para o serviço Adsl


code:
dhcp client ifdetach intf=InternetADSL
dhcp client ifattach intf=InternetADSL

 


E este para ver o estado (Opcional)


code:
dhcp client iflist

35 respostas

Para quem tem ADSL é substuitir "InternetGPON" por "InternetADSL".


 


Obrigado @@xptopt, já consigo desativar a ligação no router da meo, agora só me falta conseguir fazer a autenticação no Asus. Alguma ideia?
Boas @@Miguel7


 


Estou á espera que a Meo disponibilize um script que vai fazer bridge da porta 4 do router Meo.


 


Mas não existe nenhuma data para isso , se não estiver até ao final da semana , eu volto a insistir com eles .
Reputação 1
Boas


 


Obrigado pela dica xptopt.


 


Só uma questão, não existe possibilidade de criar um .bat file com esses comandos e assim quando necessário apenas executar esse ficheiro e fazer tudo de uma forma automática?
Boas @@oem


 


Deve ser possível mas isso já não é a minha área .
Reputação 1
Depois de ter feito essa pergunta fui pesquisar e não foi muito dificil de encontrar.


 


Para quem estiver interessado, basta copiar o seguinte script e colar no bloco de notas e guardar como ficheiro .vbs; "ex: meo.vbs"


 


code:
Set cloner = CreateObject("WScript.Shell")
cloner.run"cmd"
WScript.Sleep 500

cloner.SendKeys"telnet 192.168.1.254"
cloner.SendKeys("{Enter}")
WScript.Sleep 500

cloner.SendKeys"sumeo"
cloner.SendKeys("{Enter}")
WScript.Sleep 500

cloner.SendKeys"bfd,10ng"
cloner.SendKeys("{Enter}")
WScript.Sleep 500

cloner.SendKeys"dhcp client ifdetach intf=InternetGPON"
cloner.SendKeys("{Enter}")
WScript.Sleep 300

cloner.SendKeys"dhcp client ifattach intf=InternetGPON"
cloner.SendKeys("{Enter}")
WScript.Sleep 300

cloner.SendKeys"exit"
cloner.SendKeys("{Enter}")
WScript.Sleep 100

cloner.SendKeys"exit"
cloner.SendKeys("{Enter}")

 


O script efectua os passos acima de forma automática e fecha também após a execução dos mesmos, dá jeito para não ter que andar sempre a inserir isso "à mão".


 


De qualquer forma, obrigado xptopt.
Boa tarde a todos mas o meu ip não muda já segui os passos acima descritos e nada...alguma ideia..obrigado a todos
Boas @@pauloscp80


 


Devia mudar , qual é o firmware do teu router?
Obrigado pela resposta rapida o firmware é FW: 10.2.1.L...nao aei se tenho de ativar mais alguma coisa em algum lado sem ser o telnet no windows
Boas @@pauloscp80


 


Quando executas os comandos dá algum erro ?


 


Executa esta comando antes para ver qual é o ip


code:
dhcp client iflist
Quando executo os comandos nao da nenhum erro mas tambem nao da informaçao nenhuma...ao executar dhcp client iflist aparece sempre o mesmo ip
Boas @@pauloscp80


Tens serviço empresarial ou normal ?


 
Normal
@@pauloscp80


 


Estás a usar os comandos correctos , um é para fibra o outro é para ADLS.
Sim para fibra é o que tenho em casa
@@pauloscp80


 


Experimenta fazer um reset ao router e tenta novamente .
Amigo não cheguei a fazer reset e agora já está a bombar estranho....mas muito obrigado pela paciência.valeu grande abraço
Podes sempre usar isto

https://www.youtube.com/watch?v=sVyBGXXRF_U
Comigo não funciona.


O script corre normalmente mas o ip não muda.


Tenho fibra normal, já fiz reset ao router, o portátil está ligado por wireless.


Será que tenho que mudar alguma configuração no router?


 


Router: Technicolor TG784n v3


Firmware: 10.2.1.L
Comigo isto tb não está a funcionar. Já tenho a telnet activada, corro os scripts, ja os inseri manualmente tb, Ja fiz reset ao router e nada, n consigo mudar o IP da InternetGPON.  Alguem me pode ajudar?

O meu Desktop PC está ligado por ethernet.

TG784n v3

10.2.1.L

SingleEDGE IPv4 & IPv6 (modificado pelo utilizador)
Hj durante a noite deixei os routers desligados, liguei-os agora e mesmo assim foi me atribuido o mesmo IP. Não entendo pq que agora de um dia para o outro isto deixou de dar para mudar o IP, antes era só reiniciar o router que mudava logo.
idem...
Passada uma semana, experimentei de novo o script e, sem fazer absolutamente nada, começou a funcionar.


🤦
Reputação 2
Este tópico não serve de nada, pois o IP é atribuído por DHCP.


Como tal se não existir outro IP disponível será atribuído sempre o mesmo IP.


O acesso não deixa de ter perfil de IP Dinâmico, apenas não é renovado com a frequência que se calhar gostariam lol.


 


Enquanto uns pagam para ter IP fixo, outros refilam por o "terem"... enfim. O tuga nunca está satisfeito 😃
Boas, para desativar o DHCP e assim já funciona ir a > Rede doméstica > Interfaces > LocalNetwork > Configurar, desativar Servidor DHCPv4, aplicar e reiniciar o modem!

 

Agora já funciona 😉
Crachá
Desde o update para 10.2.1.L não consigo alterar o IP, alguém sabe de uma solução, tenho ADSL e já tentei todos os comandos descritos.

Responder