Thomson TG799vn - Solução para velocidade wireless presa nos 65mbps!


Reputação 5
Atenção - Para utilizadores principiantes - Se os procedimentos do tutorial vos fazem confusão ou não têm mesmo a certeza do que estão a fazer, não continuem e contactem o apoio técnico, entregando o serviço a quem sabe. Não me responsabilizo por quaisquer problemas causados ao equipamento ou à vossa rede.


 


Atenção: Apenas testado em condiçoes ideais, com o firmware 10.2.1.D!!


 


Eis o que consegui até agora com o meu equipamento:


router: Thomson TG799vn


Adaptador USB wifi: Belkin surf micro USB 150mbps Wifi b/g/n


 


http://s13.postimg.org/orq12c3jb/tg799vn_wifi.jpg


 


 


Tendo em conta que o trafego fibra está em parte reservado para a TV e limitado entre 90mbps a 95mpbs para a net, conseguir quase 91mbps através do wifi do router não é nada mau na minha opnião. Apesar de estar ainda algo distante da velocidade WLAN desejável. Porém ainda estou em fase de testes e agradecia que testassem voces tambem para podermos comparar resultados.


 


O que Fazer:


 


- aceder à interface web do router com o root user ou super user da MEO, tanto faz. rootuser: microuser password: !C0nf16,M30 ou superuser: sumeo pasword: bfd,10ng A seguir abram - Ferramentas - Gestão de utilizadores - para criar uma nova conta com privilégios equivalentes ao microuser, ou superuser(ex: admin/admin) para facilitar o acesso geral.


 


Nota: para quem tem outro router diferente do TG799vn ou outra versão de firmware, saibam como obter acesso rootuser consultando este tópico: http://forum.meo.pt/t5/Equipamentos-Internet/Como-restaurar-acessos-RootUser-e-permiss%C3%B5es-num-router-TG784n/td-p/68474


 


2º - aceder por telnet ao router com a nova conta que criaram ou o microuser/sumeo, como preferirem. menu iniciar - executar/procurar ficheiros - cmd.exe na linha de comandos a seguir: telnet 192.168.1.254 (ou o IP que tiverem configurado para o router) Podem usar um programa para telnet da vossa preferencia (ex: putty)


 


Introduzam o user e a password que falei acima.


 


3º -alterar configuraçoes avançadas wireless. Ainda na linha de comandos telnet introduzam - menu - para aceder ao menu de acesso rapido


 


http://s15.postimg.org/oz7jtw9hn/telnet1.jpg


 


A este ponto ignorem todas as demais opçoes existentes e sigam directamente para a de nome "wireless". Usem as teclas de direcção para navegar e a tecla Enter para confirmar valores. Tecla tab para alternar entre a tabela de valores e a barra de botoes "OK" "Cancel".


 


http://s8.postimg.org/r26mpqdat/telnet_2.jpg


 


Em "wireless" sigam para - radio - e modifiquem os seguintes valores


 


http://s14.postimg.org/l79rtqyvl/telnet3.jpg


 


state:= enabled (significa que o radio 2,4 GHz fica ligado permanentemente)


channel:= 1 (o canal é o que voces bem entenderem, claro, mas aconselho o uso do canal 1)


interop:= 802.11b/g/n (não há muita escolha, aqui obviamente a opçao que inclui a norma N)


frameburst:= enabled (vale a pena ter sempre isto ligado, aumenta significativamente a velocidade de transmissao)


channelwidth:= 20/40 (a largura de banda maior de 40 mhz que tanta falta fazia agora possivel de configurar) (Estas 3 proximas opçóes sáo especificas da norma N e podem produzir resultados diferentes em condiçoes diferentes, se nao resultar para o vosso caso tentem configurar de outra maneira com umas ligadas ao inves de outras)


sgi:= enabled (Short Guard Time interval: activado produziu melhorias significativas na velocidade)


cdd:= disabled (Cyclic Delay Diversity: não melhorou velocidade, pelo que parece é uma tecnica de evasao às interferências, util talvez para quem tenha mais routers wifi na vizinhança. deixei desligado)


stbc:= enabled (Space Time Block Coding: revela tambem algumas melhorias na velocidade e, por isso, deixei activado)


frameaggregation:= ampdu (aqui é simples ampdu significa maior velocidade; amsdu maior fiabilidade - vejam o que resulta melhor no vosso caso)


radio_id= (Não é relevante, deixem em branco que assume o valor ja existente)


 


E pronto.. já está!.. tecla tab e confirmem com "OK" na barra em baixo.


 


O router irá agora repor o wireless com as novas configuraçoes. O vosso pc deverá perder conectividade por 1s ou 2. NAO REINICIEM O ROUTER DE MODO ALGUM!!.. Ainda dentro do menu "wireless" pressionam a tecla tab e, seleccionem o botão "Cancel". Depois, de volta à raiz é só digitar o comando 'saveall' e dar Enter...


 


http://s15.postimg.org/7bpqvozkb/telnetfim.jpg


 


Aguardar uns segunditos.. Por fim, comando 'exit', duas vezes, para sair da sessão telnet e linha de comandos. Isto foi o que consegui de melhor até agora.


 


Espero que tenha sido útil a esta comunidade. :)


 


Não se esqueçam de fazer "Like" e continuem a dar o vosso precioso feedback! 😉

172 respostas

Reputação 5
Finalmente disponivel para a malta. :)

Estive só a fazer algumas pequenas correcçoes de ultima hora. De agora em diante vou alterando conforme se verifiquem outros resultados melhores que o que obtive. De salientar que o router pode exibir velocidades NAO REAIS na interface web. Qualquer teste que façam, obviamente terá de ter outros elementos em conta. Mas fico a aguardar os vossos posts. 😉
Será que este excelente tutorial também se aplica para o TG784?! Em wireless não consigo mais de 20Mbps quando em LAN obtenho o referente ao pacote MEO Fibra 30.
Finalmente disponivel para a malta. :)

Estive só a fazer algumas pequenas correcçoes de ultima hora. De agora em diante vou alterando conforme se verifiquem outros resultados melhores que o que obtive. De salientar que o router pode exibir velocidades NAO REAIS na interface web. Qualquer teste que façam, obviamente terá de ter outros elementos em conta. Mas fico a aguardar os vossos posts. ;)

Obrigado pelo tutorial, mas a password de microuser no meu não funcion, tenho o ultimo firmware 1021d mas não sou m30 será por isso?
Reputação 5
Obrigado pelo tutorial, mas a password de microuser no meu não funcion, tenho o ultimo firmware 1021d mas não sou m30 será por isso?

Se não és MEO és quê, já agora?.. Se não és MEO tens de tentar obter o user e pass de accesso root por outra fonte, lamento mas não tenho como te ajudar nisso de momento.

Será que este excelente tutorial também se aplica para o TG784?! Em wireless não consigo mais de 20Mbps quando em LAN obtenho o referente ao pacote MEO Fibra 30.

Amigo, depende de muita coisa. Da configuraçao da tua rede, para começar. Se tens mais routers em ponte ou não. Distancia e obstáculos entre estaçôes... E aliás esse router se for mesmo o TG784, como dizes, parece me trabalhar apenas com a norma wireless G, ou seja, está logo à partida limitado a 54Mbps.

Não sei, eu no geral acho a Thomson/Technicolor uma grande trafulhice. Se forem consultar as espcificaçoes de qualquer modelo de router no site oficial eles nunca mencionam valores nenhuns de velocidades wireless. São capazes de espetar lá com logotipos todos pipis a fazer referencia a capacidade de trabalhar com varias normas incluindo a N e outra paneleirices só para "inglês" ver e depois nas especificações não tem nada de concreto e afirmativo. Pior, ainda se metem com rodeios da treta do tipo "Dynamic rates switching for optimal wireless rates" e outras cenas do género.

De qualquer forma tentem aceder por telnet ás configuraçoes avançadas do wifi. Não garanto que lá encontrem exactamente os mesmos parametros que no meu exibiu, nem que alteraçoes a esses parametros surtem melhor efeito para o vosso caso. Mas se postarem aqui as vossas duvidas eu vou ajudando no que poder. 😉
Se não és MEO és quê, já agora?.. Se não és MEO tens de tentar obter o user e pass de accesso root por outra fonte, lamento mas não tenho como te ajudar nisso de momento.



Amigo, depende de muita coisa. Da configuraçao da tua rede, para começar. Se tens mais routers em ponte ou não. Distancia e obstáculos entre estaçôes... E aliás esse router se for mesmo o TG784, como dizes, parece me trabalhar apenas com a norma wireless G, ou seja, está logo à partida limitado a 54Mbps.

Não sei, eu no geral acho a Thomson/Technicolor uma grande trafulhice. Se forem consultar as espcificaçoes de qualquer modelo de router no site oficial eles nunca mencionam valores nenhuns de velocidades wireless. São capazes de espetar lá com logotipos todos pipis a fazer referencia a capacidade de trabalhar com varias normas incluindo a N e outra paneleirices só para "inglês" ver e depois nas especificações não tem nada de concreto e afirmativo. Pior, ainda se metem com rodeios da treta do tipo "Dynamic rates switching for optimal wireless rates" e outras cenas do género.

De qualquer forma tentem aceder por telnet ás configuraçoes avançadas do wifi. Não garanto que lá encontrem exactamente os mesmos parametros que no meu exibiu, nem que alteraçoes a esses parametros surtem melhor efeito para o vosso caso. Mas se postarem aqui as vossas duvidas eu vou ajudando no que poder. ;)

eu sou meo, não sou é meo m30 ou m40 como diz na tua password... sou só total 100.
Reputação 5
Apesar do estranho problema em aparecer o tópico, aqui está ele!
Obrigado pelo tutorial 😉
Reputação 5
Obrigado pelo tutorial, mas a password de microuser no meu não funcion, tenho o ultimo firmware 1021d mas não sou m30 será por isso?

eu sou meo, não sou é meo m30 ou m40 como diz na tua password... sou só total 100.

Ah ok.. Eu tb nao sou M30!..lol.. tenho é o M4O Fibra!.. E acho que aquilo da pass quer mesmo dizer MEO, amigo. Enfim...

Nesse caso, não faço ideia, talvez o burgesso do técnico que te activou o serviço tenha mudado na altura a pass do microuser, por sabe se lá qual a razão. Já acredito em tudo, os gajos têm uma terrivel tendencia para serem "brasileiros". Mas já tentaste usar os users e passwords que se vêm aí pela net fora e incluindo neste forum?.. Tenta mesmo com o SuperUser: sumeo pass: bfd,10ng. Deve te dar acesso as mesmas opçoes de configuraçao. Senão tenta outro qualquer ou experimenta outra password que encontres. Eu por exemplo, para o sumeo, a primeira password que encontrei não serviu. Parece que eles vão mudando as pass de vez em quando, conforme os routers e os FWs, não sei, isto tambem ainda é um pouco novo para mim. Mas tou a fazer progresso... ;)

users e paswords MEO aqui!
Amigo, depende de muita coisa. Da configuraçao da tua rede, para começar. Se tens mais routers em ponte ou não. Distancia e obstáculos entre estaçôes... E aliás esse router se for mesmo o TG784, como dizes, parece me trabalhar apenas com a norma wireless G, ou seja, está logo à partida limitado a 54Mbps.

Não sei, eu no geral acho a Thomson/Technicolor uma grande trafulhice. Se forem consultar as espcificaçoes de qualquer modelo de router no site oficial eles nunca mencionam valores nenhuns de velocidades wireless. São capazes de espetar lá com logotipos todos pipis a fazer referencia a capacidade de trabalhar com varias normas incluindo a N e outra paneleirices só para "inglês" ver e depois nas especificações não tem nada de concreto e afirmativo. Pior, ainda se metem com rodeios da treta do tipo "Dynamic rates switching for optimal wireless rates" e outras cenas do género.

De qualquer forma tentem aceder por telnet ás configuraçoes avançadas do wifi. Não garanto que lá encontrem exactamente os mesmos parametros que no meu exibiu, nem que alteraçoes a esses parametros surtem melhor efeito para o vosso caso. Mas se postarem aqui as vossas duvidas eu vou ajudando no que poder. ;)

O Router é o TG784 com toda a certeza, nem percebi a dúvida em relação a isso... De qualquer forma é o único router que tenho, o portátil está a cerca de 2 metros de distância do router.

Em relação à norma "g" ou "n" não é relevante para o que perguntei, a velocidade que tenho contratada é 30/3 Mbps ainda a alguma distância dos 54 Mbps em wireless pela norma "g".
Reputação 5
As vezes, o ppl confunde os aparelhos quando existem com nomes muito parecidos (tg784,tg784n - só muda uma letra), dai a razao da incerteza.

Mas só tens mesmo esse router ligado em casa? Ou tens algo mais a usar a banda wifi 2,4GHz nas imediaçoes, vizinhos com wifi, nada? Se tens, certifica te que distancias os 2 aparelhos bem um do outro e usa canais distantes, tipo 1 e 11. Senão for isso, mantem se o que disse, tenta aceder por telnet e alterar as configurações do radio. Alguma duvida, posta aqui.
Ah ok.. Eu tb nao sou M30!..lol.. tenho é o M4O Fibra!.. E acho que aquilo da pass quer mesmo dizer MEO, amigo. Enfim...

Nesse caso, não faço ideia, talvez o burgesso do técnico que te activou o serviço tenha mudado na altura a pass do microuser, por sabe se lá qual a razão. Já acredito em tudo, os gajos têm uma terrivel tendencia para serem "brasileiros". Mas já tentaste usar os users e passwords que se vêm aí pela net fora e incluindo neste forum?.. Tenta mesmo com o SuperUser: sumeo pass: bfd,10ng. Deve te dar acesso as mesmas opçoes de configuraçao. Senão tenta outro qualquer ou experimenta outra password que encontres. Eu por exemplo, para o sumeo, a primeira password que encontrei não serviu. Parece que eles vão mudando as pass de vez em quando, conforme os routers e os FWs, não sei, isto tambem ainda é um pouco novo para mim. Mas tou a fazer progresso... ;)

users e paswords MEO aqui!

o sumeo funciona, tb dará para fazer essas alterações?
Reputação 5
Tentar não deve doer, digo eu.. :)

Segue as minhas indicaçoes em cima. Os thomson são mt parecidos por isso não deve ser mt dificil de associar e equivaler o gerenciamento de um modelo com o outro. Alguma duvida, posta aqui.

Entretanto vou alterar o tutorial e adicionar lá o user sumeo para evitar que mais alguem, não o tenha ou não saiba usa-lo tambem.
Reputação 5
Actualizaçao: Tópico fixo e movido para zona mais apropriada do fórum. Actualizei tambem os links já existentes para este tutorial.
Essa velocidade de download dá para melhorar. Mas por norma é necessário a PT reconfigurar o acesso de internet um pouco acima do contratado. Por exemplo, se configurarem a conta de cliente a 115 megas, a velocidade já dá 100-105... Infelizmente,mesmo nós técnicos não conseguimos ajuda por parte do nosso suporte técnico de forma a fazer essa configuração para todos os clientes...
Reputação 5
Muito bem, Marco. E, verdade seja dita, estou bem contente com os 91/20 megas.. ;)

Mas o que está em discussão é a capacidade ou não de um dispositivo wireless N, que é a parte router wifi deste modem DSL/gateway fibra, de fornecer acesso dentro da sua rede local (entre um PC e um tablet por exemplo) com velocidades dignas de se atribuirem à norma 802.11n (até 300Mbps, em muitos routers), e não a velocidade de acesso internet da fibra em si.

Mas compreendo que não seja possivel aos técnicos fazerem certo tipo de alterações na hora. Já me é suficientemente claro, após alguns dias de uso do MEO M4O, que a PT restringe, sufoca aliás, os seus equipamentos com firmwares pouco desenvolvidos ou propositadamente limitados, topologias de rede excessivamente rectilineas, protecçoes e protocolos em demasia, etc...

Eu próprio, não pude fazer esta alteração, explicada no tutorial, antes da actualizaçao de firmware para a versao 10.2.1.D, pois os parâmetros essencias não apareciam sequer na sessão Telnet! Enfim... O uso deles da marca Thomson tambem não ajuda muito.
Infelizmente tens razão... Penso que já estava mais que na horinha da PT investir num outro tipo de equipamento, mais capaz, para fazer face ás novas exigencias dos utilizadores. Quanto á questão da velocidade máxima só a referi porque alguém menciou o "problema" da net apenas chegar aos 90's e tal 🙂
Boas amigo xapt3r5, Desde o meu obrigado pelo manual. Já estive a fazer as alterações, e não encontrei nenhuma melhoria...! Em relação há velocidade... acho que sendo bem conversado, se consegue a velocidade contratada! Eu tenho o tarifario 100 total e tenho 100MG reias!

Abraço
Reputação 5
Boas. Se não encontraste melhoria (e aposto que não serás o unico), pode dever se a uma série de factores.. Um deles, se calhar o mais emergente, é o uso de dispositivos wireless, totalmente ou parcialmente não compativeis com a norma 802.11n. Ou simplesmente o uso da norma 802.11g. Como referi no tutorial, eu criei 1º as condiçôes ideais para o teste (tudo norma N, apenas uma estaçâo wifi ligada ao router, sem qualquer interferencia de outros aparelhos 2,4GHz na proximidade, etc..)! Afinal, isto até é um pouco mais complexo que aceder a uma interface e simplesmente alterar valores de configuração.

Cria as condiçoes, tal como eu. Tenta ainda trocar parametros diferentes ligados e/ou desligados, como disse no tutorial, e vê o resultado... Não te posso valer muito mais amigo.

Aliás eu já fiz mais testes entretanto, pesquisei um pouco mais e cheguei à conclusão que este tg799vn, na melhor das hipoteses, e em condições ideais, quando não existem grandes flutuações no sinal de radio-frequencia, dá aí 100-110Mbps no máximo dos máximos, por wifi. Tem a ver com a multiplexagem, que é fraquissima para um router associado a este tipo de serviço, segundo a minha pesquisa. Este router faz uso de uma unica antena de Transmissão-Recepção (interna ainda por cima), enquanto os mais avançados têm até 3 combinadas, em simultâneo (os que dão 300Mbps, certamente).

OFF-TOPIC: Quanto à velocidade da fibra, volto a referir, estou satisfeito com os 90/20Mbps. Já li, (inclusive neste forum), discuti e reflecti o que tinha a reflectir sobre as voltas e reviravoltas que o pessoal dá, quando se queixa que não tem os "100 Megas garantidos" e, sinceramente, acho uma tolice.
tenho o thomson tg799vn e vou fazer isso que publicaste. só uma duvida: onde dizes " := disabled (Cyclic Delay Diversity: não melhorou velocidade, pelo que parece é uma tecnica de evasao às interferências, util talvez para quem tenha mais routers wifi na vizinhança. deixei desligado)", é assim apanho aqui umas 20~25 redes dos vizinhos. Que me aconselhas? Obrigado desde já pelo tutorial 😉
Amigo, desculpa lá o negrito...é uma questão de habito! A PEN que uso para teste é esta:
SMC WUSBS 150mbps N wireless USB Adapter. Porque eu tenho o PC ligado por cabo na saída 1GB.
No Router a velocidade máxima que aparece é de 54MG, mas pelo menos nesse aspeto melhorou algo porque antes oscilava bastante... tinha alturas que só aparecia 12 MG!

Abraço
Reputação 5
tenho o thomson tg799vn e vou fazer isso que publicaste. só uma duvida: onde dizes " := disabled (Cyclic Delay Diversity: não melhorou velocidade, pelo que parece é uma tecnica de evasao às interferências, util talvez para quem tenha mais routers wifi na vizinhança. deixei desligado)", é assim apanho aqui umas 20~25 redes dos vizinhos. Que me aconselhas? Obrigado desde já pelo tutorial ;)

Aconselho-te a experimentar. Experimentas 1º, uns 2 ou 3 dias com isso desligado e depois ligado. Cria as condições melhores que for possivel, e faz o teste. Depois no fim comparas e vê o que serve melhor. Mas talvez seja bom ligado no teu caso. Só tu podes confirmar isso!

Amigo, desculpa lá o negrito...é uma questão de habito! A PEN que uso para teste é esta:
SMC WUSBS 150mbps N wireless USB Adapter. Porque eu tenho o PC ligado por cabo na saída 1GB.
No Router a velocidade máxima que aparece é de 54MG, mas pelo menos nesse aspeto melhorou algo porque antes oscilava bastante... tinha alturas que só aparecia 12 MG!

Abraço

A pen USB wifi que usas é suficientemente boa. No entanto é susceptivel de emitir/receber pior o sinal tal como é o TG799vn, por ter uma antena interna de baixo ganho, em maiores distâncias. Mas mesmo se estiveres perto do router, o simples facto de teres ligado outro dispositivo da norma G ao router, pode gerar uma queda na velocidade da comunicaçao, pois o router tem de compensar pela sua fraca capacidade a gestão de várias normas entre si. Eu, quando ligo um PC com wireless 802.11g ao thomson tambem verifico, mais ou menos, a mesma queda de sinal.
Mas, independentemente disto tudo, se estás a usar cabo ethernet, não vejo porque tenhas de te preocupar com alguma coisa amigo...
Ok vou experimentar então. No entanto deixo-te uma imagem das redes wireless que apanho aqui. Só para dares uma vista de olhos
Ty pela ajuda mano
PS: onde ves a setinha é a minha rede
Obrigado amigo pela resposta, resumindo e concluindo... o Router é fraquito!

Em relação ao ter ligado o wireless, preciso dele ligado porque tenho outros aparelhos que funcionam dessa forma, e um com alguma distancia! O cabo de rede foi só para dar um exemplo... porque a maquina que eu estou mais tempo funciona dessa forma!

Abraço
Reputação 5
Aproveito para deixar aqui, para quem é curioso, o link do post com que fechei o tópico que me levou a criar este tutorial. Fala das razoes que levam a que o TG799vn e os Thomson no geral não sejam grande coisa e, tem links interessantes sobre essa mesma matéria:


Wireless no Router Thomson TG799vn[/b]
Aproveito para deixar aqui, para quem é curioso, o link do post com que fechei o tópico que me levou a criar este tutorial. Fala das razoes que levam a que o TG799vn e os Thomson no geral não sejam grande coisa e, tem links interessantes sobre essa mesma matéria:


Wireless no Router Thomson TG799vn[/b]

Boas,

Existe alguma forma de fazer save por telnet, depois de fazer as alterações que postaste aqui notei algumas melhorias de facto, mas, sempre que desligo o router e volto a ligar perde essas definições.

Obrigado.
Reputação 5
Existe pois! E fico agradecido por me teres lembrado isso. Por acaso não tive em grande conta uma possivel lacuna no firmware do Thomson, que obriga a salvar a configuração manualmente, após a alteração de parâmetros. Aqui vai:


Depois de configurares de novo as opções do radio, ainda na sessão telnet, dentro do menu "wireless" pressiona a tecla tab e, selecciona o botão "Cancel".

Depois, de volta à raiz é só digitar o comando 'saveall' e dar Enter...

Aguardar uns segunditos.. Por fim, 'exit' duas vezes para sair da sessão telnet e da linha de comandos.

Confirma, por favor, se fez alguma diferença ou ficou igual e posta aqui depois. De qualquer forma vou acrescentar este detalhe ao tutorial. Muito obrigado pelo feedback. 🙂

Responder