Pergunta

Qual o nome do domínio da rede que o router fiber gateway gr241ag tem na lan doméstica?

  • 12 Julho 2019
  • 21 respostas
  • 318 visualizações

Crachá +3
Vivam,

Gostaria de configurar um pi-hole para filtrar a publicidade indesejada a partir da lan.

A páginas tantas precisava de usar os FQDN presentes na rede entre os quais se encontra o nome do domínio que o router da meo predefine.

Como saber este elemento do FQDN que o router da meo estabelece?

Obrigado pela ajuda.

21 respostas

Crachá +3
Boas,

meo.Home sendo "Home" o que pretende.
Crachá +3
@Dtaven Obrigado.
Crachá +3
@Dtaven Obrigado.
De nada. Se conseguir colocar a funcionar diga-me porque eu estou com sérias dificuldades (Web inferface do router lenta e TV com paragens)
Crachá +3
@Dtaven Ok.

Assim farei.

Ainda não conclui a configuração do Pinhole.

Pelo que entendi refere-se ao router e IPTV do isp MEO.

Estou certo nesta assumpção?

Ou está também a referir-se ao pihole?

Cumprimentos e até já.
Crachá +3
Sim, está correcto.

Eu já o tinha configurado e mudei de operador e agora dá tais problemas quando o ponho como DHCP
Crachá +3
@Dtaven Viva,

Acabei agora de configurar o meu Pi-Hole. Neste momento está a funcionar.

Quer detalhar quais as dificuldades?

Isto é,

1.º Onde e como configurou o pi-hole como dhcp server?

Nota. Curiosamente, eu também uso o pi-hole como servidor dhcp. A curiosidade aqui é que ele usou o nome do domínio de fábrica. (Eu não o alterei na secção correspondente, julgo que perto da configuração para ativar o servidor DHCP do pi-hole). ou seja tenho dois domínios para os equipamentos que uso. O domínio lan e o domínio local consoante os equipamentos que se conectem usem o protocolo dhcp ou ip estático, (e estejam configurados para usar uma dessas "tecnologias" pois não estou certo de qual a especificação que os meus equipamentos reconhecidos usam, se avahi-bonjour, se mdns etc..)

Posso confirmar que tenho o IPTV (box) a funcionar e todos os restantes equipamentos também. Talvez haja uma latência extra mas, atualmente, não me está a incomodar.

Resumindo: servidor pi-hole como servidor dhcp e (indirectamente por essa forma) como servidor/bloqueador dns. Para poder ter isto ativo, tive que, em primeiro lugar, desativar o servidor dhcp do router meo.

Até já.
Crachá +3
O meu também funciona mas ao fim de +/-24H começa a TV a parar e dar "Serviço indisponível".

Já o router mal desactivo DHCP e o activo-o no Raspberry fica com a interface WEB lenta (chega a demorar os 10s a mudar de página). Tudo o resto funciona bem.

Na minha rede continuo a usar o domínio antigo só tendo acrescentado o "Local domain name" no "Use Conditional Forwarding".

Não sei se não te nada a ver com o IPV6 que não usava antigamente. Se, até amanhã, não tiver problemas diga-me que eu tento configurar tudo a partir do zero.

Obrigado
Crachá +3
@Dtaven

Ok, de acordo. Mas ainda antes diga que setup usa neste momento como pi-hole.

Percebi que é um raspberry pi. Eu estou a usar um também, mas em que o rootfs está num disco externo. Trata-se dum pi 2 b+. O sistema base implantado era o osmc. Mas, por agora está apenas como pi-hole e cli music player (mpv e ffmpeg com alsa). Tive dificuldade em instalar o pi-hole porque apesar de ter o pi com ip estático, ele (o pi) tinha dois dns. Agora tem só um dns externo e nenhum dns interno. (entenda-se da lan). Suspeito que: OU vou ter a mesma lentidão que o @Dtaven ou que o @Dtaven terá que colocar o rootfs num aparelho mais rápido e com maior capacidade (se se confirmar que está a usar o pi com um micro sd).

Se nenhuma das hipóteses que coloquei for a sua (e ainda que alguma ou todas estejam correctas), experimente colocar o nome de domínio original ("lan" se não estou em erro), nas definições do pi-hole.

Último pedido, (visto que a minha "memória" está bastante "volátil" 🙂 ), se eu não reportar algo amanhã, tal como combinado, agradeço que poste nova mensagem neste tópico para me convocar.

Entretanto, cumprimentos, e até já.
Crachá +3
@Dtaven

Bom dia.

O meu sistema está operacional.

Por definição, no entanto, o sistema não está ligado 24/24.

E o seu?

Cumprimentos.

Até já.
Crachá +3
Bom dia,

Não. Diga-me só uma coisa tem o IPV6 activo tanto no DNS como no DHCP?

Acho que vou tentar a configuração desde o zero.

Obrigado pelo feedback

Cumprimentos
Crachá +3
Olá de novo @Dtaven

Aqui lhe envio as configurações que serão pertinentes em relação ao ipv6.

Como pode ver, a única alteração que fiz a este nível foi a de ativar a check box "enable ipv6 support (slaac ra).

Confirme que colocou o DHCP do router MEO inativo, sff

Até já.


Crachá +3
Pois. Tenho tudo na mesma desconfio que é mesmo a configuração de rede do Raspberry.
Vou "formatar"

Muito obrigado pelo feedback

Abraço e mais vez obrigado
Crachá +3
@Dtaven

Lembrei me de uma coisa...

Quantos IP tem como DNS no raspberry?

E quais?

E, por último, qual é o serviço responsável pela configuração da sua ligação à rede no raspberry?

Curiosamente ou não os seus problemas começam com o fim das 24 horas do lease, certo?

P.s. coloquei (acidentalmente) a definição de solução no seu post, não sei como retirar... ;-)

Até já
Crachá +3
@mccurly

Bom dia,


Mais uma vez obrigado pela ajuda. Ao fim de muitos testes cheguei a uma conclusão:
É o router!
Esperimentar desligar o Raspberry , colocar IP fixo na minha máquina e desligar o DHCP.
A Interface WEB começa logo a "patinar"...

Acho que vou abrir aqui outro tópico a ver se alguém me ajuda.

Cumprimentos
Crachá +3
@Dtaven Bom dia.

Não tem que agradecer. Mas antes desse "desespero" responda pf. qual é o Sistema Operativo (distribuição) que tem no seu pi e qual o serviço (do systemd ou outro) que tem para controlar a rede nesse SO / distro.

No meu caso, como lhe disse antes (julgo eu) tenho um osmc para o raspberry pi 2. No fórum da osmc desaconselham o pi-hole nesta distro. Mas eu teimei e consegui. Nessa distro o serviço responsável pela gestão da net é o connman (se não estou em erro). Segundo este post dum thread do forum da osmc , indicará, nesse caso algo que poderá tentar @Dtaven.
Eu lembro-me que o meu pi tinha problemas ao aceder à net quando, ao correr o commando
connmanctl services
ele (para além da informação esperada, não me fornecia os dns que eu lhe tinha colocado no interface do pi-hole mas sim os dns que tinha colocado na app myosmc dentro do gui. Por isso corri o segundo comando:
connmanctl config EthernetName ipv4 manual address netmask gateway
(em que os 3 últimos elementos ficam ao seu "encargo"), ao mesmo tempo que, dentro da app myosmc desactivei os dois dns que tinha (e verifiquei que ele aceitava estas configurações em tempo real pois a app retornou o status "connected" de imediato, ao contrário de quando usava dois dns externos e ele me dava o status como disconnected), e ainda... usei o mesmo dns na configuração do pi-hole.

Resumindo: usar o mesmo dns (um só), no connman e esse mesmo dns no pi-hole.

Espero que assim consiga finalmente resolver o seu problema.


Cumprimentos,

Até já.
Crachá +3
Só pode ser o Router.
A única coisa que preciso fazer para ele começar a demorar 10s a mudar de página é desligar o DHCP (mesmo tendo o Raspberry desligado e, claro, com IP manual na máquina).

Quanto ao Raspberry instalei a última versão do Raspbian e sem mais configurações instalei o PI-hole para obter exatamente o mesmo resultado.



Cumprimentos
Crachá +3
@Dtaven olá.

Sim sou forçado a concordar que o problema terá outra razão além do pi.

Nesse caso já pensou em colocar o router nas definições originais de fábrica?

Diga depois o que se passará.

Os melhores cumprimentos e até já.
Crachá +3
Também já fiz tal. Assim que desligo o DHCP fica "todo maluco" 🙂
Crachá +3
Olá @Dtaven ,

vou partilhar aqui as minhas confs da interface WAN do router meo.

Assumo que o problema da lentidão na resolução de nomes seja na WAN também, certo?

Compare sff.


Cumprimentos e até já
Crachá +3
Bom dia @Dtaven .

Em jeito de "epitáfio" ao nosso tópico, tentei desabilitar os dois servidores DHCP que tinha na minha rede (o pi-hole e o router da meo, que está desabilitado por defeito quando o pi-hole está a trabalhar) e não tive qualquer problema de navegação.

Entretanto visto que tenho mais do que um router na (sub)rede da minha casa, embora todos eles estejam sem o serviço de dhcp ativo, coloco a questão (a mim próprio pelo menos) se isso terá tido influência no desempenho interno da minha rede. (Note-se que os equipamentos testados estavam todos dentro da gama de E com ips fixos)

Por isso, @Dtaven o questiono: tem mais algum roteador na sua (sub)rede?

Em caso negativo coloque seriamente em jogo a hipótese de contactar com o 16902 e expor o seu problema por esse canal. Ou criar um pedido de ajuda no seu "mymeo". Ok?

Por ora é tudo....

Cumprimentos e "até já".

🙂
Crachá +3
Não tenho. Enviei por pm video.

Responder