Resolvido

Portforwarding TECHNICOLOR TG784n V3

  • 30 November 2013
  • 58 respostas
  • 166796 visualizações

Reputação 1
 


-----------------------------------------------------------------------------------


Para o firmware 10.2.1.L ver solução na página 3 deste tópico ...


 -----------------------------------------------------------------------------------


 


Boas, Deixo aqui o único método que consegui para fazer eficazmente o portforwarding no TECHNICOLOR TG784n V3.


 


Passo 1: Aceder à gestão do TECHNICOLOR (http://192.168.1.254) com user debug ver este tópico - post do user lfernandes


 


Passo 2: Criar um utilizador próprio com permissões de rootuser ver este tópico - obrigado xptopt


 


NOTA: Eu neste passo quando editava e gravava o user.ini em windows7 após o upload do ficheiro para o router, este quando reiniciava, não arrancava mais. Só após reset físico. Só consegui este passo quando o editei numa máquina virtual em linux.


 


Passo 3: Criar os portforwardings necessários na gestão do TECHNICOLOR (http://192.168.1.254)


 


Passo 4: Entrar em telnet no router (telnet 192.168.1.254) com o utilizador criado nos passos anteriores.


 


Escrever: menu


(Carregar na tecla TAB, cursores e ENTER para seleccionar)


No menu seleccionar a opção :NAT


Selecionar a opção: mapadd


 


Nota: As opções que não mencionar aqui deixei em branco.


intf = Internet


type= NAPT


inside_addr = IP DO VOSSO EQUIPAMENTO - C1 na imagem (exemplo: 192.168.1.60)


protocol = tcp


outside_port = PORTA EXTERNA (11111) ou GAMA DE PORTAS (11111-11122)


inside_port = PORTA INTERNA (11111) ou GAMA DE PORTAS (11111-11122)


mode = inbound


 


Tab para ok, e cancel ate sairem do menu.


Na linha de comandos (ainda em telnet):


saveall


exit


 


Passo 5: Configurar o serviço de DNS dinâmico e desligar a Firewall (na gestão do TECHNICOLOR). -------------------------------------------------------------------------------------- http://www.ideianet.pt/rede_meo0.jpg No meu caso como necessito de ter várias redes isoladas umas das outras em vez de ter os equipamentos ligados directamente no TECHNICOLOR, tenho 2 routers CISCO LINKSYS ligados ao TECHNICOLOR e que depois me criam as várias redes que preciso. A minha rede é a seguinte: http://www.ideianet.pt/rede_meo.jpg Equipamento A


WAN : IP MEO (ONT)


TECHNICOLOR TG784n V3


DHCP ON - 192.168.1.60 a 192.168.1.253


Firewall OFF


 


Equipamento B


WAN : 192.168.1.61 (TECHNICOLOR DHCP)


CISCO WRT160Nv2


DHCP ON - 192.168.11.100 a 192.168.11.149


Firewall ON


 


Equipamento C


WAN : 192.168.1.60 (TECHNICOLOR DHCP)


CISCO E3200 DHCP ON - 192.168.10.200 a 192.168.10.219


Firewall ON


 


 


Inicialmente no lugar do WRT160Nv2 tinha um SMC, e não sei se devido ao sinal da MEOBOX vir na rede ou não, sempre que o ligava a MEOBOX ficava "aos soluços" e a rede instável. A única solução que encontrei foi substituir o SMC pelo WRT160Nv2.


 


Ficou logo tudo 5 estrelas !


De qualquer modo isto indica que nem todos os equipamentos (routers) servem para esta topologia.


 


Para uma rede (como a minha), para além dos passos descritos acima, é necessário:


- Configurar o 2º router para uma gama de IPs diferente do TECHNICOLOR (ex: 192.168.10.x)


- Ligar um cabo de rede da LAN do TECHNICOLOR à porta WAN do 2º router


- Configurar o tipo de ligação para a porta WAN do 2º router como IP (DHCP)


- Configurar no TECHNICOLOR todos os portforwardings para o 2º router (método descrito em cima)


- Configurar no 2º router os portforwardings para os equipamentos finais (PCs, Consolas, etc) - Ligar a segurança no 2º router (firewall, etc)


 


Caso haja mais routers (3º, 4º ...) repetir estes passos para cada um deles ... (mudando a gama de IPs)


 


De fora (internet) faço WOL e administração remota (software Radmin) ao Equipamento C1 e tenho acesso por FTP (modo passivo que necessita de uma gama de portas) ao Equipamento C2 (servidor de FTP). Também tenho acesso à gestão do Equipamento B. No Equipamento C1 tenho o emule com as portas TCP e UDP OK. A MEOBOX está ligada directamente ao Equipamento C sem qualquer tipo de configuração adicional e mantêm todas as funcionalidades (MUSICBOX, etc.). Isto tudo a funcionar sem qualquer tipo de interferência ou instabilidade.


 


Espero que esta informação seja de alguma utilidade para alguns utilizadores.


 


Abraço,


Nunex70


 


P.S. Atenção para não utilizar portas que sejam necessárias aos serviços ! Abrir ou alterar essas portas pode criar conflitos no sistema !
icon

Solução por nunex70 2 February 2015, 14:01

Ver original

Tópico fechado, já não permite mais respostas.

58 respostas

Ninguém!?


 


Deve ser mesmo complicada então a questão que coloquei...


Obrigado na mesma à comunidade "Meo Fórum"
Boa tarde!

 

Fiz tudo o que foi referido para fazer Portforwarding ao TECHNICOLOR TG784n V3 com o software 10.2.1.L, como explicado pelo Nunex na página 3 deste tópico, mas nada! Tudo pafrece resultar bem, ou seja sem erros de resposta.

O que eu pretendo fazer não é aceder a nenhum equipamento dentro da minha rede mas sim ao mesmo router, para poder controlar açgumas coisas á distãncia tal como quando o posso fazer quando estou dentro da rede.

Por isso neste comando telnent que o nunex indicou, eu coloquie o endereço do equipamento ao qual pretendo aceder, o router. technicolor

code:
tmpladd type=napt outside_addr=0.0.0.1 inside_addr=192.168.1.254 outside_port=5500 inside_port=5500
 

Desactivei a firewall, tudo certinho. Mas continuo a não conseguir aceder ao router de fora da rede...

 

Agradecia ajuda se possivel. Obrigado desde já.

 
Reputação 6
Crachá +10
Olá ?


 


Não é necessário enviar mensagem privada para esse efeito. Não estou disponivel para o assistir remotamente, lamento.


 


Já experimentou usar uma porta de saida ( converter em...) diferente da de entrada?


 


Não se esqueça que deve configurar novamente as portas tanto no servidor como no cliente, caso decida usar diferentes das standard.


 


Configure portas ou intervalos de portas diferentes para cada servidor. Aqui está um manual de utilizador de uma camara IP Pixord 207: http://api.ivv-aut.com/adp/22%20-%20CCTV%20IP/2222%20-%20C%C3%82MARAS%20DE%20V%C3%8DDEO%20IP/222210%20-%20C%C3%82MARAS%20DE%20CORPO%20PROFISSIONAIS/22221005%20-%20COM%20LENTE%20INCORPORADA/22221005000098%20-%20PIXORD%20207/P201_207_manual_util_EN.pdf


 


Não sei se é o seu modelo, já que não especificou, mas penso que a configuração seja identica. Pode observar na página 37 do manual acima, as definições para o DDNS. Aqui terá de configurar as portas de acordo com o que estableceu na 'Partilha de jogos e aplicativos', no router MEO.


 


Reveja os parametros e tente de novo.


 


Atentamente,
Restaurei definições de origem, voltei a fazer tudo de novo, primeira camera porta 90 tudo ok, vou fazer o mesmo para a segunda camera atribuo a porta 75 e nada, alias vou verificar as portas e a 90 aberta e 75 fechada, como é isto possivel


??



 
Reputação 6
Crachá +10
kostinha escreveu:

 


...As portas que tento abrir 8080; 75; 88



 


Quais as de entrada e de saida?


 


Certifique-se que a porta de entrada para a segunda camara é diferente da de entrada da primeira, uma vez que está a criar dois servidores em simultaneo e, o router MEO reserva permanentemente as portas que estão a ser solicitadas pelo servidor, mesmo que não esteja a receber o feed dessa ligação.


 


exemplo:


 


camara 1





camara 2





 


 


Dica: evite o uso de portas http ou outras genéricas (ex: 80, 8080), pois as mesmas já são amplamente requeridas por inumeros serviços na rede.


 


 


Atentamente,
Boas uma das cameras uma foscam que funciona na prefeição sem problemas depois de seguir o tutorial para abrir portas.


A outra uma pixord para a qual segui os mesmos procedimentos da anterior e nada de nada, criei para ela 3 com portas diferentes e nada de nada, se for na rede interna funciona bem, com qualquer das portas que abri, mas para a visualizar de uma outra rede nada de nada. Eu apenas uso o router da meo o Technicolor TG784n v3.


As portas que tento abrir 8080; 75; 88
Reputação 6
Crachá +10
Olá ?


 


Qual a marca e modelo das camaras? Quantos routers usa na sua rede e quais as marcass e modelos? Quais são as portas que está a tentar abrir?


 


Atentametne,
Boas malta ver se alguem me consegue ajudar, pois estou a ter dificuldades em abrir uma porta, o problema é o seguinte. Possuo 2 ipcam, as quais funcionavam às 5 maravilhas com o meu anterior fornecedor de ineternet, passei agora para  meo fibra, e tentei seguir os tutoriais para fazer o port forward para as cameras, a primeira segui os passos todos, e funciona nas maravilhas, vou fazer procedimentos iguais para a segunda com uma porta diferente da anterior e nada, já tenteo abrir diferentes e nada, não consigo de nehuma maneira, e quando vou verificar se as postas estao abertas, dá sempre postas fechadas, e na primeira dá como estando aberta e claro tudo funcional. Alguma dica por ai?
Desde ja obrigado pela resposta.

Sempre tive especial interessa por TI em geral porem não tenho nenhuma formação profissional nem nada que se pareça.Queria começar a ter umas aulas de CCNA,mas se me souber recomendar algum outra coisa ficaria agradecido.De qualquer forma obrigado pelo tempo despendido e pela informação prestada nos posts,não se limitando apenas a responder à questão inicialmente colocada.

Regressando então à duvida inicial,qual é a forma mais simples de fazer Port Fowarding num router da MEO?

Obrigado 

 
Reputação 6
Crachá +10
?


 


Faltou dizer que o UPnP só servirá, se o software de administração remota integrar esse protocolo, caso contrário terá mesmo de fazer a abertura manual.


O NAT (network address translation) é apenas necessário no dispositivo que serve de gateway (normalmente o router MEO), numa topologia tipica de LAN caseira simples, em que há um unico anfitrião ou gateway de acesso à WAN e, o resto são, ou switches, ou acess points (sem controlo avançado de portas/protocolos). 


 


Normalmente, quem pretende ter acesso remoto, quando não define, conhece previamente os protocolos e portas em uso, ou sabe qual escolher, de entre algumas portas ou intervalos típicos, conforme os serviços pretendidos (ssh, telnet, ftp, etc...). Há muitas formas de obter acesso do exterior a computadores de redes locais sem saber ao certo onde começar, um exemplo é através da varredura (scan) de portas. Em todo o caso, requer sempre algum nível de exposição ou abertura do alvo, ao exterior e, o uso de software transparente (ou não) em execução no terminal, instalado com notificação prévia (ou não), voluntariamente (ou não), para permitir esse acesso. Nos dias que correm, um computador, sem qualquer software ou "serviços" em memória, sem "falhas" para explorar, mesmo que ligado à internet e sem protecção, muito dificilmente é um computador acessivel do exterior.


 


Mas isto, naturalmente, já são tópicos para abordar noutro fórum. Se quiser, posso explicar-lhe como abrir portas, correctamente e da forma mais simples no router MEO, sem precisar de fazer uma completa revolução na sua LAN...


 


Atentamente,
O UpNp esta ativado,porem se não sou eu mesmo a defenir manualmente que porta abrir,como saberei então o numero dela para a pingar e ver se esta aberta?

Com desativar o NAT,quer dizer que devia mudar para um STATIC NAT?Se desativar por completo o NAT,não poderei ter apenas um dispositivo conectado por vez,visto que  já não terei um IP publico para a minha rede local.

Como ja mencionei anteriormente , sou ainda um pouco ignorante no que toca a redes,peço a sua compreensão..

Obrigado 
Reputação 6
Crachá +10
?


 


Quando se refere a "porta não especificada", presumo que seja aleatória. Ora, nesse caso, tudo o que tem a fazer é, ligar o UPnP em todos os dispositivos e, deixa-lo cumprir a sua tarefa. Isto significa que não deve tentar abrir portas manualmente, em simultâneo, pois pode provocar conflito na gestão dos protocolos. Se por ventura, o UPnP não funcionar correctamente, só tem mais uma de duas opções: ou desactiva por completo a gestão de portas (firewall, NAT, etc) em todos os seus dispositivos ou, terá de definir, pelo menos, um intervalo de portas no qual irá trabalhar, tendo este de ser correctamente redireccionado entre dispositivos anfitriões da LAN (routers normalmente), de um para outro e, definir a abertura correcta de portas do lado do servidor, ou a maquina que está a ser alvo do controlo remoto. Em qualquer dos casos, é imperativo que o "serviço de administração remota" esteja correctamente configurado, em execução permanente e pronto a aceitar ligações da WAN. Escusado será dizer que não deve instalar anti-virus ou qualquer outro software que ofereça protecção especial, contra esse tipo de intrusões, naquele terminal...


 


Atentamente,
Queria abir uma porta não especificada para utilizar num software de controlo de administrador remoto(RAT).

Tenho ética,estou a fazer isto para propósitos puramente educativos,sou autodidata e não usar vou ninguém como cobaia para além de mim próprio.

Ja estabeleci um dns dinamico,estava com problemas então no Port Fowarding.

NeoPT escreveu:
Olá @mrtm2002

 

Seja bem-vindo ao MEO Fórum.

 

Antes que o possa ajudar com o port forwarding, peço-lhe que explique resumidamente, o que pretende alcançar, ou que portas necessita direccionar e, quais os equipamentos que está a usar para o efeito. Obrigado.

 

Atentamente,

 

 

 
Reputação 6
Crachá +10
Olá ?


 


Seja bem-vindo ao MEO Fórum.


 


Antes que o possa ajudar com o port forwarding, peço-lhe que explique resumidamente, o que pretende alcançar, ou que portas necessita direccionar e, quais os equipamentos que está a usar para o efeito. Obrigado.


 


Atentamente,
 

Tens a certetza?

E se fizermos o procedimento indicado neste post para criar um RootUser mesmo com o firmware L?

http://forum.meo.pt/t5/Equipamentos-Internet/Como-restaurar-acessos-RootUser-e-permiss%C3%B5es-num-router-TG784n/td-p/68474

Aí consseguiria fazer port fowarding sem probelmas certo?

 

 
O método apresentado aqui afinal funciona ou não?? Tenho um Technicolor TG784n v3 no firmware L a solução apresentada na página 3 parece já não funcionar segundo outros utilizadores.. Sendo assim,e.completamente impossível fazer PortFowarding no firmware L sem permissões de rootuser?
E como desligo eu a firewall do router???
Não consigo entrar com o user debug, eu tentei no google chrome, temd e ser mesmo no firefox
Boa tarde a todos,

Venho pedir a vossa ajuda, pois já ando há 1 semana nisto e não consigo abrir as portas.

 

Já tentei de tudo o que encontrei neste forum, a situação é a seguinte: preciso de aceder ao meu DVR (Surveillance kit da conceptronic) que tem o ip 192.168.1.10, já criei o super user, adicionei os port forwarding no gui do thomson, desliguei a firewall no router e no pc, etc. Enfim, tudo o que encontrei neste post fiz e funciona, mas as portas continuam sem acesso.

 

No log do router tenho isto:

FIREWALL rule : Protocol: TCP Src ip: 66.240.174.69 Src port: 49116 Dst ip: 192.168.1.10 Dst port: 7001 Chain: forward_host_service Rule Id: 3 Action: accept

 

 

Fiz um nat maplist e deu isto:

Idx Type Interface Outside Address Inside Address Use
1 NAT Internet 188.80.15.226:8 127.0.0.1:8 0
2 NAT Internet 188.80.15.226 127.0.0.1 0
3 NAPT Internet 188.80.15.226:21 192.168.1.253:21 0
4 NAPT Internet 188.80.15.226:[7000-7002] 192.168.1.10:[7000-7002] 0
5 NAPT Internet 188.80.15.226:21021 127.0.0.1:21 0
6 NAPT Internet 188.80.15.226:[21800-21805] 192.168.1.253:[21800-21805] 0
7 NAPT Internet 188.80.15.226:23023 127.0.0.1:23 0
8 NAPT Internet 188.80.15.226:51005 127.0.0.1:51005 0
9 NAPT Internet any:[7000-7002] 192.168.1.10:[7000-7002] 0
10 NAPT Internet 188.80.15.226:68 127.0.0.1:68 0
11 NAPT Internet 188.80.15.226:[7000-7002] 192.168.1.10:[7000-7002] 0
12 NAPT Internet 188.80.15.226:51973 192.168.1.66:123 2
13 NAPT Internet 188.80.15.226:[7000-7002] 192.168.1.10:[7000-7002] 0
14 NAPT Internet 188.80.15.226:22022 192.168.1.253:22 0
15 NAPT Internet 188.80.15.226 unmapped 76
1 NAT IPVideoADSL 10.237.255.221:8 127.0.0.1:8 0
2 NAT IPVideoADSL 10.237.255.221 127.0.0.1 0
3 NAPT IPVideoADSL 10.237.255.221:21 192.168.1.253:21 0
4 NAPT IPVideoADSL 10.237.255.221:[7000-7002] 192.168.1.10:[7000-7002] 0
5 NAPT IPVideoADSL 10.237.255.221:21021 127.0.0.1:21 0
6 NAPT IPVideoADSL 10.237.255.221:[21800-21805] 192.168.1.253:[21800-21805] 0
7 NAPT IPVideoADSL 10.237.255.221:23023 127.0.0.1:23 0
8 NAPT IPVideoADSL 10.237.255.221:51005 127.0.0.1:51005 0
9 NAPT IPVideoADSL 10.237.255.221:68 127.0.0.1:68 0
10 NAPT IPVideoADSL 10.237.255.221:5060 10.237.255.221:5060 0
11 NAPT IPVideoADSL 10.237.255.221:[7000-7002] 192.168.1.10:[7000-7002] 0
12 NAPT IPVideoADSL 10.237.255.221:64104 192.168.1.64:1032 2
13 NAPT IPVideoADSL 10.237.255.221:[7000-7002] 192.168.1.10:[7000-7002] 0
14 NAPT IPVideoADSL 10.237.255.221 unmapped 2

 

POR FAVOR, AJUDEM!! OBRIGADO 

:(
 
Boa tarde,

Primeiro de tudo, obrigado pela solução. Segundo: Sabes como se faz o undo dessas configurações?

 

Cumprimentos!
Boas


Sei que este post já foi feito à algum tempo mas alguem pode confirmar os seguintes pontos?:


 


No intf, não tenho a opção internet, tenho internetGPON e outras 2 que agora não posso ver, mas fiz o procedimento com internetgpon.


 


De resto ficou como está o exemplo, mas mesmo assim aparece que a porta não está aberta, será por mode=inbound, também tenho que por outbound?


 


Obrigado!
Reputação 6
Boas @@mastercop


 


Qual é o firmware no router principal?


 


Como foi feita a configuração dos routers adicionas?


 


A opção de usar mais routers technicolor não é a melhor , visto que só um já da problemas , três ainda pior .


 


Mas tirando esse pormenor se mudaste o ip dos routers adicionais e desactivaste o DHCP e o IGMP Proxy deveria funcionar.


 


Se a box falhar com um equipamento em especifico por conflito de ip , podes sempre forçar outro ip para esse equipamento , Vê aqui como .


 


https://forum.meo.pt/t5/Tutoriais/Atribuir-um-IP-est%C3%A1tico-a-um-dispositivo-de-rede-local-no-router/m-p/24329#U24329
Gostaria de ter a vossa ajuda para configurar estes equipamentos de modo a funcionar as duas BOX meo.


Tenho uns anexos a 25 metros ond etenho outra box, e por vezes falha quando ligo equipamentos por wireless...conflitos IP.


Como a casa é grande, tenho um piso -1 onde o sinal wireless é fraco.


 


Espero que consigam ajudar-me a configurar da melhor forma, estes equipamentos


 


MEO FIBRA 100megas


 


 
Depois de tudo o que foi escrito antes neste tópico, chegou-se à triste conclusão que depois da MEO ter alterado o firmware deste router para a versão L, não é permitido ao cliente que o usa fazer port forward dentro da sua rede. Como eu achei que isto é atentório da liberdade de utilização do serviço, comuniquei o meu desgarado à MEO. Depois disso fui contactado pelo serviço 16209 e o assistente, depois desta explicada a situação que me afecta e a muitos outros clientes, ele assegurou-me que o problema ia ser encaminhado para o departamento de engenharia (programação, suponho). Passados 2 meses, o problema subsiste.


Formulei novamente reclamação à MEO e fui contactado novamente pelo serviço 16209 e um outro assistente perguntou-me se utilizava muito a box para ver TV, ao que eu lhe disse que nem por isso. Então a solução proposta por ele foi que eu arranjasse um outro router e o configurasse. Assim, quando estivesse a ver TV ligava o Technicolor, quando não estivesse a ver TV, desligava o Technicolor e usava o outro router para fazer port forward.


Dá para acreditar nisto???


Nos próximos dias vou fazer testes com um router 4G da NOS e se resultar, vou mandar estes senhores às malvas!
Boas,


 


Tenho um router v3 e estou com um problema, nao consigo abrir a porta para fazer mas fiz o port forward.


 


Tenho um router extra ligado ao router da meo.


Router meo admin 192.168.1.254


Router extra admin 192.168.0.1  mas tem o IP 192.168.1.71


 


Tenho 2 cameras Wifi IP ligadas ao router extra, uma na porta 88 outra na porta 11999 e estou a utilizar o no-ip como DNS dinamico. 


 


A porta 88 consigo aceder de fora da internet e vejo (Port Forward Network Utilities) que esta aberta.


A porta 11999 nao consigo aceder e vejo continua fechada. Mas de dentro da rede consigo aceder 192.168.0.104:11999


A unica diference entre as cameras é que a 88 tem Upnp penso eu.


 


No router extra fiz tambem o port forward e consigo aceder dentro da rede à camera.


Ja criei o RootUser, fiz o mapadd no telnet e tambem criei na partilha de jogos ou aplicações para a port 11999


 


Alguem tem alguma dica?


 


Obrigado!