Resolvido

Portforwarding TECHNICOLOR TG784n V3

  • 30 November 2013
  • 59 respostas
  • 166268 visualizações

Reputação 1
 





-----------------------------------------------------------------------------------





Para o firmware 10.2.1.L ver solução na página 3 deste tópico ...





 -----------------------------------------------------------------------------------





 





Boas, Deixo aqui o único método que consegui para fazer eficazmente o portforwarding no TECHNICOLOR TG784n V3.





 





Passo 1: Aceder à gestão do TECHNICOLOR (http://192.168.1.254) com user debug ver este tópico - post do user lfernandes





 





Passo 2: Criar um utilizador próprio com permissões de rootuser ver este tópico - obrigado xptopt





 





NOTA: Eu neste passo quando editava e gravava o user.ini em windows7 após o upload do ficheiro para o router, este quando reiniciava, não arrancava mais. Só após reset físico. Só consegui este passo quando o editei numa máquina virtual em linux.





 





Passo 3: Criar os portforwardings necessários na gestão do TECHNICOLOR (http://192.168.1.254)





 





Passo 4: Entrar em telnet no router (telnet 192.168.1.254) com o utilizador criado nos passos anteriores.





 





Escrever: menu





(Carregar na tecla TAB, cursores e ENTER para seleccionar)





No menu seleccionar a opção :NAT





Selecionar a opção: mapadd





 





Nota: As opções que não mencionar aqui deixei em branco.





intf = Internet





type= NAPT





inside_addr = IP DO VOSSO EQUIPAMENTO - C1 na imagem (exemplo: 192.168.1.60)





protocol = tcp





outside_port = PORTA EXTERNA (11111) ou GAMA DE PORTAS (11111-11122)





inside_port = PORTA INTERNA (11111) ou GAMA DE PORTAS (11111-11122)





mode = inbound





 





Tab para ok, e cancel ate sairem do menu.





Na linha de comandos (ainda em telnet):





saveall





exit





 





Passo 5: Configurar o serviço de DNS dinâmico e desligar a Firewall (na gestão do TECHNICOLOR). -------------------------------------------------------------------------------------- http://www.ideianet.pt/rede_meo0.jpg No meu caso como necessito de ter várias redes isoladas umas das outras em vez de ter os equipamentos ligados directamente no TECHNICOLOR, tenho 2 routers CISCO LINKSYS ligados ao TECHNICOLOR e que depois me criam as várias redes que preciso. A minha rede é a seguinte: http://www.ideianet.pt/rede_meo.jpg Equipamento A





WAN : IP MEO (ONT)





TECHNICOLOR TG784n V3





DHCP ON - 192.168.1.60 a 192.168.1.253





Firewall OFF





 





Equipamento B





WAN : 192.168.1.61 (TECHNICOLOR DHCP)





CISCO WRT160Nv2





DHCP ON - 192.168.11.100 a 192.168.11.149





Firewall ON





 





Equipamento C





WAN : 192.168.1.60 (TECHNICOLOR DHCP)





CISCO E3200 DHCP ON - 192.168.10.200 a 192.168.10.219





Firewall ON





 





 





Inicialmente no lugar do WRT160Nv2 tinha um SMC, e não sei se devido ao sinal da MEOBOX vir na rede ou não, sempre que o ligava a MEOBOX ficava "aos soluços" e a rede instável. A única solução que encontrei foi substituir o SMC pelo WRT160Nv2.





 





Ficou logo tudo 5 estrelas !





De qualquer modo isto indica que nem todos os equipamentos (routers) servem para esta topologia.





 





Para uma rede (como a minha), para além dos passos descritos acima, é necessário:





- Configurar o 2º router para uma gama de IPs diferente do TECHNICOLOR (ex: 192.168.10.x)





- Ligar um cabo de rede da LAN do TECHNICOLOR à porta WAN do 2º router





- Configurar o tipo de ligação para a porta WAN do 2º router como IP (DHCP)





- Configurar no TECHNICOLOR todos os portforwardings para o 2º router (método descrito em cima)





- Configurar no 2º router os portforwardings para os equipamentos finais (PCs, Consolas, etc) - Ligar a segurança no 2º router (firewall, etc)





 





Caso haja mais routers (3º, 4º ...) repetir estes passos para cada um deles ... (mudando a gama de IPs)





 





De fora (internet) faço WOL e administração remota (software Radmin) ao Equipamento C1 e tenho acesso por FTP (modo passivo que necessita de uma gama de portas) ao Equipamento C2 (servidor de FTP). Também tenho acesso à gestão do Equipamento B. No Equipamento C1 tenho o emule com as portas TCP e UDP OK. A MEOBOX está ligada directamente ao Equipamento C sem qualquer tipo de configuração adicional e mantêm todas as funcionalidades (MUSICBOX, etc.). Isto tudo a funcionar sem qualquer tipo de interferência ou instabilidade.





 





Espero que esta informação seja de alguma utilidade para alguns utilizadores.





 





Abraço,





Nunex70





 





P.S. Atenção para não utilizar portas que sejam necessárias aos serviços ! Abrir ou alterar essas portas pode criar conflitos no sistema !
icon

Solução por nunex70 2 February 2015, 14:01

Ver original

Tópico fechado, já não permite mais respostas.

59 respostas

Boas malta ver se alguem me consegue ajudar, pois estou a ter dificuldades em abrir uma porta, o problema é o seguinte. Possuo 2 ipcam, as quais funcionavam às 5 maravilhas com o meu anterior fornecedor de ineternet, passei agora para  meo fibra, e tentei seguir os tutoriais para fazer o port forward para as cameras, a primeira segui os passos todos, e funciona nas maravilhas, vou fazer procedimentos iguais para a segunda com uma porta diferente da anterior e nada, já tenteo abrir diferentes e nada, não consigo de nehuma maneira, e quando vou verificar se as postas estao abertas, dá sempre postas fechadas, e na primeira dá como estando aberta e claro tudo funcional. Alguma dica por ai?
Reputação 6
Crachá +10
Olá ?





 





Qual a marca e modelo das camaras? Quantos routers usa na sua rede e quais as marcass e modelos? Quais são as portas que está a tentar abrir?





 





Atentametne,
Boas uma das cameras uma foscam que funciona na prefeição sem problemas depois de seguir o tutorial para abrir portas.





A outra uma pixord para a qual segui os mesmos procedimentos da anterior e nada de nada, criei para ela 3 com portas diferentes e nada de nada, se for na rede interna funciona bem, com qualquer das portas que abri, mas para a visualizar de uma outra rede nada de nada. Eu apenas uso o router da meo o Technicolor TG784n v3.





As portas que tento abrir 8080; 75; 88
Reputação 6
Crachá +10
kostinha escreveu:



 





...As portas que tento abrir 8080; 75; 88







 





Quais as de entrada e de saida?





 





Certifique-se que a porta de entrada para a segunda camara é diferente da de entrada da primeira, uma vez que está a criar dois servidores em simultaneo e, o router MEO reserva permanentemente as portas que estão a ser solicitadas pelo servidor, mesmo que não esteja a receber o feed dessa ligação.





 





exemplo:





 





camara 1











camara 2











 





 





Dica: evite o uso de portas http ou outras genéricas (ex: 80, 8080), pois as mesmas já são amplamente requeridas por inumeros serviços na rede.





 





 





Atentamente,
Restaurei definições de origem, voltei a fazer tudo de novo, primeira camera porta 90 tudo ok, vou fazer o mesmo para a segunda camera atribuo a porta 75 e nada, alias vou verificar as portas e a 90 aberta e 75 fechada, como é isto possivel





??







 
Reputação 6
Crachá +10
Olá ?





 





Não é necessário enviar mensagem privada para esse efeito. Não estou disponivel para o assistir remotamente, lamento.





 





Já experimentou usar uma porta de saida ( converter em...) diferente da de entrada?





 





Não se esqueça que deve configurar novamente as portas tanto no servidor como no cliente, caso decida usar diferentes das standard.





 





Configure portas ou intervalos de portas diferentes para cada servidor. Aqui está um manual de utilizador de uma camara IP Pixord 207: http://api.ivv-aut.com/adp/22%20-%20CCTV%20IP/2222%20-%20C%C3%82MARAS%20DE%20V%C3%8DDEO%20IP/222210%20-%20C%C3%82MARAS%20DE%20CORPO%20PROFISSIONAIS/22221005%20-%20COM%20LENTE%20INCORPORADA/22221005000098%20-%20PIXORD%20207/P201_207_manual_util_EN.pdf





 





Não sei se é o seu modelo, já que não especificou, mas penso que a configuração seja identica. Pode observar na página 37 do manual acima, as definições para o DDNS. Aqui terá de configurar as portas de acordo com o que estableceu na 'Partilha de jogos e aplicativos', no router MEO.





 





Reveja os parametros e tente de novo.





 





Atentamente,
Boa tarde!



 



Fiz tudo o que foi referido para fazer Portforwarding ao TECHNICOLOR TG784n V3 com o software 10.2.1.L, como explicado pelo Nunex na página 3 deste tópico, mas nada! Tudo pafrece resultar bem, ou seja sem erros de resposta.



O que eu pretendo fazer não é aceder a nenhum equipamento dentro da minha rede mas sim ao mesmo router, para poder controlar açgumas coisas á distãncia tal como quando o posso fazer quando estou dentro da rede.



Por isso neste comando telnent que o nunex indicou, eu coloquie o endereço do equipamento ao qual pretendo aceder, o router. technicolor



code:
tmpladd type=napt outside_addr=0.0.0.1 inside_addr=192.168.1.254 outside_port=5500 inside_port=5500
 



Desactivei a firewall, tudo certinho. Mas continuo a não conseguir aceder ao router de fora da rede...



 



Agradecia ajuda se possivel. Obrigado desde já.



 
Ninguém!?





 





Deve ser mesmo complicada então a questão que coloquei...





Obrigado na mesma à comunidade "Meo Fórum"