[OPENWRT e MEO] - Sem IPv6

  • 2 Maio 2016
  • 6 respostas
  • 1718 visualizações

Não consigo meter o IPv6 a trabalhar e não percebo porquê.

O meu setup é o seguinte:

[TG784n]
|
|
| LAN - WAN
|
|
[WDR4300] - DHCP 192.168.2.1 | WDS AP
|
|
| WDS
|
|
[2x Routers Clientes WDS] - Firewall desligada, LAN/WAN com bridge, sem DHCP.

Andei a mexer nas definições do IPv6 e DHCPv6, mas não sei o suficiente para perceber qual é o problema e nada parece resolve-lo. De momento estou a usar Chaos Calmer (15.05.01) com as definições de fabrica, apenas adicionei os DNS da Google no WAN/WAN6.

Os clientes têm lease DHCPv6 e DNS, mas estão sem gateway e não conseguem resolver endereços IPv6. Quando ligado diretamente ao router da MEO, o IPv6 funciona sem problemas.

Alguma ideia do que se possa passar?

6 respostas

Reputação 1
Crachá +4
Boas. Achas que conseguias dar mais dados/inserir as config dos activos da tua rede?
Pelo que já consegui perceber, o WDR4300, tanto com firmware original como com OpenWRT não consegue configurar o prefixo IPV6 (/56) da MEO.


 


Já tentei dizer ao OpenWRT que o prefixo é /56 e até copiar e colar o prefixo, mas mesmo assim não funciona. Tem ideia do que devo fazer para configurar correctamente o OpenWRT, partindo das configurações de fábrica?


 


Obrigado!
Reputação 1
Crachá +4
Boas. Já experimentaste em openwrt configurar /etc/network/interfaces na linha do interface que pretendes activas ipv6 e colocas por dhcp. Já tentaste isso?
Reputação 1
Crachá +4
Desculpa é /etc/config/network
Reputação 1
Crachá +4
tenho um adb 4000n a correr openwrt, fazendo de ap/ switch (onde ligo 2a stb ). O meu ficheiro network tem ipv6 config assim:

config globals 'globals'
option ula_prefix 'fdb2:3dbd:796a::/48'

config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.102'
option netmask '255.255.255.0'
option gateway '192.168.1.254'
option dns '192.168.1.254'
option ip6assign '60'

Pelo k tenho testado funciona bem. Como tens o teu configurado? Podes postar a config do teu /network?
Reputação 1
Crachá +4
Boas. Tenta isto: com luci instalado no openwrt, coloca tudo em relay mode em network-interfaces- edit - dhcp server - ipv6 settings.

Responder