Resolvido

Necessito desbloquear portas 22 e 23 no TG784n 10.2.1.L

  • 29 Outubro 2014
  • 22 respostas
  • 6246 visualizações

Bom dia,

Tive um problema com o meu NAS Synology por falha de energia elétrica e o meu volume com "crashou" porque um dos discos avariou. Pedi a assistência ao cliente da Synology que acedeu remotamente ao meu NAS e começou a reparação e recuperação dos dados.

 

O acesso é feito via Telnet e SSH, portas 23 e 22, repectivamente.Tudo estava ok até que actualizaram o firmware do router para 10.2.1.L, sem prévio aviso ou pedido da minha parte.

O meu Thomson TG784n creio que é das primeiras versões e não aparece sequer o tal modo gamer.

 

Perdi alguns utilizadores e outras configurações... mas, sobretudo, o port forward das portas 22 e 23 deixou de funcionar.

Embora introduza as regras necessárias para passar estas portas para o meu ip interno 192.168.1.79 (meu NAS), continuam bloqueadas ao exterior.

 

O que posso fazer? 

A quem ou como posso reclamar o desbloqueio destas portas?

 

Preciso que a Synology possa aceder ao meu NAS para recuperar os meus dados mas a Meo está a bloquear a assistência técnica via internet ao meu equipamento.

 

Obrigado. Cumprimentos,

Miguel
icon

Solução por NeoPT 31 Outubro 2014, 20:11

@@@xptopt 

Não desfazendo da tua boa vontade em ajudar, que será sempre apreciável, eu tambem pensei inicalmente sugerir o modo gamer, mas não tinha a certeza se valia a pena.

Só para clarificar um detalhe, o "cone udp" também chamado "udp hole punch", permite a comunicação livre de pacotes UDP num intervalo de portas especificado, certo?.. Portanto, estando a analisar a abertura de portas para serviços que supostamente usam apenas o TCP (FTP,Telnet,SSH), essa solução não fará qualquer diferença, ou estou errado? Se não estou em erro, mesmo até os serviços de jogos estabelecem 1º a ligação por meio do protocolo TCP e depois usam uma ou mais portas UDP para todo o resto.

Eu fiz o teste do cone udp na minha rede caseira, embora tenha o firmware 10.2.1.D. Apenas quando vou á partilha de jogos e aplicações e "aplico" a porta 23 (ainda não testei a porta 22) ao meu PC, configurada como 'servidor', a mesma é apresentada como aberta e consigo aceder sem qualquer problema ao servidor telnet, fora da LAN. Se remover o cone udp a ligação estabelece-se, sem problema. Se manter o cone udp e remover a "regra" da porta 23, a porta fecha e deixo de poder usar o serviço. A porta fecha também, se parar o serviço no PC, voltando a abrir imediatamente se o iniciar.

Pelo menos no meu caso, o cone udp não pareceu ter utilidade, consegui abrir sempre a porta 23 pelo processo habitual e tenho também ,sempre, as seguintes entradas na maplist:


3 NAPT Internet        2.83.xxx.xxx:21 ;                192.168.1.253:21            0


16 NAPT Internet        2.83.xxx.xxx:22022 ;             192.168.1.253:22       0


10 NAPT Internet        2.83.xxx.xxx:23023 ;             127.0.0.1:23                 0

EDIT: já testei a porta 22 com um servidor SSH e não me permitiu iniciar sequer o serviço. Apenas aquela entrada no router parece estar a impedir a abertura do serviço, nesta porta, a qualquer outro dispositivo na rede, por se tratar de mais uma ligação da WAN para a LAN, enquanto as outras apontam para o loopback interno no router. Tinhas razão nisto @@@xptopt , obrigado pela dica.

 Usei a aplicação FreeSSHd para testar. Como podem observar em baixo, a aplicação deu o erro "the specified address is already in use", quando tentei abrir a porta 22 com o SSH. No entanto o serviço Telnet, funciona perfeitamente na porta 23 (já testado anteriormente).



Bastou mudar a porta do serviço SSH no servidor FreeSSHd e já permitiu o correcto funcionamento.





@@@Banimale  


Existe alguma razão especial para usar a porta 22, para o SSH no NAS, do lado da LAN? Penso que não e, se o problema que está a ter, for idêntico ao meu, basta na configuração do NAS mudar as portas dos serviços Telnet/SSH para outras diferentes, não usadas (ex: porta 16), abri-las depois no router, do lado do servidor e, o problema ficará definitivamente resolvido sem mais atropelos. Espero.

Veja na imagem exemplo, em baixo, a abertura é feita para a porta 16, apenas do lado do servidor (LAN) continuando a usar-se a porta 22 para o lado cliente (caso o suporte synology o exija):



 

Depois do servidor iniciado no PC, mais um teste à porta 22 com o yougetsignal e, voilá:



EDIT2: Tambem testei a ligação por 4G com o meu smartphone e um cliente SSH Android, à porta 22, com sucessso!

 


Não se esqueça de voltar a ligar a firewall...

Cumps

Ver original

22 respostas

Reputação 5
Boa tarde, @@@Banimale 


 


Tem a certeza que introduziu correctamente as portas na "Partilha de jogos e aplicações", e atribuiu ao dispositivo na rede correspondente ao servidor NAS?.. Já reveu as configurações do próprio servidor NAS? Pode existir algum parametro incorreto.


 


Faça o seguinte: no pc, abra a linha de comandos e aceda ao router meo, por telnet (telnet 192.168.1.254). De seguida digite o comando 'nat maplist'. Copie o texto e poste aqui o resultado.


 


Cumps
Obrigado pela resposta e ajuda.


 


Já revi as regras várias vezes e tentei de várias formas... na rede interna cosigo ssh e telnet. De fora, não. Qualquer port checker diz-me que as portas estão fechadas.


As regras da firewall do NAS estão iguais ao que eram mas até já tentei retirar toda a proteccção e firewall... resultado foi o mesmo.


A sensação que me dá é que para estas portas, o router ignora as regras de port forward.


 


Mas vou fazer o que sugeriu quando chegar a casa... e depois posto aqui o resultado do nat maplist..(espero conseguir aceder ao router via telnet)


 


Obrigado mais uma vez. um abraço
Aparentemente está ultrapassado.


 


Como sugeriu liguei-me por telnet ao router e investiguei nat maplist e népia... de todas a minhas regras de port forward, só não apareciam as das portas a 22 e 23.


 


depois fui ver a config da firewall... e optei por firewall config state=disabled


(estava enabled)


e voilá... as regras de port forward das portas 22 e 23 aparentemente já funcionam... pelo menos dois port checkers já me dizem que estão abertas


 


enrentanto retirei todas as outras regras por segurança uma vez que tenho a firewall do router totalmente off, embora tenha firewall no NAS e nos PCs... pelo menos enquanto durar a novela do NAS.


Mais uma vez obrigado pela ajuda


 


Obrigado pela ajuda!
Reputação 5
Bom dia, @@@Banimale 


 


Não era assim que contava, que resolvesse o problema. A firewall nao deve permanecer desativada. Por favor peço-lhe que desmarque o post como solução, pois não apresenta uma solução definitiva. Pedi-lhe que postasse o resultado da 'maplist', para que no futuro os outros contribuidores saibam o que procurar. Embora nao o tenha feito, se diz que não encontra lá as portas 22 e 23, pode tratar-se duma incorreção na introdução de portas. Tambem podia ser da firewall, com um nivel de segurança excessivo. Volte a activar a firewall do router MEO, por favor, e na pagina do router, configure-a com o nivel de segurança: "Padrão".


 


Eis um teste que pode fazer, para o ajudar a diagnosticar a abertura de portas:


A titulo de curiosidade, ontem, criei no meu router TG799vn, uma nova aplicação com o nome "telnet", na "partilha de jogos e aplicações", no router MEO, introduzindo nela a porta 23. Atribui a regra ao endereço IP do meu PC.


 


Depois no meu PC, testei a porta usando o site: http://www.yougetsignal.com/tools/open-ports/. A porta 23, permaneceu fechada!


 


Abri o "Painel de controlo" (do Windows 7), e entrei em "Programas e funcionalidades/Activar ou desactivar funcionalidades do Windows", para instalar o "Servidor Telnet". De seguida recuei para o "Painel de Controlo" e entrei em "Ferramentas administrativas/Serviços". Na janela "Serviços" desci até encontrar o serviço "Telnet", cliquei com o botão direito do rato e acedi a "propriedades", para alterar o 'Tipo de arranque' para: "Manual". Cliquei em 'Ok' e depois novamente com o botao direito do rato, para 'Inciar' o serviço "Telnet". Um pop-up, com uma barra de progresso, apareceu a demonstrar que o serviço foi iniciado. O meu anti-virus exibiu tambem um pop-up a relatar que foi criada uma regra para o Servidor Telnet na firewall, apesar de eu já a ter desactivado para efeitos de teste (lembrem-se disto, por favor).


 


Depois no meu PC, testei novamente a porta usando o site: http://www.yougetsignal.com/tools/open-ports/. A porta 23, que antes estava fechada, revelou-se então, aberta. A execução de um serviço, correctamente configurado no PC, fez toda a diferença no teste de portas.


 


Ainda não satisfeito com o resultado, fui buscar o meu smartphone, com Android 4.1.2 e, entrei na playstore para descarregar a aplicação "Simple Telnet Client". Instalei a aplicação, desliguei o Wi-fi no smartphone, para não comunicar através da rede LAN de casa, e activei os "Dados móveis". Abri a aplicação e introduzi o endereço IP da minha ligação MEO, e sem grande surpresa o meu smartphone acedeu com sucesso, através de 4G, por telnet ao meu PC em casa.


 


Faço questão de esmiuçar e desmistificar os problemas de port forwarding dos clientes MEO, por isso, peço lhe que tente outra vez a abertura de portas, sem desactivar a firewall no router e, poste depois sobre como correu.


 


Cumps.
Bom dia@NeoPT,


Obrigado pela ajuda mais uma vez.


 


Tentarei um solução alternativa assim que resolver o problema do meu NAS.


 


Posso adiantar que tendo retirado todas as regras port forward no router, o comando nat maplist mostrava, entre outros:


ip externo na porta 22022 (acho que era assim)    127.0.0.1:22


ip externo na porta 23023 (acho que era assim)    127.0.0.1:23


(tentarei colocar o outrput corecto hoje á noite)


 


Ao adicionar várias regras no router, todas eram implementadas excepto as das portas 22 e 23.


 


Lembro que o meu TG784n é das primeirasversões... não sei se isto limita alguma coisa.


Salvo melhor opinião, uma vez que funciona com firewall do router desactivada, parece-me que o problema do bloqueio é mesmo aqui. Até porque a firewall do NAS tem estas portas abertas.


Quando refere que o nível de segurança da firewall poderia ser execessivo, há algo que eu possa fazer para diminuir sem ser desactivar? No acesso web ao router não consigo alterar nada na configuração da firewall.


 


Obrigado. Um abraço
Reputação 5
Boa tarde @@@Banimale 


 


Essas linhas que viu, apresentam o router MEO a abrir as portas 22 e 23, para ele próprio. Perfeitamente normal, já que o próprio router, faz uso destes protocolos. Mas gostaria de observar o resto, se fizer favor. Pode mesmo postar print screen (teclas AltGr+PrtScr) da janela, da linha de comandos.


 


O facto de ser uma versão antiga não limita nada em especial em termos de NAT. Qualquer router deve vir preparado de fabrica para abrir as portas que lhe são solicitas, internamente na LAN, salvo erro ou defeito exepcional na produção.


 


A firewall deve permitir configurar o nivel de segurança. Qual o ulitizador que está a usar para entrar na página do router? Use o seguinte:


 


utilizador: sumeo
password: bfd,10ng


 


Não é necessario usar o telnet para alterar o estado à firewall do router MEO. Para isso tem a página, "Ferramentas/Firewall" em http://192.168.1.254


 


Para configurar o nivel de segurança, basta clicar logo no canto superior direito em "Configurar". Se entrar primeiro em "detalhes" e configurar a partir dai, possivelmente, é lhe negado o acesso. Escolha o nivel "Padrão". No fim faça "Aplicar":


 





 


Cumps
com todas as regras:


 


{sumeo}=>nat maplist
Idx Type Interface       Outside Address                Inside Address                 Use
  1 NAT  InternetGPON    85.245.xxx.xxx:8 ;             127.0.0.1:8                   0
  2 NAT  InternetGPON    85.245.xxx.xxx ;                127.0.0.1                      0
  3 NAPT InternetGPON    85.245.xxx.xxx:20 ;             192.168.1.79:20                0
  4 NAPT InternetGPON    85.245.xxx.xxx:22 ;             192.168.1.79:22                1
  5 NAPT InternetGPON    85.245.xxx.xxx:23 ;             192.168.1.79:23                1
  6 NAPT InternetGPON    85.245.xxx.xxx:443 ;            192.168.1.79:443               0
  7 NAPT InternetGPON    85.245.xxx.xxx:[989-990]       192.168.1.79:[989-990]         0
  8 NAPT InternetGPON    85.245.xxx.xxx:1900 ;           192.168.1.79:1900              0
  9 NAPT InternetGPON    85.245.xxx.xxx:[5000-5001]     192.168.1.79:[5000-5001]       6
 10 NAPT InternetGPON    85.245.xxx.xxx:5002 ;           192.168.1.79:5002              0
 11 NAPT InternetGPON    85.245.xxx.xxx:5004 ;           192.168.1.79:5004              0
 12 NAPT InternetGPON    85.245.xxx.xxx:[5005-5006]     192.168.1.79:[5005-5006]       0
 13 NAPT InternetGPON    85.245.xxx.xxx:5050 ;           192.168.1.79:5050              0
 14 NAPT InternetGPON    85.245.xxx.xxx:[7000-7001]     192.168.1.79:[7000-7001]       0
 15 NAPT InternetGPON    85.245.xxx.xxx:[8080-8082]     192.168.1.79:[8080-8082]       0
 16 NAPT InternetGPON    85.245.xxx.xxx:9091 ;           192.168.1.79:9091              0
 17 NAPT InternetGPON    85.245.xxx.xxx:16881 ;          192.168.1.79:16881             0
 18 NAPT InternetGPON    85.245.xxx.xxx:21021 ;          127.0.0.1:21                   0
 19 NAPT InternetGPON    85.245.xxx.xxx:23023 ;          127.0.0.1:23                   0
 20 NAPT InternetGPON    85.245.xxx.xxx:32400 ;          192.168.1.79:32400             0
 21 NAPT InternetGPON    85.245.xxx.xxx:[50000-50002]   192.168.1.79:[50000-50002]     0
 22 NAPT InternetGPON    85.245.xxx.xxx:51006 ;          127.0.0.1:51006                0
 23 NAPT InternetGPON    85.245.xxx.xxx:51414 ;          192.168.1.79:51414             0
 24 NAPT InternetGPON    85.245.xxx.xxx:[55336-55663]   192.168.1.79:[55336-55663]     0
 25 NAPT InternetGPON    85.245.xxx.xxx:65001 ;          192.168.1.79:65001             0
 26 NAPT InternetGPON    85.245.xxx.xxx:68 ;             127.0.0.1:68                   0
 27 NAPT InternetGPON    85.245.xxx.xxx:68 ;             85.245.xxx.xxx:68 ;             0
 28 NAPT InternetGPON    85.245.xxx.xxx:443 ;            192.168.1.79:443               0
 29 NAPT InternetGPON    85.245.xxx.xxx:[989-990]       192.168.1.79:[989-990]         0
 30 NAPT InternetGPON    85.245.xxx.xxx:1900 ;           192.168.1.79:1900              0
 31 NAPT InternetGPON    85.245.xxx.xxx:[5000-5001]     192.168.1.79:[5000-5001]       0
 32 NAPT InternetGPON    85.245.xxx.xxx:5060 ;           85.245.xxx.xxx:5060 ;           0
 33 NAPT InternetGPON    85.245.xxx.xxx:16881 ;          192.168.1.79:16881             0
 34 NAPT InternetGPON    85.245.xxx.xxx:51223 ;          192.168.1.74:1032              2
 35 NAPT InternetGPON    85.245.xxx.xxx:51364 ;          192.168.1.79:123               2
 36 NAPT InternetGPON    85.245.xxx.xxx:51414 ;          192.168.1.79:51414             0
 37 NAPT InternetGPON    85.245.xxx.xxx:22022 ;          192.168.1.253:22               0
 38 NAPT InternetGPON    85.245.xxx.xxx ;                unmapped                       107


 


Infelizmente, depois de accionar a firewal e atribuir nível de segurança padrão, retirar as regras e voltar a adiciona-las.. fiquem sem acesso exterior as portas 22 e 23.


 


tive de desligar  totalmente a firewall via telnet para coneguir acesso outra vez. Desligar no acesso web, não desliga a firewall, apenas o nível de segurança e continuava sem ver as portas.


 


obrigado
cada vez que desligo a firewall, cerca de uma hora depois fico sem lan nas ligações com fio.


todas as ligações cabladas diexam de funcionar, apenas ligações wireless continuam activas.


só qunado reinicio o router volto a ter lan wired.
Reputação 5
Banimale escreveu:

 


Infelizmente, depois de accionar a firewal e atribuir nível de segurança padrão, retirar as regras e voltar a adiciona-las.. fiquem sem acesso exterior as portas 22 e 23.


 


tive de desligar  totalmente a firewall via telnet para coneguir acesso outra vez. Desligar no acesso web, não desliga a firewall, apenas o nível de segurança e continuava sem ver as portas.


 


obrigado



Bom dia @@@Banimale 


 


EDIT: Estive a consultar a lista de routers compativeis com o UPnP do NAS Synology no site ofcicial ( https://www.synology.com/en-us/knowledgebase/tutorials/456 ) e só o modelo TG799vn é reportado como compativel. Mesmo que se confirme, apenas significa que tem sempre de abir as portas manualmente no seu router.


 


No site, recomenda tambem modificar a configuração do NAS para usar um IP estático na LAN. Nada de novo e, a menos que "mexa" deliberadamente nas definições DHCP do router MEO, o IP do NAS irá manter-se-á igual, mesmo que reinice o router.


 


A propósito, tentou usar o EZ-Internet Wizard? Se sim, não obteve resultados positivos?


 


Tome atenção à firewall do NAS, se estiver a usá-la, deve desativa-la temporariamente, para efeitos de teste.


 


Outro aspecto que deve ter em conta, se o desconhece, é que, se não tiver um nome de endereço dinamico (DDNS) associado ao seu IP da ligação de internet MEO e, por algum motivo a ligação se perder e o endereço IP mudar, poderá perder-se a conexão aos serviços. Isto só é mesmo importante caso, queira garantir o acesso ao apoio tecnico da synology. Se o seu IP mudar, facilmente tomará nota disso.


 


Chegou a tentar o teste no PC, que postei em cima? Tem de cancelar a regra, no router MEO e, abtribui-la ao seu PC, quando o fizer...


 


A "maplist" que mostra foi capturada antes ou depois de activar a firewall do router MEO? E tinha removido já as regras, ou ainda estavam em vigor?


 


Esperimentou reiniciar o router e todos os dispositivos de rede, incluindo o NAS? Tem a certeza que o NAS estava a executar o serviço de servidor Telnet e SSH, quando voltou a ligar a firewall do router MEO? Se os serviços, não estiverem em execução as portas nunca serão abertas. Veja aqui como activar os serviços: http://www.ingmarverheij.com/how-to-enable-terminal-access-to-synology-nas/


 


É estranho, pois parece haver algum erro na configuração que está a usar...


 


Pode mostrar-me como está a abrir as portas tanto no router MEO, como no NAS, se fizer favor?


 


Obrigado


Cumps
Boas


 


Olhando para a Nat maplist parece que o router está a usar a porta 22 para o ip 192.168.1.253 que é por defeito o ip do ftpserver do router , pode estar ai o problema , já removeste a entrada criada por defeito no router para o ip 192.168.1.253 ?


 






Recomendo também desactivar a partilha de conteúdos em Ferramentas > Partilha de conteúdos


 


Ps. Podes também usar este comando para criar um Nat CONE (UDP) para a porta 22-23


 


code:
connection bind application=CONE(UDP) port=22-23
saveall
system reboot

 
Boa tarde @@@NeoPT ,


Obrigado pela reposta.


Infelizmente acho que já fiz quas tudo o que mencionou mas este f-d-s vou tentar replicar o que indicou de forma mais metódica  organizada.


Ainda não fiz o teste no PC.


O TG784n de facto não é suportado e sempre me obrigou a parametrização manual.


Uso o DDNS da synology (synology.me) bem como o quickconnect da synology.


O NAS tem  ip estático no router.


 


vou testar o resto e darei novidades. obrigado pela ajuda


 


Para cúmulo  recuperação de dados pela Synology não está a ser fácil.:catfrustrated:


 
Boa tarde @@@xptopt ,


Obrigado pela resposta.


 


FTP Server estava desligado mas pelo sim pelo não. liguei e. voltei a desligar mas. continua a aparecer na maplist.


tentei remover manualmente (nat tmpldelete index=xx) mas continua sempre lá.


 


fiz o cone udp mas, sincerament,e preciso da tua ajuda para saber como usufruir deste cone... :catembarrassed:


 


confesso que já estive mais longe de comprar um outro router para ligar como consta do teu tutorial (ligar segundo router para quem tem este firmware) com switch antes dos routers e acabar com ... este problema... ligando o NAS ao outro router


o problema é que o tutorial é para Asus e eu até estava a ponderar um Netgear (refurbished)... mas depois não saberia configurar o IPTV no netgear 
Boas
No fim de adicionar as portas ao nat cone (udp) e abrindo as portas manualmente , se fosse esse o problema deveria funcionar , já experimentaste desactivar o UPNP ?


 


Quanto ao Netgear o problema não é configurar a IPTV mas sim a VLAN 12 , não sei como é efectuado nesse router, mas a box pode ficar no router da meo , nesta configuração os dois routers vão ficar com net e com ip´s diferentes .
Olá @@@xptopt ,


 


OK, vou testar as portas UDP então.


UPNP está sempre desligado.


 


Enganei-me, era precisamente ao VLAN 12 que me referia.


 


Pela minha configuração de equipamentos em casa, tenho mesmo de ligar a box ao segundo router: só tenho um cabo do 2.º andar (ONT + 784n) para o 1º andar (box, NAS, media player, PS3, etc).


A ideia seria mudar o switch que tenho no 1º andar para o 2º antes dos dois routers... o novo router ficaria no 1º andar a distribuir internet cablada e wireless... daí pensar num router AC1750-AC1900  mas os Asus ainda são carotes.


 


obrigado. um abraço
Reputação 5
@@@xptopt 


 


Não desfazendo da tua boa vontade em ajudar, que será sempre apreciável, eu tambem pensei inicalmente sugerir o modo gamer, mas não tinha a certeza se valia a pena.


 


Só para clarificar um detalhe, o "cone udp" também chamado "udp hole punch", permite a comunicação livre de pacotes UDP num intervalo de portas especificado, certo?.. Portanto, estando a analisar a abertura de portas para serviços que supostamente usam apenas o TCP (FTP,Telnet,SSH), essa solução não fará qualquer diferença, ou estou errado? Se não estou em erro, mesmo até os serviços de jogos estabelecem 1º a ligação por meio do protocolo TCP e depois usam uma ou mais portas UDP para todo o resto.


 


Eu fiz o teste do cone udp na minha rede caseira, embora tenha o firmware 10.2.1.D. Apenas quando vou á partilha de jogos e aplicações e "aplico" a porta 23 (ainda não testei a porta 22) ao meu PC, configurada como 'servidor', a mesma é apresentada como aberta e consigo aceder sem qualquer problema ao servidor telnet, fora da LAN. Se remover o cone udp a ligação estabelece-se, sem problema. Se manter o cone udp e remover a "regra" da porta 23, a porta fecha e deixo de poder usar o serviço. A porta fecha também, se parar o serviço no PC, voltando a abrir imediatamente se o iniciar.


 


Pelo menos no meu caso, o cone udp não pareceu ter utilidade, consegui abrir sempre a porta 23 pelo processo habitual e tenho também ,sempre, as seguintes entradas na maplist:


3 NAPT Internet        2.83.xxx.xxx:21 ;                192.168.1.253:21            0


16 NAPT Internet        2.83.xxx.xxx:22022 ;             192.168.1.253:22       0


10 NAPT Internet        2.83.xxx.xxx:23023 ;             127.0.0.1:23                 0


 


EDIT: já testei a porta 22 com um servidor SSH e não me permitiu iniciar sequer o serviço. Apenas aquela entrada no router parece estar a impedir a abertura do serviço, nesta porta, a qualquer outro dispositivo na rede, por se tratar de mais uma ligação da WAN para a LAN, enquanto as outras apontam para o loopback interno no router. Tinhas razão nisto @@@xptopt , obrigado pela dica.


 


 Usei a aplicação FreeSSHd para testar. Como podem observar em baixo, a aplicação deu o erro "the specified address is already in use", quando tentei abrir a porta 22 com o SSH. No entanto o serviço Telnet, funciona perfeitamente na porta 23 (já testado anteriormente).


 





 


Bastou mudar a porta do serviço SSH no servidor FreeSSHd e já permitiu o correcto funcionamento.


 





 





 


@@@Banimale  


Existe alguma razão especial para usar a porta 22, para o SSH no NAS, do lado da LAN? Penso que não e, se o problema que está a ter, for idêntico ao meu, basta na configuração do NAS mudar as portas dos serviços Telnet/SSH para outras diferentes, não usadas (ex: porta 16), abri-las depois no router, do lado do servidor e, o problema ficará definitivamente resolvido sem mais atropelos. Espero.


 


Veja na imagem exemplo, em baixo, a abertura é feita para a porta 16, apenas do lado do servidor (LAN) continuando a usar-se a porta 22 para o lado cliente (caso o suporte synology o exija):


 





 


 


 


Depois do servidor iniciado no PC, mais um teste à porta 22 com o yougetsignal e, voilá:


 





 


EDIT2: Tambem testei a ligação por 4G com o meu smartphone e um cliente SSH Android, à porta 22, com sucessso!


 


 


Não se esqueça de voltar a ligar a firewall...


 


Cumps
Reputação 5
Olá @@@Banimale 


 


Há novidades em relação ao serviço SSH no firmware 10.2.1.L


 


Se tiver ou mais alguém, consultando este tópico, tiver problemas em clientes ou servidores SSH, com o firmware 10.2.1.L, não hesitem em consultar também este tópico, que contem mais uma solução:


 


http://forum.meo.pt/t5/Equipamentos-Internet/porta-ssh-22-outbound-bloqueada/td-p/59536


 


 
Eu estou com um problema semelhante. Tenho o servidor de VPN instalado no Synology, tenho portforward devidamente configurado no 784n v3 para OpenVPN e para IPSec, mas por mais que tente, não consigo ligar-me externamente ao Synology.


 


O mesmo acontece com o servidor de SSH. E aqui acontece o mesmo que já foi relatado aqui: se me tentar ligar dentro da rede, tudo funciona, mas se tentar ligar-me a partir do exterior, já não funciona. Ah e para não correr o risco de conflito de portas, o port forward está configurado de forma a que o acesso externo fique pendurado numa porta com um número alto (e que não é, obviamente, 22).


 


Alguma dica sobre o que fazer para por este cenário a funcionar?
Tenho o mesmo problema.

Tentei criar uma VPN com OpenVPN que usa a porta UDP 1194 e o router teimosamente dá "Port closed" no http://www.yougetsignal.com/tools/open-ports/

Já tentei os comandos:

connection bind application=CONE(UDP) port=1194

saveall

 

comforme vi referido em alguns foruns e sem sucesso.

Acedo bem ao dispositivo via SHH mapeado na Firewall através da rede interna, mas através do IP público nada.

Parece mesmo que há qualquer coisa com este router/firmware que não permite fazer aquilo que é suposto ou pelo menos anunciado.

O que preciso de fazer para poder usar o equipamento e serviço ?

Não sei a versão do firmware, mas como parece que eles se auto-actualizam , deverá ser a mais recente.

Já tinha feito isto anteriormente, há largos meses atrás, com sucesso...

Liguei bem a uma VPN PPTP implementada num PC windows e de fora(3G) liguei com sucesso à mesmo

 

Agradeço uma explicação esclarecedora do que se passa...porque parece que os utilizadores que aqui se queixam são utilizadores com conhecimentos avançados de rede IP e não estão a conseguir fazer o que é suposto.

 

Agradeço antecipadamente

GPeCurto

 
Boas @@gpecurto


 


Vê se isto ajuda.
http://npr.me.uk/vpnissue.html#vpnpptp
http://npr.me.uk/vpnissue.html
Ola


 


Sei que é um pouco offtopic, mas tou com um problema que se está a tornar sério no cafe dos meus pais, temos um grupo relativamente grande de malta jovem e abusam da liberdade com a aplicação Meo remote, nas duas boxes que temos em salas diferentes e ninguem se entende.


 


Já pesquisei o problema durante varias horas e tentei resolver o problema de algumas maneiras mas sem sucesso e antes de ter de ir comprar um router novo questiono-me se nao haverá maneira de fechar os portos ou impedir que alguns IP's detectem ou comuniquem com as boxes e utilizem o meo remote.


 


A situcão está realmente a incomodar e a provocar desentendimentos, perda de clientela etc 😞
Reputação 1
? Boas Romeu. No teu caso eu faria o seguinte. Deixar o Technicolor para vocês, trocares o nome da rede, password e ficaram apenas vocês com ela e com acesso ao Meo remote. E ao Technicolor ligar por exemplo um 841N(atualizando ao último firmware que os primeiros trazem bugs) na gama de ip 192.168.2.1 com dhcp ativo e colocares o nome da rede do antigo Technicolor e a pass que o Technicolor tinha. Assim nem os clientes se apercebem da mudança e ficaram a usar uma gama de ip separada da tua.
Olá,
desculpem o desenterranço. O FreeSSHd permite reabrir o telnet para aceder ao router. O meu router tem novo firmware vem com o telnet bloqueado.

Responder