Connection Reset by Peer em vários sites


Boas,

há vários sites que tenho dificuldades em aceder por obter erro "Connection reset by peer" e a conclusão que chego é que o problema está do lado da meo.

Exemplos:

https://xkcd.com/

https://humblebundle.imgix.net (este é uma cdn que faz host de imagens para o Humble Bundle)

 

Sintomas:

a tentar aceder a urls destes dominions tenho o erro "Connection Reset by peer", mas se insistir e fizer refresh muitas vezes, eventualmente funciona.

 

Porque acho que o problema é do lado da Meo:

  1. Apesar de tester este problemas com mais sites, estes dois exemplos são sites bastante sólidos e não vão assim abaixo a toda a hora (como as páginas de suporte da meo sugeririam)
  2. Tenho este problema em 3 dispositivos com 3 diferentes OS e browsers.
  3. Quando ligo a VPN do trabalho deixo de ter problemas
  4. Já tentei mudar/desligar os DNS da google/cloudfare que normalmente uso, limpar cookes, cache, etc, browsers diferentes e reiniciar o router.
Tech Debug:

 

 

code:
traceroute: Warning: xkcd.com has multiple addresses; using 151.101.192.67
traceroute to xkcd.com (151.101.192.67), 64 hops max, 52 byte packets
1 dsldevice (192.168.1.254) 2.268 ms 1.195 ms 1.137 ms
2 10.244.0.1 (10.244.0.1) 13.750 ms 7.661 ms 12.973 ms
3 telepac14-hsi.cprm.net (195.8.30.242) 3.734 ms 3.755 ms 3.689 ms
4 lis1-cr1-bu10-200.cprm.net (195.8.30.237) 7.814 ms
lis2-cr1-bu10-200.cprm.net (195.8.30.241) 6.014 ms 3.850 ms
5 lon3-cr1-be4.cprm.net (195.8.1.46) 34.739 ms 34.224 ms
lon3-cr1-be3.cprm.net (195.8.1.6) 35.340 ms
6 ae-11.r24.londen12.uk.bb.gin.ntt.net (195.66.224.138) 32.458 ms 32.567 ms 34.779 ms
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *
31 * * *
32 * * *
33 * * *
34 * * *
35 * * *
36 * * *
37 * * *
38 * * *
39 * * *
40 * * *
41 * * *
42 * * *
43 * * *
44 * * *
45 * * *
46 * * *
47 * * *
48 * * *
49 * * *
50 * * *
51 * * *
52 * * *
53 * * *
54 * * *
55 * * *
56 * * *
57 * * *
58 * * *
59 * * *
60 * * *
61 * * *
62 * * *
63 * * *
64 * * *
Repare-se nos tempos altos e os saltos marcados com * * * demoraram muito tempo.



 

Existe mais alguém com este tipo de problema e existe solução?

 

1 resposta

Confirmo. Acontece-me uns 90% das vezes com o xkcd.com e uns 50% com o julialang.org (e está a acontecer agora, primeira vez, com o www.researchgate.net).

Isto é algo que já me acontece há anos! Mas a mim costuma resultar mudar o DNS para a Google por exemplo... (IPv4 e v6).

Responder