Como restaurar acessos RootUser e permissões num router TG784n (10.2.1.L)

  • 20 Março 2015
  • 302 respostas
  • 60560 visualizações


Mostrar a primeira mensagem

302 respostas

Reputação 5
MiguelLima escreveu:

No meu cavo será desligar o cabo ADSL certo? Tenho ADSL.. Não fibra.. Fogo é q apenas quero da prioridade ao meu IP local do PC lol


 


 


EDIT: segui todos os passos e parecia estar tudo a correr bem, mas quando cheguei à parte de introduzir isto na consola


 


code:
var user = "nauser";
var hash2 = "f8700f3bb4e73cc4bb5229def20ce0d0";
var HA2 = MD5("GET" + ":" + uri);
document.getElementById("user").value = user;
document.getElementById("hidepw").value = MD5(hash2 + ":" + nonce +":" + "00000001" + ":" + "xyz" + ":" + qop + ":" + HA2);
document.authform.submit(); 

 


deu um erro: Uncaught ReferenceError: MD5 is not defined(…)



 


Isso parece-me ser um problema da consola do browser, experimente com outro.


 


Eu já disse "cabo"da WAN apenas e não cabo ethernet para não distinguir casos. Logicamente que sim, no caso do ADSL, o cabo telefónico, ou seja o acesso à WAN.


 


Atentamente,
Vou experimentar essa ferramenta. Mas como sei se o meu tg784n é v3 ou nao? tenho o firmware 10.2.1.L e no software tenho de escolher entre:


MEO: TG784n:     Rev. 10.2.1.L


MEO: TG784n v3: Rev. 10.2.1.L


 
No meu cavo será desligar o cabo ADSL certo? Tenho ADSL.. Não fibra.. Fogo é q apenas quero da prioridade ao meu IP local do PC lol


 


 


EDIT: segui todos os passos e parecia estar tudo a correr bem, mas quando cheguei à parte de introduzir isto na consola


 


code:
var user = "nauser";
var hash2 = "f8700f3bb4e73cc4bb5229def20ce0d0";
var HA2 = MD5("GET" + ":" + uri);
document.getElementById("user").value = user;
document.getElementById("hidepw").value = MD5(hash2 + ":" + nonce +":" + "00000001" + ":" + "xyz" + ":" + qop + ":" + HA2);
document.authform.submit(); 

 


deu um erro: Uncaught ReferenceError: MD5 is not defined(…)
Reputação 5
?


 


Existe uma ferramenta que o pode ajudar e que não está mencionada no post inicial, por ser da autoria do ?. Se lesse o tópico todo, certamente já a teria encontrado aqui: http://forum.meo.pt/t5/Equipamentos-Internet/Como-restaurar-acessos-RootUser-e-permiss%C3%B5es-num-router-TG784n/m-p/79329/highlight/true#M17041


 


Eu só me lembrei dela agora, peço desculpa.


Boa sorte.


 


Atentamente,


 
Reputação 5
?


 


Tente de novo o reset. O firmware 10.2.1.D tinha um bug que provocava por vezes a falha no processo de reposição de configurações, dando a falsa sensação de o ter completado, que penso continuar no 10.2.1.L. Faça mais tentativas deste tutorial. Penso que existe um timing para desligar o cabo da WAN do router MEO. não deve desligar antes, nem depois. Aconselho-o, antes de mais, a ler o tópico na integra.


 


Atentamente,
Quando tento fazer o comando, após desligar o router da net e fazer reset:


 


code:
system ra instadd name=remoteaccess

 


Tenho como resposta "command not allowed". Tudo o que quero fazer é conseguir configurar o IPQoS para dar prioridade ao IP local do meu portatil... E não tenho forma de o fazer. Sempre "command not allowed".  


 


PS: tenho o THOMSON TG784n versao de firmware 10.2.1.L


 


sugestoes? 
Confirmo o que o amigo do comentário anterior com um belo username disse, também me dá user e pass errados nesse passo com um TG784n v1 (firmware 10.2.1.L)

Edit:
De facto a password parece ser outra para o v1. Após uma pesquisa rápida descobri a hash correcta.
Deixem o user: nauser
Hash da pw: f8700f3bb4e73cc4bb5229def20ce0d0
Boa noite.

O myRoot ainda funciona para TG784n 10.2.1.L?

Tentei agora e chega à parte em que aparece o formulário para fazer login, ele mete o user nauser mas depois aparece a dizer que o user e pass são errados.

Na janela de cima fica assim: 

http://i.imgur.com/RYZYuXK.png

 

Parece que a hash da pass do user nauser está errada.
Reputação 2
Crachá +5
WizardOZ escreveu:

Problema resolvido!
Depois de reler este tópico verifiquei que o problema já tinha sido identificado anteriormente.
Não podemos seleccionar a opção "desactivar actualizações" no myRoot.
Depois do ter acesso a um utilizador com root podemos abrir o acesso remoto ou a partir da interface web ou por telnet "system ra instadd remoteaccess" e configurar.

Por incrível que pareça o meu VOIP ficou a funcionar automaticamente.


 



Não tens de que :P;)
Problema resolvido!
Depois de reler este tópico verifiquei que o problema já tinha sido identificado anteriormente.
Não podemos seleccionar a opção "desactivar actualizações" no myRoot.
Depois do ter acesso a um utilizador com root podemos abrir o acesso remoto ou a partir da interface web ou por telnet "system ra instadd remoteaccess" e configurar.

Por incrível que pareça o meu VOIP ficou a funcionar automaticamente.


 
Estou cansado de ligar para a MEO para me reporem a configuração do VOIP mas dizem sempre que não conseguem aceder ao router.


Tenho um Asus n66u ligado ao ONT e o technicolor ligado ao Asus porta 4 (vlan).


Tenho Internet nos dois, a meobox funciona em ambos, os telefones é que nickles!!!


O IP público parece ser diferente de ambos, mas não há maneira de conseguir aceder ao router da MEO por fora, mesmo quando ligo o router directamente ao ONT!!!


quando coloco


code:
http://proxy.piratenpartij.nl/TEU.ENDEREÇO.IP.INTERNET:1234/remote_admin.lp

nunca chego ao destino!!! nunca chego a ver a página. 


 


talvez o problema resida no processo.


Utilizei o myRoot (fantástico) para me criar um utilizar com permissões de root user, no entanto, nunca activei a opção de desabilitar o acesso remoto da assistencia.


 


Curioso é que quando o router da MEO está ligado ao Asus e tenho o endereço a partir de um computador ligado ao Asus até consigo aceder, mas penso que isso será batota!!! nesse momento consigo entrar com o nauser.


 


Outra coisa que constatei é que frequentemente deixo de ter o remoteaccess


quando faço system ra list não tenho nada!


por isso, volto a criar e configurar um novo remoteaccess... mas nem assim!!


 


 


Alguém me pode indicar uma direcção para este problema?
Estive a experimentar o programa no router versão anterior e dá erro :


 


"Service Unavailable


The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later."


 


Não sei a que se deve isto mas para mim é um basta. Ontém era-me impossível fazer o que quer que fosse na internet. Não pago 65€ pelo triple play por mês para ter este serviço de trampa. Como se não bastasse isso ainda me bloqueiam o acesso root. Ainda esta semana mudo de operador.


 


Obrigado pela ajuda
Reputação 7
Crachá +19
boas


 


provavelmente um router recondicionado...eu pedia a troca...
o router foi substituído há uns 3 meses porque o anterior avariou e nem se derem ao trabalho de ao menos colocar um novo...


assim sendo vou testar o programa
Reputação 7
Crachá +19
boas


 


a troca de router exige que um tecnico vá a residencia...um TG784...é antigo e provavelmente não estara na melhores condições...esta ligado 24x7 e nada dura para sempre...
Reputação 5
O programa funciona para o TG784 independentemente do modelo. (penso eu de que...)


 


Podes sempre optar por fazer esse processo manualmente, para isso mesmo é que este tópico foi feito, e aí terás a certeza que ficará a funcionar corretamente.
e a meo troca o router? é que é impossivel esta net assim. Antes de atualizarem o router eu ainda conseguia gerir isto mais ou menos, agora tenho um serviço que pago cheios de limitações.


 


o contrato de fidelização já acabou há uns meses, só estou à espera que ponham fibra à porta para mudar para o distribuidor da mesma. Há meses que estou a pagar bem mais do que devia por 24mb de net quando nem 8mb recebo, e tudo o que implique nova fidelização está posto de parte. Provavelmente para me mudarem de router vão querer já nova fidelização.


 


Até podia testar a ver se o programa funciona. O problema é que correndo mal depois teria de estar uns dias à espera dum aparelho novo, e como não vivo sozinho e há mais pessoas tv/internetdependentes não queria estar a deixá-los sem o serviço
Agora a meo já corrigui o bug do utilizador 😞
Reputação 7
Crachá +19
boas


 


@vitorugo_8 com esse router fica dificil seja o que for...pede para trocar o router pois esta completamente desactualizado...
Alguém sabe se este método funciona num Thomson TG799vn ?

Obrigado.

 

Dark
@@vitorugo_8 podes sempre arriscar e testar, se esse router não tiver sido comprado por ti, pertence à meo e tem garantia.
será que a aplicação myroot funciona com o modelo do meu router?
Também eu sofro com este bloqueio ridiculo da meo. Tinha a PS4 em DMZ para jogar à vontade sem lags nem bloqueios de portas etc, mas desde que me atualizaram o software do router que não consigo aceder a essa opção e jogar PS4 tornou-se impossível.


 


Tenho ADSL, o router é o TG784, com o malfadado 10.2.1.L. Neste tópico só tenho encontrado referências à fibra e à versão TG784n ou v3 do router. Há alguma solução para quem ainda possui este router?





 
 







 
 
Cumprimentos a todos e parabéns pelo forum. Já andava a investigar este tema há algum tempo e só ontem vos encontrei. Antes tarde que nunca!! ;)

 

Parabéns ? pela investigação e parabéns ? pela aplicação.

 

Tenho um Thomson TG784n que foi atualizado há pouco tempo para o firmware 10.2.1.L e me impediu de gerir a MINHA rede da forma que pretendo. ABAIXO A DITADURA! VIVA A LIBERDADE!

 

Estive a ler atentamente as instruções de utilização da tua ferramenta myRooT e fiquei com duas dúvidas:

. já não é necessário desligar fisicamente o cabo de internet WAN?

. os procedimentos podem ser efetuados por Wi-Fi?

 

É que tenho o router instalado numa ATI no sotão, com Wi-Fi amplificado pela casa, pelo que só me ligo dessa forma; para ligar por cabo terei que desarrumar muita tralha.

 

Cumprimentos.

 

 
Qual é o processo para o TG787 SIP (10.2.1.L) ?

tudo funciona ate chegar ao ponto


code:
var user = "nauser";
var hash2 = "d3eff9622e6e8efe7d8c059c596f075f";
var HA2 = MD5("GET" + ":" + uri);
document.getElementById("user").value = user;
document.getElementById("hidepw").value = MD5(hash2 + ":" + nonce +":" + "00000001" + ":" + "xyz" + ":" + qop + ":" + HA2);
document.authform.submit(); 
, qual seria a hash2 do TG787 ?

Responder