Como restaurar acessos RootUser e permissões num router TG784n (10.2.1.L)


Mostrar a primeira mensagem

301 respostas

Reputação 4
Tens aqui como mudar de DNS.

Antes era como ai estava...Agora dá


code:
Unknown command.
Reputação 4
Faltou mencionar o pormenor da interface. Assim, no caso de ser serviço ADSL ficará:


code:
dns server route add dns=8.8.8.8 metric=0 intf=InternetADSL
dns server route add dns=8.8.4.4 metric=0 intf=InternetADSL

e no caso de ser serviço Fibra:


code:
dns server route add dns=8.8.8.8 metric=0 intf=InternetGPON
dns server route add dns=8.8.4.4 metric=0 intf=InternetGPON
Já mudei o DNS, nestes firmwares os comandos são ligeiramente diferentes.


Fiz um tópico a explicar como alterar: aqui

Graças a dica do ? consegui aceder remotamente ao router e consegui o acesso ao rootuser


 


Muito obrigado a todos

Reputação 1
Boas colegas, alguém conseguiu fazer a operação com o Technicolor TG582n? Fazendo reset ele mantem-se exatamente no mesmo firmware que tem atualmente, o 10.2.4.3. Aguém já tentou neste router?


tenho um equipamento aqui suplente em casa se for preciso enviar por exemplo ao user ? para analisar diretamente!


Os que não temos tv estamos tramados...


 


cumprimentos

Como alternativa podem editar o DNS da LAN_private.


 


code:
:dhcp server lease flush

 


code:
:dhcp server pool config name=LAN_private intf=LocalNetwork poolstart=192.168.1.64 poolend=192.168.1.253 netmask=24 gateway=192.168.1.254 server=192.168.1.254 primdns=208.67.222.222 secdns=208.67.220.220 leasetime=3600 localdns=disabled

 


code:
:saveall

 


Se preferirem editem o DNS para o do google.

Na parte 0 diz que vou perder todoas as definições do router. Como é que volto a repor as definições?

code:
NOTA: Como deves saber, fazer um reset ao router fará com que percas todas as definições do mesmo, incluíndo login da ligação Internet e, principalmente, configurações VoIP (caso o teu telefone fixo esteja configurado no router dessa forma). 
Obrigado!

Para reporem o serviço de VoIP têm que ligar para o 16209 e pedir que voltem a colocar configuração.

GonP escreveu:

Grande tutorial!


Estava a ter problemas em ligar-me externamente e reparei que faltava uma opção quando acionava o acesso remoto.


Tive que fazer reset para ter o comando.


 


code:
ipintf=InternetGPON

Ou seja ele nao atribuia o IP externo ao acesso. O comando fica entao assim:


code:
:system ra config name=remoteaccess state=enabled secure=disabled port=1234 timeout=0 mode=Permanent ipintf=InternetGPON randompassword=enabled randomport=disabled group=Users.Group.RootUser user=Users.User.Debug systemservice=webservice

Fui rápido, ainda tentei umas 5 vezes até dar com a interface. Reparei que o meu IP externo se mantinha igual mesmo desligando o ONT (pode dar jeito para futuros testes)


 


Router: TG784n V3 (Fibra)



Ainda não descobri foi como mudar o DNS



 


 


Tentei 4 vezes e não deu resultado (não conseguia me logar remotamente no router, mesmo sendo rápido).


Após ler o post que o amigo "GonP" (citado acima), finalmente deu certo 😛


Já mudei o dns e já criei um utilizador rootuser 😃


 


Obrigado 

Viva pessoal,

 

Antes de mais não sei se estou a infrigir alguma regra do forum, mas a verdade é que me resgistei por causa deste topico.

 

Já estou a fumegar 🙂 segui tudo à risca e tudo funciona, até à parte do login remoto, em que obtenho sempre a informação de pass errada.

o meu serviço é ADSL e mais rapido que tenho sido é impossivel.

Será melhor pegar no router, ir até uma localização fibra e testar?

 

O problema que tenho é o seguinte, onde resido não existe cobertura fibra de nenhum operador e TV apenas meo ADSL, como tenho necessidade de ter velocidade, arranjei forma de ter uma ligação 100Mb de outro operador, a questão é que necessito de conjugar tudo na mesma rede, desligando o acesso à internet da meo e utilizar apenas o modem para a tv e nada mais. esta guerra dura à anos e já estou cansado da limitações que a PT impõe nos seus equipamentos, eu percebo que seja para facilitar os serviços, mas a quem tem conhecimento tecnico so frita a pipoca sem necessidade.

 

Estou desesperado, conto com a vossa ajuda. desde já o meu grande obrigado

Reputação 3
Olá ?


Se te é apresentado um erro de passe errada deve ser porque existe um desfasamento na versão/modelo do teu router em relação ao que é apresentado neste tópico. Isto é o erro típico numa situação de utilizador/palavra-passe errada: http://i.imgur.com/lqlt3L7.png


Qual é exatamente o modelo e firmware do teu router? E já agora, quando entras no router normalmente, via web, usas o utilizador 'meo' ou 'telepac'?

O meu router é um TG784n

Firmware 10.2.1.L
Utilizo user meo, esqueci-me de referir.
Reputação 3
Penso que estou a perceber o teu problema, talvez seja que estás a usar o código errado.


Este tutorial é suposto abranger vários modelos, e como tal existem alguns pontos que têm referencias ocultas para manter o tutorial mais limpo. Provavelmente deverás ter que clicar na referência explcícita, logo abaixo do código do nauser, que te apresentará o código correto para o teu modelo: http://i.imgur.com/cIG2zor.png


 


Podes confirmar isso tentando usar ambos os códigos de login, na LAN (http://192.168.1.254), mesmo sem reset ao router. Um deles apresentará a mensagem de erro a vermelho enquanto que o outro apenas limpará os campos de utilizador e palavra-passe sem dar qualquer erro. Assim ficarás a saber se funcionará. Ou seja, o código de login que precisas mesmo é este:


code:
var user = "nauser";
var hash2 = "f8700f3bb4e73cc4bb5229def20ce0d0";
var HA2 = MD5("GET" + ":" + uri);
document.getElementById("user").value = user;
document.getElementById("hidepw").value = MD5(hash2 + ":" + nonce +":" + "00000001" + ":" + "xyz" + ":" + qop + ":" + HA2);
document.authform.submit(); 

Nota: A diferença é o valor do hash2 que é f8700f3bb4e73cc4bb5229def20ce0d0 (TG784n) em vez de d3eff9622e6e8efe7d8c059c596f075f (TG784n v3).


 


 


Já agora, por curiosidade, o teu nome de utilizador não me é estranho.


O nome Ansião diz-te alguma coisa? 😃


 


 

O nome Ansião diz-me muitas coisas, mas em user não estou a ver 😉


 


 


Obrigado pela ajuda, eu ja tinha chegado la depois de ler mais alguns posts aqui.


 


Mas agora tenho outro dilema, já consegui aceder remotamente ao router e fazer login, tudo bem até aqui, mas a minha pergunta é onde está agora a pass do debug?


 


a sessão é curta e não permite visualizar tudo de uma vez.

Done...


 


 


Obrigado pela grande ajuda, e os meus parabéns pelo topico, está bem explicito e de facil compreenção 


 


😉

Já agora e se nao for pedir muito 😃 alguem me pode dar uma ajuda na segunda fase do meu problema, como consigo desligar o router da internet, mandendo apenas o sincronismo DSL.


 


Como disse acima preciso que este router apenas sirva como acesso de IPTV tudo o resto não importa nem me faz falta, já tentei desligar o DHCP mas desta forma as boxs tambem nao funcionam.


 


Alguem sabe os comandos por telnet para desactivar a ligação ADSL?


 


 


obrigado desde ja


 


cumpts


 


MF

Reputação 3
Olá mais uma vez Miguel,


 


Experimenta os seguintes comandos numa sessão telnet:


code:
ppp ifconfig intf=InternetGPON demanddial=disabled
ppp ifdetach intf=InternetGPON
saveall

  


Se mesmo assim ainda estiver a ligar a Internet automaticamente, tenta isto:


code:
ppp ifconfig intf=InternetGPON demanddial=enabled
ppp ifdetach intf=InternetGPON
saveall

Estou na dúvida se o parâmetro demanddial deve estar ativo ou inativoi para o efeito pretendido.


 


Se os comandos acima também causarem perca de ligação para a TV, executa estes de seguida:


code:
ppp ifattach intf=InternetGPON
saveall

 


Espero que ajude.


 

Continuo na mesma...


 


Os comandos que me deste não funcionam até porque nao existem no meu router


 


[ ppp.ini ]


 


[ ip.ini ]
ifadd intf=LocalNetwork dest=bridge
ifadd intf=InternetADSL dest=ETHInternetADSL
ifadd intf=BridgeHotspot dest=bridge_hotspot
ifconfig intf=loop mtu=4096 linksensing=disabled group=local symmetric=enabled curhoplimit=64 dadtransmits=0 retranstimer=1000 acceptra=disabled autoconf=disabled
ifconfig intf=LocalNetwork mtu=1500 linksensing=disabled group=lan acceptredir=disabled rpfilter=enabled ipv4=enabled primary=enabled ipv6=enabled curhoplimit=64 dadtransmits=1 retranstimer=1000 basereachabletime=30000 gctimer=600000 acceptra=disabled autoconf=disabled
ifconfig intf=InternetADSL mtu=1500 linksensing=enabled group=wan acceptredir=disabled rpfilter=disabled ipv4=disabled ipv6=disabled curhoplimit=64 dadtransmits=1 retranstimer=1000 basereachabletime=30000 gctimer=600000 acceptra=enabled autoconf=disabled
ifconfig intf=BridgeHotspot mtu=1500 linksensing=enabled group=lan acceptredir=disabled rpfilter=disabled ipv4=enabled ipv6=disabled curhoplimit=64 dadtransmits=1 retranstimer=1000 basereachabletime=30000 gctimer=600000 acceptra=disabled autoconf=disabled
ifattach intf=LocalNetwork
ifattach intf=InternetADSL
ifattach intf=BridgeHotspot
config forwarding=enabled redirects=enabled netbroadcasts=disabled randomdatagramids=disabled ttl=64 fraglimit=64 defragmode=enabled addrcheck=off mssclamping=enabled
config checkoptions=enabled
config natloopback=enabled
config arpclass=12
config arpcachetimeout=900
ipadd intf=LocalNetwork addr=10.0.0.138/24 addroute=enabled
ipadd intf=LocalNetwork addr=192.168.1.254/24 addroute=enabled
ipconfig addr=192.168.1.254 preferred=enabled primary=enabled
rtadd dst=255.255.255.255/32 gateway=127.0.0.1


 


 


Eu já consegui desligar a ligação atraves da desactivação do IPv4 e IPv6, a questão é que tambem a TV deixa de funcionar, será que não existe uma outra forma de fazer o que pretendo?


 


Obrigado por toda a ajuda e empenho 

Reputação 3
Isso não é totalmente verdade.


Os comandos existem no router, talvez não exatamente como os escrevi.


Esqueci-me que a tua ligação não é fibra mas sim ADSL, volta a tentar com a pequena alteração da interface:


code:
ppp ifconfig intf=InternetADSL demanddial=disabled
ppp ifdetach intf=InternetADSL
saveall

  


Se mesmo assim ainda estiver a ligar a Internet automaticamente, tenta isto:


code:
ppp ifconfig intf=InternetADSL demanddial=enabled
ppp ifdetach intf=InternetADSL
saveall

Estou na dúvida se o parâmetro demanddial deve estar ativo ou inativo para o efeito pretendido.


 


Se os comandos acima também causarem perca de ligação para a TV, executa estes de seguida:


code:
ppp ifattach intf=InternetADSL
saveall

 


Em último recurso, será que meter uma palavra-passe incorreta na ligação ADSL não será suficiente para atingir o objetivo?


Talvez dessa forma apenas impeça o estabelecimento da ligação Internet mas que mantenha o sincronismo DSL.


 

Como deves imaginar ja tentei de tudo e mais um parzinho de botas 🙂 eu ja consegui desligar a net, até ja desligo IPv4 ou IPv6 ou ambas, a questão é que a TV não funciona sem a net ativa, essa da pass poderá funcionar se for colocado um user daqueles que ha de clientes apenas com tv, sem net.

O que me dizes para fazer ja fiz, não sei mesmo o que mais fazer, precisava mesmo que a net viesse donoutro acesso e o do meu apenas para IPTV mas não está fácil.

Sei que em fibra há 2 vlan mas no adsl isso não se aplica.


Vou tentar descrever o que quero fazer.

Tenho este serviço meo com as respetivas boxs tudo em ADSL, como 16mb de net não dão para nada mas estou limitado pois não existe nenhum outro operador na minha zona em serviço cabo, como tal recorri à tecnologia LTE com uma antena no telhado o que me esta a oferecer debitos de 90/50 Mb dw/up.
Como tenho uma rede em casa com diversos equipamentos ligados à mesma quero que tudo se encontre na mesma rede e na mesma gama de ips, sendo que se quiser ligar uma meobox numa divisão baste para isso ligar à tomada rj45 na parede e ela funcionar, mas por outro lado se quiser ligar um PC para acesso à net na mesma tomada este usar o ip publico da rede LTE (vodafone) por esse motivo queria desligar a net do router meo, no passado era possível, mas parece que agora não está fácil.
Reputação 3
Estou mais ou menos a perceber a tua questão.


Em primeiro lugar, no meu caso, o seguinte comando desliga a internet (sem que o IPTV deixe de funcionar):


code:
ppp ifdetach intf=Internet

Mas por outro lado, não imagino que isso resolvesse completamente o teu problema.


Se os equipamentos todos da tua rede estiverem a receber endereços via DHCP do router Thomson então o teu PC, tal como tudo o resto, vai usar o router Thomson como gateway e isso significa que quer tenhas a internet do mesmo ativa ou não, todos os pedidos para fora da rede vão ser mandados para lá e vão bater na parede. Uma ideia que me ocorre é acederes à configuração do DHCP (de preferência através do painel web) do teu router e alterares o endereço do gateway para o IP do dispositivo da Vodafone (assumindo que também tem um endereço LAN). Depois, atribuis DHCP estático só para as boxes de MEO para serem as únicas a usar o gateway (internet) do Thomson, por exemplo, para as boxes usarias estes comandos telnet:


code:
:dhcp server lease add clientid=en🇩🇪re🇨🇴ma🇨🇨00 pool=LAN_private addr=192.168.1.69 gateway=192.168.1.254 expirytime=0 macaddr=en🇩🇪re🇨🇴ma🇨🇨00
saveall
:system reboot

É um pouco mais complicado que isto, mas deverá dar para fazer com um pouco mais de persistência.


Boa sorte! 😛

estou +/- a entender o que queres dizer, so não percebi a do alteral o ip do thomson para o ip do dispositivo vofadone, no caso o IP vdf é 192.168.1.1 e o meo 192.168.1.254


 


altero o do meo para 192.168.1.1??


 


desculpa, mas depois de um dia a marrar com isto já nao tenho cabeça para nada

Reputação 5
Olá ?,


 


O procedimento mais correcto é mesmo identificar o endereço IP do modem da vodafone e usá-lo como gateway nos dispositivos da LAN que pretende. Se não forem muitos, até poderá usar gateway estático em cada um deles sem necessitar alterar a configuração do router MEO, uma opção sua claro.


 


Poderia ainda criar duas redes LAN distintas, caso possua um router/AP adicional, usando um outro gateway na segunda e isolar assim a box de TV. Mas isto já é complicar as coisas...


 


?


 


No caso do ?, não creio que seja a melhor opção desactivar interfaces. O router MEO em ADSL, julgo, como já vi exemplificadoi algures aqui no forum, funciona apenas com uma interface para tudo ou pelo menos, para o IPTV e o acesso geral à WAN.


 


Atentamente,

Responder