Resolvido

Cisco 877 substituir o TG784

  • 2 Maio 2016
  • 9 respostas
  • 3518 visualizações

Reputação 1
Crachá +4
Boas. Tenho em casa um já velhinho Cisco 877. Aqui hà tempos (alguns "aninhos") andei a ver se o ponha  a substituir o thomson, o que parcialmente consegui sendo que nunca consegui resolver os "freezes" da imagem nas stb (10sec de imagem; freeze, mudava de canal e voltava a dar e novo freeze), penso que teria alguma coisa a havel com o IGMP e em particular com a versão do IOS!?


Como tinha acesso root ao TG (na altura fw 10.2.1D - acesso dual - meo cobre), optei por deixar o acesso wan e as stb's com o tg e a restante rede com o cisco e um DHCP/DOMAIN/APP/FILE/VPN server numa rede classe B (o acesso não era feito por modo bridge, mas por roteamento entre as duas redes a de casa e a da meo). Não que necessita-se disto, foi apenas por gozo, e neste momento já há algum tempo que não está assim, tenho tudo ligado no TG e o servidor está desligado.


O que pretendia agora, depois destes anos era substituir o TG784nV3 (k muitos criticam, mas que acho um equipamento qualidade/preço excelente e com muitas potencialidades) pelo cisco 877. tenho acesso root ao TG (graças a vocês), ligação IPoE (single edge - acesso meo cobre).


Será que alguém já fez algo assim com router cisco ou me poderia ajudar a dar utilidade ao 877? Obrigado 😃
icon

Solução por marco75 22 Maio 2017, 11:43

Boas. se o ios do 857 suportar os comandos e só copiar e colar os que postei para o 877. funciona na perfeição. o que te está a acontecer é que tens problemas com trafego multicast. Por isso as gravações e os 8-10 segundos iniciais do canal funcionam, pk qq um deles é unicast. quando passa para tráfego multicast "freeza". copia e cola a config que postei acima (com os teus dados claro, tenta também clonar o mac da tua HGW).


multilink bundle-name authenticated - global config mode


ip pim sparse-dense-mode - na config sub-intf ATM0.1

ip pim sparse-dense-mode
ip igmp helper-address [ip do gateway da ATM0.1] - ambos na config da intf vlan que está associada à vlan da bridge (portas fe0-3)

Ver original

9 respostas

Reputação 1
Crachá +4
A capacidade do processamento do 877 é baixa, daí os freezes nas stb's. No entanto, com com a nova arquitectura single edge e com apenas um PVC 1/35 com encapsulamento LLC (segundo o intf atm_1_35 do tg784nv3, mas segundo leitura k ando a fazer, parece encapsulamento aal5!?), ando um bocado ás aranhas. Nem sei se o IOS 124.4-T5 suporta o IPoE (RFC 1483/2684). Alguém dá uma ajuda?
Reputação 6
Boas ?
Para o serviço de IPTV basta que o router seja compatível com o serviço de IGMP v3 e ter o IGMP Proxy ligado no router.
Reputação 1
Crachá +4
Boas, ?.


Pelo que tenho andado a ver no TG, a nível de LAN usa IGMPv3, mas parece-me que para a WAN usa v2. tenho tentado várias configs, e numa delas consigo ter IPTV nas stb, mas com paragens após 10seg ( mudo de canal e mais 10 seg de stream até que... nova paragem). A stb (scientific atlanta actualiza hora!).


Outro facto curioso tem a ver com a net, recebo uma rota estática !? default que aponta para o ip da WAN (recebida por dhcp na ATM 0.1), e uma outra estática para a rede 10.**bleep**.**bleep**.**bleep**/32 com next-hop o ip da  ATM0.1. Se nao colocar nenhuma rota default  (ip route 0.0.0.0 0.0.0.0 ATM0.1) na config, tenho acesso à net de dentro do router (pingo 8.8.8.8, http://www.google.pt, http://www.sapo.pt), mas dos pcs da lan nada (sem acesso à net). Colocando a rota default o router tb deixa de pingar os referidos endereços. tou a fazer nat com acl e tb tentei com route-map (ambas com NAPT/overload), mas nada. Não tou a usar Bridge na lan (BVI), mas sim e só VLAN.


Mais alguma ideia/opinião. Obrigado.


Abaixo envio config usada, penso que foi a que melhores resultados me deu (tou a usar ios 12.4(24)T5)...


no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname IPTV3b
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.63
!
ip dhcp pool lan
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254
   dns-server 192.168.1.254
   lease 1 0
!
!
!
no ip cef
ip domain name iptv.telecom.pt
ip name-server 212.55.154.174
ip name-server 212.55.154.190
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username XXXXX privilege 15 secret 0 XXXXX
!
!
!
archive
 log config
  hidekeys
!
!
!
!
interface ATM 0
 description >>IPTV-ADSL<<
 mac-address xxxx.xxxx.xxxx
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
 !
!
interface ATM 0.1 point-to-point
 ip address dhcp
 ip pim sparse-mode
 ip igmp proxy-service
 ip igmp version 2
 ip nat outside
 ip virtual-reassembly
 atm route-bridged ip
 pvc 1/35
  protocol ip 255.255.255.255 broadcast
  broadcast
  encapsulation aal5snap
  protocol ip inarp
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip pim dense-mode
 ip virtual-reassembly
 ip nat inside
 ip igmp helper-address udl ATM 0.1
 ip igmp mroute-proxy ATM 0.1
 ip igmp proxy-service
 ip igmp version 3
 ip mroute-cache
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM 0.1
ip http server
ip http authentication local
no ip http secure-server
!
!
ip dns server
!
ip nat inside source route-map internet interface ATM 0.1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
route-map internet permit 10
 match ip address 1
 match interface ATM 0.1
!
!
control-plane
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login local
!
scheduler max-task-time 5000
ntp master
ntp server 213.13.16.231 version 3
Reputação 1
Crachá +4
Boas. esta é a ultima config que usei. Já tentei várias (umas mais simples, outras com as config igmp trocadas entre wan e lan), e sempre com o mesmo resultado:


tenho net a bombar; funcionam apps, gravações locais, gravações auto, mas os streams dos canais são exactamente de 10 segundos e depois fica indisponivel, só mudando de canal e aí são mais 10 seg. Alguém pode dar uma opinião/ajuda?


!
!
interface ATM 0
 description >>IPTV-ADSL<<
 mac-address 0000.0000.0000
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
 !
!
interface ATM 0.1 point-to-point
 mtu 1500
 ip address dhcp
 ip pim sparse-dense-mode
 ip igmp proxy-service
 ip igmp version 2
 ip mroute-cache
 ip nat outside
 ip virtual-reassembly
 atm route-bridged ip
 pvc 1/35
  protocol ip 255.255.255.255 broadcast
  broadcast
  encapsulation aal5snap
  protocol ip inarp
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip igmp mroute-proxy ATM 0.1
 ip igmp proxy-service
 ip igmp version 3
 ip mroute-cache
 ip igmp helper-address udl ATM 0.1
 ip virtual-reassembly
 ip nat inside
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM 0.1 dhcp
ip http server
ip http authentication local
no ip http secure-server
!
!
ip dns server
!
ip nat inside source route-map internet interface ATM 0.1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
route-map internet permit 10
 match ip address 1
 match interface ATM 0.1
!
!
control-plane
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login local
!
scheduler max-task-time 5000
ntp master
ntp server 213.13.16.231 version 3
Reputação 1
Crachá +4
Boas. Finalmente está a funcionar. Compativel com IPOE, config para meo IPTV. Estava a complicar demais a config, afinal revelou-se até bastante simples, mais simples do que quando usava PPPoE. Deixo abaixo para quem quiser usar num cisco. Neste caso usei um 877 com ios 12.4(24)t5:


no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname IPTV_MEO
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.63
!
ip dhcp pool lan
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 192.168.1.254
lease 1 0
!
!
!
no ip cef
ip domain name iptv.telecom.pt
ip name-server 212.55.154.174
ip name-server 212.55.154.190
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username USER privilege 15 secret 0 PASS
!
!
!
archive
log config
hidekeys
!
!
!
!
interface ATM 0
description >>IPTV-ADSL<<
mac-address 0000.0000.0000
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
!
!
interface ATM 0.1 point-to-point
mtu 1500
ip address dhcp
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly
atm route-bridged ip
pvc 1/35
protocol ip 255.255.255.255 broadcast
broadcast
encapsulation aal5snap
protocol ip inarp
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description LAN
ip address 192.168.1.254 255.255.255.0
ip pim sparse-dense-mode
ip igmp helper-address [ip do gateway da ATM0.1]
ip virtual-reassembly
ip nat inside
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM 0.1 dhcp
ip http server
ip http authentication local
no ip http secure-server
!
!
ip dns server
!
ip nat inside source route-map internet interface ATM 0.1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
route-map internet permit 10
match ip address 1
match interface ATM 0.1
!
!
control-plane
!
line con 0
no modem enable
line aux 0
line vty 0 4
login local
!
scheduler max-task-time 5000
ntp master
sntp server 213.13.16.231 version 3
Boas a todos, desde ja peço desculpa por este "desenterro" mas tenho aqui um cisco 857
Com esta configuração tenho tudo a funcionar com excessao da box que encrava mais ou menos de 10 em 10 segundos. As gravaçoes automaticas estao a dar. Desde ja agradeço a config. Alguem conseguiu resolver o problemas da box?
tambem nao consegui configurar os seguintes comandos acho que nao devo tar a coloca los no sitio certo. Isto é essencial para a box bombar?

multilink bundle-name authenticated
ip pim sparse-dense-mode

desde ja agradeço qq opiniao
cumps
Reputação 1
Crachá +4
Boas. se o ios do 857 suportar os comandos e só copiar e colar os que postei para o 877. funciona na perfeição. o que te está a acontecer é que tens problemas com trafego multicast. Por isso as gravações e os 8-10 segundos iniciais do canal funcionam, pk qq um deles é unicast. quando passa para tráfego multicast "freeza". copia e cola a config que postei acima (com os teus dados claro, tenta também clonar o mac da tua HGW).


multilink bundle-name authenticated - global config mode


ip pim sparse-dense-mode - na config sub-intf ATM0.1


 


ip pim sparse-dense-mode
ip igmp helper-address [ip do gateway da ATM0.1] - ambos na config da intf vlan que está associada à vlan da bridge (portas fe0-3)
Boas....desde ja obrigado....é isso, o ios é uma versao security e a versao que está nessa configuração é advipservices, por isso é que os comandos nao entram....o mac e o ip tudo ok....já actualizei para a versao 12.4-15-T17 e está tudo a funcionar. Essa versao 12.4-24-T5 ja nem está disponivel no site do fabricante (possivelmente removida do download por apresentar falhas). Eu até aconselho a usar a 12.4-15-T17 e para quem tiver ram e flash suficiente pode usar a 15.1-4-M10 ambas as versões advipservicesk9....nao usem a versao securityk9 se nao acontece-vos como me aconteceu


cumps
Crachá
Boas,

Alguem them um config a funcionar no 877 com ios 12.4(24)t5 numa porta LAN e nao porta WAN? Meu Thompson 784 esta uma bela posta, e lendo alguns posts na internet vejo que a PT nao so tem accesso ao Router, como a rede interna, que raio de privacidade, ein...

Obrigado.

Responder